aboutsummaryrefslogtreecommitdiff
path: root/textproc/redland/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/redland/Makefile')
-rw-r--r--textproc/redland/Makefile19
1 files changed, 11 insertions, 8 deletions
diff --git a/textproc/redland/Makefile b/textproc/redland/Makefile
index 3d3a5d518a1c..ae006b165210 100644
--- a/textproc/redland/Makefile
+++ b/textproc/redland/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= redland
-PORTVERSION= 0.9.16
-PORTREVISION= 1
+PORTVERSION= 0.9.18
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.redland.opensource.ac.uk/dist/source/
@@ -20,21 +19,25 @@ COMMENT= A high-level interface for RDF
LIB_DEPENDS= db41.1:${PORTSDIR}/databases/db41 \
raptor.2:${PORTSDIR}/textproc/raptor
-USE_GNOME= gnomehack gnometarget pkgconfig
+USE_GNOME= gnomehack gnometarget lthack pkgconfig
USE_OPENSSL= yes
USE_GETOPT_LONG= yes
USE_GMAKE= yes
-GNU_CONFIGURE= yes
+USE_INC_LIBTOOL_VER= 13
+LIBTOOLFILES= configure raptor/configure rasqal/configure
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-bdb-lib="${LOCALBASE}/lib" \
--with-bdb-include="${LOCALBASE}/include/db41" \
--with-bdb-dbname="db41" \
- --with-libwww \
- --with-raptor=system
+ --with-raptor=system \
+ --with-rasqal=internal \
+ --with-threestore=no \
+ --with-mysql=no
INSTALLS_SHLIB= yes
-MAN1= rdfproc.1 redland-config.1 redland-db-upgrade.1
-MAN3= redland.3
+MAN1= rasqal-config.1 rdfproc.1 redland-config.1 \
+ redland-db-upgrade.1 roqet.1
+MAN3= librasqal.3 redland.3
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib