aboutsummaryrefslogtreecommitdiff
path: root/textproc/ruby-amatch
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/ruby-amatch')
-rw-r--r--textproc/ruby-amatch/Makefile9
-rw-r--r--textproc/ruby-amatch/distinfo6
-rw-r--r--textproc/ruby-amatch/files/patch-ext_amatch.c23
3 files changed, 19 insertions, 19 deletions
diff --git a/textproc/ruby-amatch/Makefile b/textproc/ruby-amatch/Makefile
index 0411ccad9f6d..665ac51bf738 100644
--- a/textproc/ruby-amatch/Makefile
+++ b/textproc/ruby-amatch/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= amatch
-PORTVERSION= 0.2.3
+PORTVERSION= 0.2.5
CATEGORIES= textproc ruby
MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -23,9 +23,12 @@ RUBY_SETUP= install.rb
INSTALL_TARGET= site-install
-PLIST_FILES= bin/agrep.rb %%RUBY_SITEARCHLIBDIR%%/amatch.so
+PLIST_FILES= bin/agrep.rb %%RUBY_SITELIBDIR%%/amatch/version.rb \
+ %%RUBY_SITEARCHLIBDIR%%/amatch.so
+PLIST_DIRS= %%RUBY_SITELIBDIR%%/amatch
+
DOCSDIR= ${RUBY_MODDOCDIR}
-PORTDOCS= CHANGES README.en
+PORTDOCS= CHANGES README
.include <bsd.port.pre.mk>
diff --git a/textproc/ruby-amatch/distinfo b/textproc/ruby-amatch/distinfo
index 05f0ffd5c93d..53fd3719d4da 100644
--- a/textproc/ruby-amatch/distinfo
+++ b/textproc/ruby-amatch/distinfo
@@ -1,3 +1,3 @@
-MD5 (ruby/amatch-0.2.3.tgz) = e6ddaf5a25c83cf54966fad638eb401a
-SHA256 (ruby/amatch-0.2.3.tgz) = 130fcee3488c3070c09b42db190433e419ff7c8abdcb5d372f801eab16b0c2db
-SIZE (ruby/amatch-0.2.3.tgz) = 27833
+MD5 (ruby/amatch-0.2.5.tgz) = ec1e139d6978e7e4100144b7c2e9ddf9
+SHA256 (ruby/amatch-0.2.5.tgz) = fd3eb6ac602fbd7dac3d51d3476da750e1cb20e3b1597529c0ebcbfc24591322
+SIZE (ruby/amatch-0.2.5.tgz) = 38582
diff --git a/textproc/ruby-amatch/files/patch-ext_amatch.c b/textproc/ruby-amatch/files/patch-ext_amatch.c
index 3c6d3e780228..82efea02b390 100644
--- a/textproc/ruby-amatch/files/patch-ext_amatch.c
+++ b/textproc/ruby-amatch/files/patch-ext_amatch.c
@@ -1,28 +1,25 @@
-
-$FreeBSD$
-
---- ext/amatch.c.orig
-+++ ext/amatch.c
-@@ -86,9 +86,10 @@
+--- ext/amatch.c.orig 2009-08-26 02:35:48.000000000 +0200
++++ ext/amatch.c 2010-04-23 12:48:35.000000000 +0200
+@@ -89,9 +89,10 @@
if (TYPE(strings) == T_STRING) { \
return match_function(amatch, strings); \
} else { \
- Check_Type(strings, T_ARRAY); \
int i; \
-- VALUE result = rb_ary_new2(RARRAY(strings)->len); \
-+ VALUE result; \
+- VALUE result = rb_ary_new2(RARRAY_LEN(strings)); \
++ VALUE result; \
+ Check_Type(strings, T_ARRAY); \
-+ result = rb_ary_new2(RARRAY(strings)->len); \
- for (i = 0; i < RARRAY(strings)->len; i++) { \
++ result = rb_ary_new2(RARRAY_LEN(strings)); \
+ for (i = 0; i < RARRAY_LEN(strings); i++) { \
VALUE string = rb_ary_entry(strings, i); \
if (TYPE(string) != T_STRING) { \
-@@ -949,8 +950,8 @@
+@@ -1098,8 +1099,8 @@
if (TYPE(strings) == T_STRING) {
result = PairDistance_match(amatch, strings, regexp, use_regexp);
} else {
- Check_Type(strings, T_ARRAY);
int i;
+ Check_Type(strings, T_ARRAY);
- result = rb_ary_new2(RARRAY(strings)->len);
- for (i = 0; i < RARRAY(strings)->len; i++) {
+ result = rb_ary_new2(RARRAY_LEN(strings));
+ for (i = 0; i < RARRAY_LEN(strings); i++) {
VALUE string = rb_ary_entry(strings, i);