aboutsummaryrefslogtreecommitdiff
path: root/textproc/ruby-xmlconfigfile/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/ruby-xmlconfigfile/Makefile')
-rw-r--r--textproc/ruby-xmlconfigfile/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/textproc/ruby-xmlconfigfile/Makefile b/textproc/ruby-xmlconfigfile/Makefile
new file mode 100644
index 000000000000..97eb7e15f32d
--- /dev/null
+++ b/textproc/ruby-xmlconfigfile/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: Ruby/xmlconfigfile
+# Date created: 25 February 2003
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmlconfigfile
+PORTVERSION= 0.8.0
+CATEGORIES= textproc devel ruby
+MASTER_SITES= http://www.maik-schmidt.de/projects/xmlconfigfile/dist/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= A Ruby module for easy handling of XML configuration files
+
+RUN_DEPENDS= ${RUBY_SITELIBDIR}/rexml/document.rb:${PORTSDIR}/textproc/ruby-rexml
+
+USE_ZIP= yes
+
+USE_RUBY= yes
+USE_RUBY_SETUP= yes
+RUBY_SETUP= install.rb
+
+DOCS= docs CHANGES README TODO
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODDOCDIR}
+.for f in ${DOCS}
+ ${CP} -R ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>