aboutsummaryrefslogtreecommitdiff
path: root/textproc/ruby-xmlscan-old/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/ruby-xmlscan-old/Makefile')
-rw-r--r--textproc/ruby-xmlscan-old/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/textproc/ruby-xmlscan-old/Makefile b/textproc/ruby-xmlscan-old/Makefile
new file mode 100644
index 000000000000..7b4170cfe394
--- /dev/null
+++ b/textproc/ruby-xmlscan-old/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: ruby-xmlscan
+# Date created: 7 August 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmlscan
+PORTVERSION= 0.0.10
+CATEGORIES= textproc ruby
+MASTER_SITES= http://www.blue.sky.or.jp/atelier/ruby/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+BUILD_DEPENDS= racc:${PORTSDIR}/devel/ruby-racc
+RUN_DEPENDS= ${RUBY_SITELIBDIR}/racc/parser.rb:${PORTSDIR}/devel/ruby-racc-runtime
+
+USE_RUBY= yes
+
+do-build:
+ cd ${WRKSRC}; racc -v -g -c -o xmldtd.rb xmldtd.ry
+
+do-install:
+ cd ${WRKSRC}; ${INSTALL_DATA} [hx]*.rb ${RUBY_SITELIBDIR}/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}/ja
+ ${INSTALL_DATA} ${WRKSRC}/README ${RUBY_DOCDIR}/${PORTNAME}/ja/
+.endif
+
+.include <bsd.port.mk>