aboutsummaryrefslogtreecommitdiff
path: root/textproc/source-highlight/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/source-highlight/Makefile')
-rw-r--r--textproc/source-highlight/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/textproc/source-highlight/Makefile b/textproc/source-highlight/Makefile
index c815250d4ca1..bd2d54f2472a 100644
--- a/textproc/source-highlight/Makefile
+++ b/textproc/source-highlight/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= source-highlight
-PORTVERSION= 2.10
+PORTVERSION= 2.11.1
PORTREVISION= 0
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_GNU}
@@ -19,7 +19,7 @@ BUILD_DEPENDS= exctags:${PORTSDIR}/devel/ctags
LIB_DEPENDS= boost_regex:${PORTSDIR}/devel/boost
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= LDFLAGS=-L${LOCALBASE}/lib CPPFLAGS=-I${LOCALBASE}/include
+CONFIGURE_ARGS= LDFLAGS=-L${LOCALBASE}/lib CPPFLAGS=-I${LOCALBASE}/include
.if defined(NOPORTDOCS)
MAKE_ENV+= NOPORTDOCS="${NOPORTDOCS}"
.endif
@@ -29,6 +29,8 @@ USE_GMAKE= yes
MAN1= source-highlight.1 check-regexp.1
INFO= source-highlight
+OPTIONS= BASH "Support Bash completion" Off
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 700042
@@ -37,4 +39,13 @@ BROKEN= Does not compile with GCC 4.2
.endif
.endif
+.if defined(WITH_BASH)
+RUN_DEPENDS+= ${LOCALBASE}/etc/bash_completion:${PORTSDIR}/shells/bash-completion
+CONFIGURE_ARGS+= --with-bash-completion
+PLIST_SUB+= BASH=""
+.else
+CONFIGURE_ARGS+= --without-bash-completion
+PLIST_SUB+= BASH="@comment "
+.endif
+
.include <bsd.port.post.mk>