aboutsummaryrefslogtreecommitdiff
path: root/textproc/stardict2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/stardict2/Makefile')
-rw-r--r--textproc/stardict2/Makefile36
1 files changed, 14 insertions, 22 deletions
diff --git a/textproc/stardict2/Makefile b/textproc/stardict2/Makefile
index efcf58f6c885..8abe12e2145d 100644
--- a/textproc/stardict2/Makefile
+++ b/textproc/stardict2/Makefile
@@ -5,16 +5,17 @@
# $FreeBSD$
#
-PORTNAME= stardict2
-PORTVERSION= 2.0.0
-CATEGORIES= chinese
-MASTER_SITES= http://reciteword.cosoft.org.cn/yaoguang/myapps/ \
+PORTNAME= stardict
+PORTVERSION= 2.2.0
+CATEGORIES= chinese textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://freebsd.sinica.edu.tw/pub/statue/stardict2/
-DISTFILES= stardict-${PORTVERSION}.tar.gz \
- stardict-cdict-big5-${PORTVERSION}.tar.bz2 \
- stardict-cedict-big5-${PORTVERSION}.tar.bz2 \
- stardict-xdict-big5-${PORTVERSION}.tar.bz2 \
- stardict-xdict-ce-big5-${PORTVERSION}.tar.bz2
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTFILES= stardict-${PORTVERSION}.tar.bz2 \
+ stardict-cdict-big5-2.1.0.tar.bz2 \
+ stardict-cedict-big5-2.1.0.tar.bz2 \
+ stardict-xdict-big5-2.1.0.tar.bz2 \
+ stardict-xdict-ce-big5-2.1.0.tar.bz2
MAINTAINER= statue@freebsd.sinica.edu.tw
COMMENT= English-Chinese dictionary
@@ -26,23 +27,14 @@ USE_GMAKE= yes
USE_X_PREFIX= yes
USE_BZIP2= yes
USE_GNOME= libgnome libgnomeui libbonobo bonoboactivation gconf2
-WRKSRC= ${WRKDIR}/stardict-${PORTVERSION}
MAN1= stardict.1
-do-extract:
- ${MKDIR} ${WRKDIR}
- cd ${WRKDIR} && tar zxf ${DISTDIR}/stardict-2.0.0.tar.gz && \
- tar jxf ${DISTDIR}/stardict-cdict-big5-2.0.0.tar.bz2 && \
- tar jxf ${DISTDIR}/stardict-cedict-big5-2.0.0.tar.bz2 && \
- tar jxf ${DISTDIR}/stardict-xdict-big5-2.0.0.tar.bz2 && \
- tar jxf ${DISTDIR}/stardict-xdict-ce-big5-2.0.0.tar.bz2
-
post-install:
${MKDIR} ${PREFIX}/share/stardict/dic/
- ${INSTALL_DATA} ${WRKDIR}/stardict-cdict-big5-2.0.0/* ${PREFIX}/share/stardict/dic/
- ${INSTALL_DATA} ${WRKDIR}/stardict-cedict-big5-2.0.0/* ${PREFIX}/share/stardict/dic/
- ${INSTALL_DATA} ${WRKDIR}/stardict-xdict-big5-2.0.0/* ${PREFIX}/share/stardict/dic/
- ${INSTALL_DATA} ${WRKDIR}/stardict-xdict-ce-big5-2.0.0/* ${PREFIX}/share/stardict/dic/
+ ${INSTALL_DATA} ${WRKDIR}/stardict-cdict-big5-2.1.0/* ${PREFIX}/share/stardict/dic/
+ ${INSTALL_DATA} ${WRKDIR}/stardict-cedict-big5-2.1.0/* ${PREFIX}/share/stardict/dic/
+ ${INSTALL_DATA} ${WRKDIR}/stardict-xdict-big5-2.1.0/* ${PREFIX}/share/stardict/dic/
+ ${INSTALL_DATA} ${WRKDIR}/stardict-xdict-ce-big5-2.1.0/* ${PREFIX}/share/stardict/dic/
.include <bsd.port.mk>