aboutsummaryrefslogtreecommitdiff
path: root/textproc/stardict3
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/stardict3')
-rw-r--r--textproc/stardict3/Makefile7
-rw-r--r--textproc/stardict3/files/patch-dict__src__dictmanagedlg.cpp10
-rw-r--r--textproc/stardict3/files/patch-dict__src__mainwin.cpp10
3 files changed, 22 insertions, 5 deletions
diff --git a/textproc/stardict3/Makefile b/textproc/stardict3/Makefile
index 81499ba68535..b25591f51790 100644
--- a/textproc/stardict3/Makefile
+++ b/textproc/stardict3/Makefile
@@ -3,6 +3,7 @@
PORTNAME= stardict
PORTVERSION= 3.0.4
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= GOOGLE_CODE
DIST_SUBDIR= stardict
@@ -20,8 +21,7 @@ CONFIGURE_ARGS= --disable-festival \
--disable-gucharmap \
--disable-espeak \
--disable-updateinfo
-USE_BZIP2= yes
-USES= gettext gmake pathfix pkgconfig
+USES= tar:bzip2 gettext gmake pathfix pkgconfig
CONFIGURE_WRKSRC= ${WRKSRC}/dict
BUILD_WRKSRC= ${CONFIGURE_WRKSRC}
INSTALL_WRKSRC= ${CONFIGURE_WRKSRC}
@@ -29,9 +29,6 @@ INSTALL_WRKSRC= ${CONFIGURE_WRKSRC}
PROJECTHOST= stardict-3
OPTIONS_DEFINE= GNOME
-OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
-
-CONFLICTS_INSTALL= stardict-2.[0-9]*
.include <bsd.port.options.mk>
diff --git a/textproc/stardict3/files/patch-dict__src__dictmanagedlg.cpp b/textproc/stardict3/files/patch-dict__src__dictmanagedlg.cpp
new file mode 100644
index 000000000000..6a9b15de1ad5
--- /dev/null
+++ b/textproc/stardict3/files/patch-dict__src__dictmanagedlg.cpp
@@ -0,0 +1,10 @@
+--- ./dict/src/dictmanagedlg.cpp.orig 2012-12-24 10:04:24.000000000 +0000
++++ ./dict/src/dictmanagedlg.cpp 2014-03-25 09:07:04.575980043 +0000
+@@ -25,6 +25,7 @@
+ #include <sys/stat.h>
+ #include <glib/gi18n.h>
+ #include <algorithm>
++#include <cstdlib>
+
+ #ifdef _WIN32
+ # include <gdk/gdkwin32.h>
diff --git a/textproc/stardict3/files/patch-dict__src__mainwin.cpp b/textproc/stardict3/files/patch-dict__src__mainwin.cpp
new file mode 100644
index 000000000000..99e77a328e85
--- /dev/null
+++ b/textproc/stardict3/files/patch-dict__src__mainwin.cpp
@@ -0,0 +1,10 @@
+--- ./dict/src/mainwin.cpp.orig 2012-12-24 10:50:21.000000000 +0000
++++ ./dict/src/mainwin.cpp 2014-03-25 09:05:47.241985479 +0000
+@@ -23,6 +23,7 @@
+ #include <glib/gi18n.h>
+ #include <gdk/gdkkeysyms.h>
+ #include <algorithm>
++#include <cstdlib>
+
+ #ifdef _WIN32
+ #define VERSION "3.0.4"