aboutsummaryrefslogtreecommitdiff
path: root/textproc/textutils/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/textutils/Makefile')
-rw-r--r--textproc/textutils/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/textproc/textutils/Makefile b/textproc/textutils/Makefile
index 68f4d402c6fd..d660a0769cdd 100644
--- a/textproc/textutils/Makefile
+++ b/textproc/textutils/Makefile
@@ -13,11 +13,13 @@ MASTER_SITE_SUBDIR= textutils
MAINTAINER= aw1@stade.co.uk
-GNU_CONFIGURE= yes
-
-CONFIGURE_ARGS= --program-prefix=g
+LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --program-prefix=g
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
MAN1= gcomm.1 gcsplit.1 gcut.1 gexpand.1 gfmt.1 ghead.1 \
gjoin.1 gmd5sum.1 gnl.1 gpaste.1 gpr.1 gsort.1 \
@@ -25,6 +27,12 @@ MAN1= gcomm.1 gcsplit.1 gcut.1 gexpand.1 gfmt.1 ghead.1 \
gtsort.1 gwc.1 gcat.1 gcksum.1 gfold.1 god.1 \
gsplit.1 gunexpand.1
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
+ s|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
+ s|\$$\(top_builddir\)/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
+
post-install:
install-info ${PREFIX}/info/textutils.info ${PREFIX}/info/dir