aboutsummaryrefslogtreecommitdiff
path: root/textproc/tk-hunspell
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/tk-hunspell')
-rw-r--r--textproc/tk-hunspell/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/textproc/tk-hunspell/Makefile b/textproc/tk-hunspell/Makefile
index e64512419b9f..481360f404d9 100644
--- a/textproc/tk-hunspell/Makefile
+++ b/textproc/tk-hunspell/Makefile
@@ -5,11 +5,13 @@
# $FreeBSD$
#
-PORTNAME= tk-hunspell
+PORTNAME= hunspell
PORTVERSION= 0.01
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
MASTER_SITE_SUBDIR= addons/204314
+PKGNAMEPREFIX= tk-
DISTNAME= turkmen_spell_checker-${PORTVERSION}-fx+tb+sm
EXTRACT_SUFX= .xpi
@@ -18,13 +20,14 @@ COMMENT= Turkmen hunspell dictionaries
USE_ZIP= yes
NO_BUILD= yes
+WRKSRC= ${WRKDIR}/dictionaries
-PLIST_FILES= share/hunspell/tk.aff \
- share/hunspell/tk.dic
-PLIST_DIRS= share/hunspell
+PLIST_FILES= %%DATADIR%%/tk.aff \
+ %%DATADIR%%/tk.dic
+PLIST_DIRSTRY= %%DATADIR%%
do-install:
- @${MKDIR} ${PREFIX}/share/hunspell
- @${INSTALL_DATA} ${WRKDIR}/dictionaries/tk* ${PREFIX}/share/hunspell/
+ ${MKDIR} ${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/tk.aff ${WRKSRC}/tk.dic ${DATADIR}/
.include <bsd.port.mk>