aboutsummaryrefslogtreecommitdiff
path: root/textproc/uim-kde4/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/uim-kde4/Makefile')
-rw-r--r--textproc/uim-kde4/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/textproc/uim-kde4/Makefile b/textproc/uim-kde4/Makefile
index 7639d33b0a9d..d8a20f3a3a03 100644
--- a/textproc/uim-kde4/Makefile
+++ b/textproc/uim-kde4/Makefile
@@ -11,12 +11,10 @@ COMMENT= KDE4 panel applet of uim input method
BUILD_DEPENDS= cmake:${PORTSDIR}/devel/cmake
LIB_DEPENDS= uim.7:${PORTSDIR}/textproc/uim
-RUN_DEPENDS= uim-pref-qt4:${PORTSDIR}/textproc/uim-qt
-
-BROKEN= does not compile
+RUN_DEPENDS= uim-pref-qt4:${PORTSDIR}/textproc/uim-qt4
USE_GCC= 4.2+
-USE_KDE4= kdelibs automoc4
+USE_KDE4= kdehier kdeprefix kdelibs automoc4
USE_QT_VER= 4
QT_COMPONENTS= qmake_build moc_build qt3support uic rcc
USE_AUTOTOOLS= libtool
@@ -25,6 +23,10 @@ MASTERDIR= ${.CURDIR}/../../textproc/uim
PKGDIR= ${.CURDIR}
CONFIGURE_ARGS= --with-qt4 --enable-pref --enable-default-toolkit=qt4 \
--enable-kde4-applet
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
+ CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" \
+ KDE4_CONFIG="${KDE4_PREFIX}/bin/kde4-config"
UIM_SLAVE= yes
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-qt4_toolbar_CMakeLists.txt