aboutsummaryrefslogtreecommitdiff
path: root/textproc/uim/files
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/uim/files')
-rw-r--r--textproc/uim/files/patch-Makefile.in13
-rw-r--r--textproc/uim/files/patch-helper:Makefile.in12
-rw-r--r--textproc/uim/files/patch-helper:helper-candwin-gtk.c15
3 files changed, 27 insertions, 13 deletions
diff --git a/textproc/uim/files/patch-Makefile.in b/textproc/uim/files/patch-Makefile.in
deleted file mode 100644
index 6f8115846be4..000000000000
--- a/textproc/uim/files/patch-Makefile.in
+++ /dev/null
@@ -1,13 +0,0 @@
---- Makefile.in.orig Sat Aug 30 09:37:54 2003
-+++ Makefile.in Sun Aug 31 15:38:52 2003
-@@ -131,7 +131,9 @@
- am__quote = @am__quote@
- install_sh = @install_sh@
- AUTOMAKE_OPTIONS = foreign
--SUBDIRS = m4 doc scm uim xim helper po gtk
-+SUBDIRS = m4 doc scm uim xim po
-+@GTK2_TRUE@SUBDIRS := $(SUBDIRS) gtk
-+@GNOME2_TRUE@SUBDIRS := $(SUBDIRS) helper
- EXTRA_DIST = README.ja INSTALL.ja test.sh.in uim.spec.in \
- intltool-extract.in intltool-merge.in intltool-update.in
-
diff --git a/textproc/uim/files/patch-helper:Makefile.in b/textproc/uim/files/patch-helper:Makefile.in
new file mode 100644
index 000000000000..6b25521297c7
--- /dev/null
+++ b/textproc/uim/files/patch-helper:Makefile.in
@@ -0,0 +1,12 @@
+--- helper/Makefile.in.orig Sun Nov 9 11:11:01 2003
++++ helper/Makefile.in Sun Nov 9 11:14:36 2003
+@@ -140,7 +140,8 @@
+ EXTRA_DIST = GNOME_UimApplet.server.in.in
+
+ serverdir = $(libdir)/bonobo/servers
+-server_DATA = GNOME_UimApplet.server
++@APPLET_TRUE@server_DATA = GNOME_UimApplet.server
++@APPLET_FALSE@server_DATA =
+ server_in_files = $(server_DATA:=.in)
+ server_in_in_files = $(server_in_files:=.in)
+
diff --git a/textproc/uim/files/patch-helper:helper-candwin-gtk.c b/textproc/uim/files/patch-helper:helper-candwin-gtk.c
new file mode 100644
index 000000000000..9d85f729dab2
--- /dev/null
+++ b/textproc/uim/files/patch-helper:helper-candwin-gtk.c
@@ -0,0 +1,15 @@
+--- helper/helper-candwin-gtk.c.orig Sun Nov 9 02:26:21 2003
++++ helper/helper-candwin-gtk.c Sun Nov 9 02:27:22 2003
+@@ -160,10 +160,11 @@
+ {
+ int index;
+ char idx[20];
++ GtkTreePath* path;
+ sscanf(str[1],"%d",&index);
+ cwin.candidate_index = index;
+
+- GtkTreePath* path = gtk_tree_path_new_from_indices(index, -1);
++ path = gtk_tree_path_new_from_indices(index, -1);
+ gtk_tree_view_set_cursor(GTK_TREE_VIEW(m_view),
+ path, NULL, FALSE);
+ gtk_tree_view_scroll_to_cell(GTK_TREE_VIEW(m_view),