aboutsummaryrefslogtreecommitdiff
path: root/textproc/wordnet/files/src.wn.Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/wordnet/files/src.wn.Makefile')
-rw-r--r--textproc/wordnet/files/src.wn.Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/textproc/wordnet/files/src.wn.Makefile b/textproc/wordnet/files/src.wn.Makefile
new file mode 100644
index 000000000000..5bfe8139bb0c
--- /dev/null
+++ b/textproc/wordnet/files/src.wn.Makefile
@@ -0,0 +1,12 @@
+PROG= wn
+NOMAN= True # man pages installed separately
+
+CFLAGS+= -DUNIX -DDEFAULTPATH="\"${PREFIX}/share/wordnet-1.6\"" \
+ -DDEFAULTBIN="\"${PREFIX}/bin\""
+
+CFLAGS+= -I${.CURDIR}/../../include
+LDADD+= -L../lib -lwn1
+
+BINDIR= ${PREFIX}/bin
+
+.include <bsd.prog.mk>