aboutsummaryrefslogtreecommitdiff
path: root/textproc/xerces-c2-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/xerces-c2-devel/Makefile')
-rw-r--r--textproc/xerces-c2-devel/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/textproc/xerces-c2-devel/Makefile b/textproc/xerces-c2-devel/Makefile
index fda5c2cc1c8f..976e31423fb4 100644
--- a/textproc/xerces-c2-devel/Makefile
+++ b/textproc/xerces-c2-devel/Makefile
@@ -55,10 +55,12 @@ MAKE_ENV+= XERCESCROOT=${WRKSRC}
GNU_CONFIGURE= yes
CONFIGURE_ENV+= XERCESCROOT=${WRKSRC} TRANSCODER=${TRANSCODER}
CONFIGURE_SCRIPT= runConfigure
-CONFIGURE_ARGS?= -p freebsd -c ${CC} -x ${CXX} -n socket -P ${PREFIX}
+CONFIGURE_ARGS+= -p freebsd -c ${CC} -x ${CXX} -n socket -P ${PREFIX}
CONFIGURE_ARGS+= -t ${TRANSCODER}
+.include <bsd.port.pre.mk>
+
.if defined(NO_THREADS)
CONFIGURE_ARGS+= -r none
.endif
@@ -73,7 +75,7 @@ PLIST_SUB+= NO_SAMPLES=""
ALL_TARGET?= all samples
XERCES_BINS?= CreateDOMDocument DOMCount DOMPrint EnumVal MemParse PParse \
Redirect SAX2Count SAX2Print SAXCount SAXPrint SEnumVal StdInParse
-SAMPLES_CONFIG_ARGS?= -p freebsd -x g++
+SAMPLES_CONFIG_ARGS+= -p freebsd -c ${CC} -x ${CXX}
.if defined(NO_THREADS)
SAMPLES_CONFIG_ARGS+= -r none
.endif
@@ -143,4 +145,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>