aboutsummaryrefslogtreecommitdiff
path: root/textproc/xlreader/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/xlreader/Makefile')
-rw-r--r--textproc/xlreader/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/textproc/xlreader/Makefile b/textproc/xlreader/Makefile
new file mode 100644
index 000000000000..7cb1b5259f08
--- /dev/null
+++ b/textproc/xlreader/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: xlreader
+# Date created: 25 Jun 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xlreader
+PORTVERSION= 0.9.0
+CATEGORIES= textproc
+MASTER_SITES= http://www.giffin.org/download/ \
+ http://critical.ch/distfiles/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= Convert .xls spread sheets to tab delimited CSV or SQL inserts
+
+USE_REINPLACE= yes
+PLIST_FILES= bin/xlreader
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|-L/usr/local/lib||; s|^CFLAGS=.*||; s|gcc|${CC}|' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>