aboutsummaryrefslogtreecommitdiff
path: root/textproc/zorba
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/zorba')
-rw-r--r--textproc/zorba/Makefile1
-rw-r--r--textproc/zorba/files/patch-CMakeLists.txt2
2 files changed, 2 insertions, 1 deletions
diff --git a/textproc/zorba/Makefile b/textproc/zorba/Makefile
index 454cd50be753..9ffbdc85a0a1 100644
--- a/textproc/zorba/Makefile
+++ b/textproc/zorba/Makefile
@@ -35,6 +35,7 @@ USES= cmake:outsource iconv compiler:c++11-lib
CXXFLAGS+= -I${LOCALBASE}/include -O1 # compiler hangs with -O2 on CURRENT
LDFLAGS+= -L${LOCALBASE}/lib
CMAKE_ARGS= -DCMAKE_REQUIRED_FLAGS:STRING="-I${LOCALBASE}/include -L${LOCALBASE}/lib" \
+ -DLOCALBASE:STRING=${LOCALBASE} \
-DCMAKE_VERBOSE_MAKEFILE:BOOL=ON
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
diff --git a/textproc/zorba/files/patch-CMakeLists.txt b/textproc/zorba/files/patch-CMakeLists.txt
index c4f0db746ca7..bfde98f6f704 100644
--- a/textproc/zorba/files/patch-CMakeLists.txt
+++ b/textproc/zorba/files/patch-CMakeLists.txt
@@ -18,7 +18,7 @@
+# execinfo
+#
+IF(FREEBSD)
-+ SET(requiredlibs ${requiredlibs} "/usr/local/lib/libexecinfo.so")
++ SET(requiredlibs ${requiredlibs} "${LOCALBASE}/lib/libexecinfo.so")
+ENDIF(FREEBSD)
+
+#