aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile9
-rw-r--r--textproc/php55-ctype/Makefile10
-rw-r--r--textproc/php55-dom/Makefile10
-rw-r--r--textproc/php55-pspell/Makefile10
-rw-r--r--textproc/php55-simplexml/Makefile10
-rw-r--r--textproc/php55-wddx/Makefile10
-rw-r--r--textproc/php55-wddx/files/patch-config.m422
-rw-r--r--textproc/php55-wddx/files/patch-wddx.c40
-rw-r--r--textproc/php55-xml/Makefile10
-rw-r--r--textproc/php55-xml/files/patch-compat.c13
-rw-r--r--textproc/php55-xmlreader/Makefile10
-rw-r--r--textproc/php55-xmlwriter/Makefile10
-rw-r--r--textproc/php55-xsl/Makefile10
-rw-r--r--textproc/php55-xsl/files/patch-php_xsl.h11
14 files changed, 185 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index a920f7359250..0ae84b008766 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1119,6 +1119,15 @@
SUBDIR += php53-xmlreader
SUBDIR += php53-xmlwriter
SUBDIR += php53-xsl
+ SUBDIR += php55-ctype
+ SUBDIR += php55-dom
+ SUBDIR += php55-pspell
+ SUBDIR += php55-simplexml
+ SUBDIR += php55-wddx
+ SUBDIR += php55-xml
+ SUBDIR += php55-xmlreader
+ SUBDIR += php55-xmlwriter
+ SUBDIR += php55-xsl
SUBDIR += plover
SUBDIR += po4a
SUBDIR += pocketreader
diff --git a/textproc/php55-ctype/Makefile b/textproc/php55-ctype/Makefile
new file mode 100644
index 000000000000..e7d588b51654
--- /dev/null
+++ b/textproc/php55-ctype/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= textproc
+
+MASTERDIR= ${.CURDIR}/../../lang/php55
+
+PKGNAMESUFFIX= -ctype
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php55-dom/Makefile b/textproc/php55-dom/Makefile
new file mode 100644
index 000000000000..22d0fa1183c8
--- /dev/null
+++ b/textproc/php55-dom/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= textproc
+
+MASTERDIR= ${.CURDIR}/../../lang/php55
+
+PKGNAMESUFFIX= -dom
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php55-pspell/Makefile b/textproc/php55-pspell/Makefile
new file mode 100644
index 000000000000..36d27eec6153
--- /dev/null
+++ b/textproc/php55-pspell/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= textproc
+
+MASTERDIR= ${.CURDIR}/../../lang/php55
+
+PKGNAMESUFFIX= -pspell
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php55-simplexml/Makefile b/textproc/php55-simplexml/Makefile
new file mode 100644
index 000000000000..dd274937d988
--- /dev/null
+++ b/textproc/php55-simplexml/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= textproc
+
+MASTERDIR= ${.CURDIR}/../../lang/php55
+
+PKGNAMESUFFIX= -simplexml
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php55-wddx/Makefile b/textproc/php55-wddx/Makefile
new file mode 100644
index 000000000000..790120bcd0ce
--- /dev/null
+++ b/textproc/php55-wddx/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= textproc
+
+MASTERDIR= ${.CURDIR}/../../lang/php55
+
+PKGNAMESUFFIX= -wddx
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php55-wddx/files/patch-config.m4 b/textproc/php55-wddx/files/patch-config.m4
new file mode 100644
index 000000000000..08787003b8f9
--- /dev/null
+++ b/textproc/php55-wddx/files/patch-config.m4
@@ -0,0 +1,22 @@
+--- config.m4.orig Mon Jul 26 09:05:10 2004
++++ config.m4 Mon Jul 26 09:07:46 2004
+@@ -5,6 +5,9 @@
+ PHP_ARG_ENABLE(wddx,whether to enable WDDX support,
+ [ --enable-wddx Enable WDDX support.])
+
++PHP_ARG_WITH(libxml-dir, libxml2 install dir,
++[ --with-libxml-dir=<DIR> WDDX: libxml2 install prefix], no, no)
++
+ if test "$PHP_WDDX" != "no"; then
+ if test "$ext_shared" != "yes" && test "$enable_xml" = "no"; then
+ AC_MSG_WARN(Activating XML)
+@@ -12,4 +15,9 @@
+ fi
+ AC_DEFINE(HAVE_WDDX, 1, [ ])
+ PHP_NEW_EXTENSION(wddx, wddx.c, $ext_shared)
++
++ PHP_SETUP_LIBXML(WDDX_SHARED_LIBADD, [
++ ], [
++ AC_MSG_ERROR([xml2-config not found. Please check your libxml2 installation.])
++ ])
+ fi
diff --git a/textproc/php55-wddx/files/patch-wddx.c b/textproc/php55-wddx/files/patch-wddx.c
new file mode 100644
index 000000000000..a8a6a79fe47f
--- /dev/null
+++ b/textproc/php55-wddx/files/patch-wddx.c
@@ -0,0 +1,40 @@
+--- wddx.c.orig Sun Jan 1 13:50:16 2006
++++ wddx.c Mon Jan 16 12:56:21 2006
+@@ -18,6 +18,10 @@
+
+ /* $Id: wddx.c,v 1.119.2.8 2006/01/01 12:50:16 sniper Exp $ */
+
++#ifdef HAVE_CONFIG_H
++# include "config.h"
++#endif
++
+ #include "php.h"
+
+ #if HAVE_WDDX
+@@ -223,7 +227,7 @@
+
+ #include "ext/session/php_session.h"
+
+-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
++#if HAVE_PHP_SESSION
+ /* {{{ PS_SERIALIZER_ENCODE_FUNC
+ */
+ PS_SERIALIZER_ENCODE_FUNC(wddx)
+@@ -302,7 +306,7 @@
+ {
+ le_wddx = zend_register_list_destructors_ex(release_wddx_packet_rsrc, NULL, "wddx", module_number);
+
+-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
++#if HAVE_PHP_SESSION
+ php_session_register_serializer("wddx",
+ PS_SERIALIZER_ENCODE_NAME(wddx),
+ PS_SERIALIZER_DECODE_NAME(wddx));
+@@ -317,7 +321,7 @@
+ PHP_MINFO_FUNCTION(wddx)
+ {
+ php_info_print_table_start();
+-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
++#if HAVE_PHP_SESSION
+ php_info_print_table_header(2, "WDDX Support", "enabled" );
+ php_info_print_table_row(2, "WDDX Session Serializer", "enabled" );
+ #else
diff --git a/textproc/php55-xml/Makefile b/textproc/php55-xml/Makefile
new file mode 100644
index 000000000000..be8e8646b390
--- /dev/null
+++ b/textproc/php55-xml/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= textproc
+
+MASTERDIR= ${.CURDIR}/../../lang/php55
+
+PKGNAMESUFFIX= -xml
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php55-xml/files/patch-compat.c b/textproc/php55-xml/files/patch-compat.c
new file mode 100644
index 000000000000..02125961b20c
--- /dev/null
+++ b/textproc/php55-xml/files/patch-compat.c
@@ -0,0 +1,13 @@
+--- compat.c.orig Tue Jul 20 10:55:02 2004
++++ compat.c Tue Jul 20 10:55:55 2004
+@@ -16,6 +16,10 @@
+ +----------------------------------------------------------------------+
+ */
+
++#ifdef HAVE_CONFIG_H
++#include "config.h"
++#endif
++
+ #include "php.h"
+ #if defined(HAVE_LIBXML) && defined(HAVE_XML) && !defined(HAVE_LIBEXPAT)
+ #include "expat_compat.h"
diff --git a/textproc/php55-xmlreader/Makefile b/textproc/php55-xmlreader/Makefile
new file mode 100644
index 000000000000..5f6531799ed3
--- /dev/null
+++ b/textproc/php55-xmlreader/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= textproc
+
+MASTERDIR= ${.CURDIR}/../../lang/php55
+
+PKGNAMESUFFIX= -xmlreader
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php55-xmlwriter/Makefile b/textproc/php55-xmlwriter/Makefile
new file mode 100644
index 000000000000..79fbac052143
--- /dev/null
+++ b/textproc/php55-xmlwriter/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= textproc
+
+MASTERDIR= ${.CURDIR}/../../lang/php55
+
+PKGNAMESUFFIX= -xmlwriter
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php55-xsl/Makefile b/textproc/php55-xsl/Makefile
new file mode 100644
index 000000000000..9816a21c6f76
--- /dev/null
+++ b/textproc/php55-xsl/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= textproc
+
+MASTERDIR= ${.CURDIR}/../../lang/php55
+
+PKGNAMESUFFIX= -xsl
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php55-xsl/files/patch-php_xsl.h b/textproc/php55-xsl/files/patch-php_xsl.h
new file mode 100644
index 000000000000..9777187f8748
--- /dev/null
+++ b/textproc/php55-xsl/files/patch-php_xsl.h
@@ -0,0 +1,11 @@
+--- php_xsl.h.orig Sun Jan 1 13:50:17 2006
++++ php_xsl.h Tue Jan 17 16:23:10 2006
+@@ -43,7 +43,7 @@
+ #include <libexslt/exsltconfig.h>
+ #endif
+
+-#include "../dom/xml_common.h"
++#include "ext/dom/xml_common.h"
+ #include "xsl_fe.h"
+
+ #include <libxslt/extensions.h>