aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-LaTeX-Driver/Makefile37
-rw-r--r--textproc/p5-LaTeX-Driver/distinfo3
-rw-r--r--textproc/p5-LaTeX-Driver/pkg-descr7
-rw-r--r--textproc/p5-LaTeX-Driver/pkg-plist10
5 files changed, 58 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index d3ffab878c97..fd56c778c91e 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -444,6 +444,7 @@
SUBDIR += p5-KinoSearch
SUBDIR += p5-Kwalify
SUBDIR += p5-LJ-SpellCheck
+ SUBDIR += p5-LaTeX-Driver
SUBDIR += p5-LaTeX-Encode
SUBDIR += p5-LaTeX-TOM
SUBDIR += p5-Lingua-Conjunction
diff --git a/textproc/p5-LaTeX-Driver/Makefile b/textproc/p5-LaTeX-Driver/Makefile
new file mode 100644
index 000000000000..09af10ff4bcb
--- /dev/null
+++ b/textproc/p5-LaTeX-Driver/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: LaTeX-Driver
+# Date created: 1st June, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= LaTeX-Driver
+PORTVERSION= 0.08
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Perl module of LaTeX Driver
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/latex:${PORTSDIR}/print/teTeX-base \
+ p5-Cwd>=0:${PORTSDIR}/devel/p5-Cwd \
+ p5-File-Slurp>=0:${PORTSDIR}/devel/p5-File-Slurp \
+ p5-PathTools>=0:${PORTSDIR}/devel/p5-PathTools \
+ p5-IO>=0:${PORTSDIR}/devel/p5-IO \
+ p5-Exception-Class>=0:${PORTSDIR}/devel/p5-Exception-Class \
+ p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= latex2ps.1 latex2pdf.1 latex2dvi.1
+MAN3= LaTeX::Driver.3 \
+ LaTeX::Driver::Paths.3 \
+ LaTeX::Driver::FilterProgram.3
+
+.include <bsd.port.pre.mk>
+post-extract:
+ @${REINPLACE_CMD} -e 's#<STDIN>#"\r"#g' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-LaTeX-Driver/distinfo b/textproc/p5-LaTeX-Driver/distinfo
new file mode 100644
index 000000000000..14a19133d9b9
--- /dev/null
+++ b/textproc/p5-LaTeX-Driver/distinfo
@@ -0,0 +1,3 @@
+MD5 (LaTeX-Driver-0.08.tar.gz) = 741c93121ac7808555252a0005d467f4
+SHA256 (LaTeX-Driver-0.08.tar.gz) = 79b08e0dda63dd3df1ce003d68db79704cd0c391c10de60e4757663a928a3951
+SIZE (LaTeX-Driver-0.08.tar.gz) = 30601
diff --git a/textproc/p5-LaTeX-Driver/pkg-descr b/textproc/p5-LaTeX-Driver/pkg-descr
new file mode 100644
index 000000000000..b98b19565aa6
--- /dev/null
+++ b/textproc/p5-LaTeX-Driver/pkg-descr
@@ -0,0 +1,7 @@
+The LaTeX::Driver module encapsulates the details of invoking the
+Latex programs to format a LaTeX document. Formatting with LaTeX
+is complicated; there are potentially many programs to run and the
+output of those programs must be monitored to determine whether
+further processing is required.
+
+WWW: http://search.cpan.org/dist/LaTeX-Driver/
diff --git a/textproc/p5-LaTeX-Driver/pkg-plist b/textproc/p5-LaTeX-Driver/pkg-plist
new file mode 100644
index 000000000000..5ebf0cb6bfb5
--- /dev/null
+++ b/textproc/p5-LaTeX-Driver/pkg-plist
@@ -0,0 +1,10 @@
+bin/latex2dvi
+bin/latex2pdf
+bin/latex2ps
+%%SITE_PERL%%/LaTeX/Driver.pm
+%%SITE_PERL%%/LaTeX/Driver/Paths.pm
+%%SITE_PERL%%/LaTeX/Driver/FilterProgram.pm
+%%SITE_PERL%%/mach/auto/LaTeX-Driver/.packlist
+@dirrm %%SITE_PERL%%/mach/auto/LaTeX-Driver
+@dirrm %%SITE_PERL%%/LaTeX/Driver
+@dirrmtry %%SITE_PERL%%/LaTeX