aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
Diffstat (limited to 'textproc')
-rw-r--r--textproc/c2html/Makefile3
-rw-r--r--textproc/c2html/distinfo2
-rw-r--r--textproc/c2html/files/patch-aa36
-rw-r--r--textproc/java2html/Makefile2
-rw-r--r--textproc/java2html/distinfo2
-rw-r--r--textproc/java2html/files/patch-aa36
-rw-r--r--textproc/perl2html/Makefile2
-rw-r--r--textproc/perl2html/distinfo2
-rw-r--r--textproc/perl2html/files/patch-aa36
9 files changed, 96 insertions, 25 deletions
diff --git a/textproc/c2html/Makefile b/textproc/c2html/Makefile
index 9cad04d4fc5b..fd14b5c0073d 100644
--- a/textproc/c2html/Makefile
+++ b/textproc/c2html/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= c2html
-PORTVERSION= 0.7.2
+PORTVERSION= 0.9.1
CATEGORIES= textproc www
MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= apps/www/converters
@@ -18,7 +18,6 @@ USE_AUTOCONF= yes
MAN1= c2html.1
post-install:
- strip ${PREFIX}/bin/c2html
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/c2html
.for file in AUTHORS NEWS README
diff --git a/textproc/c2html/distinfo b/textproc/c2html/distinfo
index 723603184e5a..ec01050f5478 100644
--- a/textproc/c2html/distinfo
+++ b/textproc/c2html/distinfo
@@ -1 +1 @@
-MD5 (c2html-0.7.2.tar.gz) = f507f31d0a1172cb9e6b4b31e816ed9a
+MD5 (c2html-0.9.1.tar.gz) = 45811eede2860d046197ee248a9a34bd
diff --git a/textproc/c2html/files/patch-aa b/textproc/c2html/files/patch-aa
index f73652506b02..64206583c854 100644
--- a/textproc/c2html/files/patch-aa
+++ b/textproc/c2html/files/patch-aa
@@ -1,6 +1,6 @@
---- Makefile.in.orig Mon May 24 14:32:18 1999
-+++ Makefile.in Wed May 26 18:44:22 1999
-@@ -9,7 +9,7 @@
+--- Makefile.in.orig Sat Apr 15 17:16:25 2000
++++ Makefile.in Sun Apr 23 15:53:23 2000
+@@ -27,7 +27,7 @@
# for gzip because otherwise the load on the web server
# grows without having big benefits.
# COMPRESSION = -DCOMPRESSION=4
@@ -9,12 +9,36 @@
# Dont change things beyond this line.
TARGET = @PROJECT_NAME@
-@@ -40,7 +40,7 @@
- srcdir = @srcdir@
+@@ -59,7 +59,7 @@
+ docdir = @DOCDIR@
CPPFLAGS = @CPPFLAGS@
-CFLAGS += -O2 -Wall
+CFLAGS ?= -O2 -Wall
- ALL_CFLAGS = $(CFLAGS) -I$(srcdir) $(COMPRESSION)
+ ALL_CFLAGS = $(CFLAGS) -I$(srcdir) -I. $(COMPRESSION)
all: $(TARGET)
+@@ -70,10 +70,12 @@
+ $(LEXOUTPUT): $(CONFIGS) $(LEXSRCS) $(HDRS)
+ $(LEX) $(LEXSRCS)
+
+-install: $(TARGET) install-doc
++install: $(TARGET)
+ @echo "Installing" $(TARGET) "to" $(bindir)
+ -mkdir -p $(bindir)
+ $(INSTALL_PROGRAM) $(TARGET) $(bindir)/$(TARGET)
++ -mkdir -p $(man1dir)
++ $(INSTALL_DATA) $(srcdir)/$(MANPAGE) $(man1dir)/$(MANPAGE)
+
+ install-strip: $(TARGET) install-doc
+ @echo "Installing" $(TARGET) "to" $(bindir)
+@@ -81,8 +83,7 @@
+ $(INSTALL_PROGRAM) -s $(TARGET) $(bindir)/$(TARGET)
+
+ install-doc:
+- -mkdir -p $(man1dir) $(docdir)
+- $(INSTALL_DATA) $(srcdir)/$(MANPAGE) $(man1dir)/$(MANPAGE)
++ -mkdir -p $(docdir)
+ $(INSTALL_DATA) $(srcdir)/AUTHORS $(docdir)/AUTHORS
+ $(INSTALL_DATA) $(srcdir)/COPYING $(docdir)/COPYING
+ $(INSTALL_DATA) $(srcdir)/NEWS $(docdir)/NEWS
diff --git a/textproc/java2html/Makefile b/textproc/java2html/Makefile
index 82b11bfd4bbc..09e02c6f20e1 100644
--- a/textproc/java2html/Makefile
+++ b/textproc/java2html/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= java2html
-PORTVERSION= 0.7.2
+PORTVERSION= 0.9.1
CATEGORIES= textproc www
MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= apps/www/converters
diff --git a/textproc/java2html/distinfo b/textproc/java2html/distinfo
index 5685d6b059cd..a5905a287e82 100644
--- a/textproc/java2html/distinfo
+++ b/textproc/java2html/distinfo
@@ -1 +1 @@
-MD5 (java2html-0.7.2.tar.gz) = a06c166312945a0bd17a1e97ffeb9a24
+MD5 (java2html-0.9.1.tar.gz) = c69d2ae10c2d6a1bc7305526fee5d01e
diff --git a/textproc/java2html/files/patch-aa b/textproc/java2html/files/patch-aa
index 0e71a01edbc0..50826b93e8cb 100644
--- a/textproc/java2html/files/patch-aa
+++ b/textproc/java2html/files/patch-aa
@@ -1,6 +1,6 @@
---- Makefile.in.orig Mon May 24 14:33:08 1999
-+++ Makefile.in Wed May 26 12:20:22 1999
-@@ -9,7 +9,7 @@
+--- Makefile.in.orig Sat Apr 15 17:16:30 2000
++++ Makefile.in Sun Apr 23 15:46:41 2000
+@@ -27,7 +27,7 @@
# for gzip because otherwise the load on the web server
# grows without having big benefits.
# COMPRESSION = -DCOMPRESSION=4
@@ -9,12 +9,36 @@
# Dont change things beyond this line.
TARGET = @PROJECT_NAME@
-@@ -40,7 +40,7 @@
- srcdir = @srcdir@
+@@ -59,7 +59,7 @@
+ docdir = @DOCDIR@
CPPFLAGS = @CPPFLAGS@
-CFLAGS += -O2 -Wall
+CFLAGS ?= -O2 -Wall
- ALL_CFLAGS = $(CFLAGS) -I$(srcdir) $(COMPRESSION)
+ ALL_CFLAGS = $(CFLAGS) -I$(srcdir) -I. $(COMPRESSION)
all: $(TARGET)
+@@ -70,10 +70,12 @@
+ $(LEXOUTPUT): $(CONFIGS) $(LEXSRCS) $(HDRS)
+ $(LEX) $(LEXSRCS)
+
+-install: $(TARGET) install-doc
++install: $(TARGET)
+ @echo "Installing" $(TARGET) "to" $(bindir)
+ -mkdir -p $(bindir)
+ $(INSTALL_PROGRAM) $(TARGET) $(bindir)/$(TARGET)
++ -mkdir -p $(man1dir)
++ $(INSTALL_DATA) $(srcdir)/$(MANPAGE) $(man1dir)/$(MANPAGE)
+
+ install-strip: $(TARGET) install-doc
+ @echo "Installing" $(TARGET) "to" $(bindir)
+@@ -81,8 +83,7 @@
+ $(INSTALL_PROGRAM) -s $(TARGET) $(bindir)/$(TARGET)
+
+ install-doc:
+- -mkdir -p $(man1dir) $(docdir)
+- $(INSTALL_DATA) $(srcdir)/$(MANPAGE) $(man1dir)/$(MANPAGE)
++ -mkdir -p $(docdir)
+ $(INSTALL_DATA) $(srcdir)/AUTHORS $(docdir)/AUTHORS
+ $(INSTALL_DATA) $(srcdir)/COPYING $(docdir)/COPYING
+ $(INSTALL_DATA) $(srcdir)/NEWS $(docdir)/NEWS
diff --git a/textproc/perl2html/Makefile b/textproc/perl2html/Makefile
index 173f5182e92c..a7039d0246ae 100644
--- a/textproc/perl2html/Makefile
+++ b/textproc/perl2html/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= perl2html
-PORTVERSION= 0.7.2
+PORTVERSION= 0.9.1
CATEGORIES= textproc www
MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= apps/www/converters
diff --git a/textproc/perl2html/distinfo b/textproc/perl2html/distinfo
index ab7f4e6a971f..0ac752d2f6e3 100644
--- a/textproc/perl2html/distinfo
+++ b/textproc/perl2html/distinfo
@@ -1 +1 @@
-MD5 (perl2html-0.7.2.tar.gz) = 0ca73bb3b5a138a45632eb756e016799
+MD5 (perl2html-0.9.1.tar.gz) = 90d2f8ed91cc02a1c53569b933a08bef
diff --git a/textproc/perl2html/files/patch-aa b/textproc/perl2html/files/patch-aa
index 3da005399ff4..12f48fbc0140 100644
--- a/textproc/perl2html/files/patch-aa
+++ b/textproc/perl2html/files/patch-aa
@@ -1,6 +1,6 @@
---- Makefile.in.orig Wed May 26 19:31:36 1999
-+++ Makefile.in Thu May 27 21:54:22 1999
-@@ -9,7 +9,7 @@
+--- Makefile.in.orig Sat Apr 15 17:16:42 2000
++++ Makefile.in Sun Apr 23 15:58:22 2000
+@@ -27,7 +27,7 @@
# for gzip because otherwise the load on the web server
# grows without having big benefits.
# COMPRESSION = -DCOMPRESSION=4
@@ -9,12 +9,36 @@
# Dont change things beyond this line.
TARGET = @PROJECT_NAME@
-@@ -40,7 +40,7 @@
- srcdir = @srcdir@
+@@ -59,7 +59,7 @@
+ docdir = @DOCDIR@
CPPFLAGS = @CPPFLAGS@
-CFLAGS += -O2 -Wall
+CFLAGS ?= -O2 -Wall
- ALL_CFLAGS = $(CFLAGS) -I$(srcdir) $(COMPRESSION)
+ ALL_CFLAGS = $(CFLAGS) -I$(srcdir) -I. $(COMPRESSION)
all: $(TARGET)
+@@ -70,10 +70,12 @@
+ $(LEXOUTPUT): $(CONFIGS) $(LEXSRCS) $(HDRS)
+ $(LEX) $(LEXSRCS)
+
+-install: $(TARGET) install-doc
++install: $(TARGET)
+ @echo "Installing" $(TARGET) "to" $(bindir)
+ -mkdir -p $(bindir)
+ $(INSTALL_PROGRAM) $(TARGET) $(bindir)/$(TARGET)
++ -mkdir -p $(man1dir)
++ $(INSTALL_DATA) $(srcdir)/$(MANPAGE) $(man1dir)/$(MANPAGE)
+
+ install-strip: $(TARGET) install-doc
+ @echo "Installing" $(TARGET) "to" $(bindir)
+@@ -81,8 +83,7 @@
+ $(INSTALL_PROGRAM) -s $(TARGET) $(bindir)/$(TARGET)
+
+ install-doc:
+- -mkdir -p $(man1dir) $(docdir)
+- $(INSTALL_DATA) $(srcdir)/$(MANPAGE) $(man1dir)/$(MANPAGE)
++ -mkdir -p $(docdir)
+ $(INSTALL_DATA) $(srcdir)/AUTHORS $(docdir)/AUTHORS
+ $(INSTALL_DATA) $(srcdir)/COPYING $(docdir)/COPYING
+ $(INSTALL_DATA) $(srcdir)/NEWS $(docdir)/NEWS