aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
Diffstat (limited to 'textproc')
-rw-r--r--textproc/p5-XML-DOM/Makefile5
-rw-r--r--textproc/p5-XML-Parser/Makefile8
2 files changed, 4 insertions, 9 deletions
diff --git a/textproc/p5-XML-DOM/Makefile b/textproc/p5-XML-DOM/Makefile
index 534fed749ca5..a8837bf61b96 100644
--- a/textproc/p5-XML-DOM/Makefile
+++ b/textproc/p5-XML-DOM/Makefile
@@ -16,12 +16,9 @@ MAINTAINER= kuriyama@FreeBSD.org
RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
-USE_PERL5= yes
+PERL_CONFIGURE= yes
MAN3= XML::DOM.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-do-configure:
- @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
-
.include <bsd.port.mk>
diff --git a/textproc/p5-XML-Parser/Makefile b/textproc/p5-XML-Parser/Makefile
index 8a1061f4bac2..c2c762ff4ce0 100644
--- a/textproc/p5-XML-Parser/Makefile
+++ b/textproc/p5-XML-Parser/Makefile
@@ -18,15 +18,13 @@ MAINTAINER= kuriyama@FreeBSD.org
LIB_DEPENDS= expat.2:${PORTSDIR}/textproc/expat2
-USE_PERL5= yes
+PERL_CONFIGURE= yes
+CONFIGURE_ARGS= EXPATLIBPATH=${LOCALBASE}/lib EXPATINCPATH=${LOCALBASE}/include
MAN3= XML::Parser.3 XML::Parser::Expat.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-do-configure:
- @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
- CC="${CC}" CCFLAGS="${CFLAGS}" \
- EXPATLIBPATH=${LOCALBASE}/lib EXPATINCPATH=${LOCALBASE}/include
+post-configure:
@${PERL} -i -pe 's/^(CC = ).*/$$1 ${CC}/;' \
-e 's/^(CCFLAGS = ).*/$$1 ${CFLAGS}/' ${WRKSRC}/Expat/Makefile