aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile2
-rw-r--r--textproc/exempi/Makefile30
-rw-r--r--textproc/exempi/distinfo3
-rw-r--r--textproc/exempi/files/patch-source_XMPFiles_FormatSupport_EndianUtils.hpp11
-rw-r--r--textproc/exempi/files/patch-source_XMPFiles_FormatSupport_Reconcile_Impl.cpp20
-rw-r--r--textproc/exempi/pkg-descr3
-rw-r--r--textproc/exempi/pkg-plist10
-rw-r--r--textproc/gstreamer-plugins-annodex/Makefile18
-rw-r--r--textproc/gtk-doc/Makefile4
-rw-r--r--textproc/gtk-doc/distinfo6
-rw-r--r--textproc/gtk-doc/pkg-plist1
-rw-r--r--textproc/intltool/Makefile4
-rw-r--r--textproc/intltool/distinfo6
-rw-r--r--textproc/libtranslate/Makefile2
-rw-r--r--textproc/libxml++26/Makefile4
-rw-r--r--textproc/libxml++26/distinfo6
-rw-r--r--textproc/libxml++26/files/patch-libxml++::parsers::parser.cc10
-rw-r--r--textproc/rarian/Makefile8
-rw-r--r--textproc/rarian/distinfo6
-rw-r--r--textproc/rarian/pkg-plist5
20 files changed, 123 insertions, 36 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 5715c586c658..973c7cddb13f 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -138,6 +138,7 @@
SUBDIR += et-aspell
SUBDIR += etoile-lucenekit
SUBDIR += etoile-ogrekit
+ SUBDIR += exempi
SUBDIR += exml
SUBDIR += expat2
SUBDIR += exslt
@@ -176,6 +177,7 @@
SUBDIR += gpp
SUBDIR += grap
SUBDIR += gsed
+ SUBDIR += gstreamer-plugins-annodex
SUBDIR += gtk-doc
SUBDIR += gtkdiff
SUBDIR += gtkspell
diff --git a/textproc/exempi/Makefile b/textproc/exempi/Makefile
new file mode 100644
index 000000000000..b71435688511
--- /dev/null
+++ b/textproc/exempi/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: exempi
+# Date created: 2008-02-26
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/textproc/exempi/Makefile,v 1.1 2008/02/26 18:50:26 ahze Exp $
+
+PORTNAME= exempi
+PORTVERSION= 1.99.9
+CATEGORIES= textproc
+MASTER_SITES= http://libopenraw.freedesktop.org/download/
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= A port of Adobe XMP SDK to work on UNIX
+
+LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
+
+USE_AUTOTOOLS= libtool:15
+USE_GNOME= ltverhack gnomehack
+CONFIGURE_ARGS= --enable-unittest=no
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib" \
+ LIBS="-liconv"
+USE_ICONV= yes
+USE_LDCONFIG= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|$${libdir}/pkgconfig|${PREFIX}/libdata/pkgconfig|' \
+ ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/textproc/exempi/distinfo b/textproc/exempi/distinfo
new file mode 100644
index 000000000000..045db78a114b
--- /dev/null
+++ b/textproc/exempi/distinfo
@@ -0,0 +1,3 @@
+MD5 (exempi-1.99.9.tar.gz) = 8fb6c6230a4862b8c82b4b76be6ffb1e
+SHA256 (exempi-1.99.9.tar.gz) = 10104ff8405604b32583fb8c8731c038525aeacf6c4a44f2845649964a3c9a7b
+SIZE (exempi-1.99.9.tar.gz) = 3063146
diff --git a/textproc/exempi/files/patch-source_XMPFiles_FormatSupport_EndianUtils.hpp b/textproc/exempi/files/patch-source_XMPFiles_FormatSupport_EndianUtils.hpp
new file mode 100644
index 000000000000..658138633b92
--- /dev/null
+++ b/textproc/exempi/files/patch-source_XMPFiles_FormatSupport_EndianUtils.hpp
@@ -0,0 +1,11 @@
+--- source/XMPFiles/FormatSupport/EndianUtils.hpp.orig 2008-02-26 11:51:10.000000000 -0500
++++ source/XMPFiles/FormatSupport/EndianUtils.hpp 2008-02-26 11:51:17.000000000 -0500
+@@ -38,7 +38,7 @@
+ #endif
+ #endif
+ #elif XMP_UNIXBuild
+-#include <endian.h>
++#include <machine/endian.h>
+ #if BYTE_ORDER == BIG_ENDIAN
+ #define kBigEndianHost 1
+ #elif BYTE_ORDER == LITTLE_ENDIAN
diff --git a/textproc/exempi/files/patch-source_XMPFiles_FormatSupport_Reconcile_Impl.cpp b/textproc/exempi/files/patch-source_XMPFiles_FormatSupport_Reconcile_Impl.cpp
new file mode 100644
index 000000000000..90e3f7c221e5
--- /dev/null
+++ b/textproc/exempi/files/patch-source_XMPFiles_FormatSupport_Reconcile_Impl.cpp
@@ -0,0 +1,20 @@
+--- source/XMPFiles/FormatSupport/Reconcile_Impl.cpp.orig 2008-02-26 11:56:56.000000000 -0500
++++ source/XMPFiles/FormatSupport/Reconcile_Impl.cpp 2008-02-26 12:04:09.000000000 -0500
+@@ -249,7 +249,7 @@
+
+ iconv_t cd = iconv_open( "ISO8859-1", "UTF-8" );
+
+- char * in = (char *)utf8Ptr;
++ const char * in = (char *)utf8Ptr;
+ size_t inLen = utf8Len;
+ size_t outLen = utf8Len * 4;
+ char * buf = (char *)calloc( outLen, 1 );
+@@ -406,7 +406,7 @@
+
+ iconv_t cd = iconv_open( "UTF-8", "ISO8859-1" );
+
+- char * in = (char *)_latin1Ptr;
++ const char * in = (char *)_latin1Ptr;
+ size_t inLen = latin1Len;
+ size_t outLen = latin1Len * 4;
+ char * buf = (char *)calloc( outLen, 1 );
diff --git a/textproc/exempi/pkg-descr b/textproc/exempi/pkg-descr
new file mode 100644
index 000000000000..543d5a0c3fea
--- /dev/null
+++ b/textproc/exempi/pkg-descr
@@ -0,0 +1,3 @@
+Exempi is an implementation of XMP and is based on Adobe XMP SDK
+
+WWW: http://libopenraw.freedesktop.org/wiki/Exempi
diff --git a/textproc/exempi/pkg-plist b/textproc/exempi/pkg-plist
new file mode 100644
index 000000000000..2e039e9feda0
--- /dev/null
+++ b/textproc/exempi/pkg-plist
@@ -0,0 +1,10 @@
+include/exempi-2.0/exempi/xmp.h
+include/exempi-2.0/exempi/xmpconsts.h
+include/exempi-2.0/exempi/xmperrors.h
+lib/libexempi.a
+lib/libexempi.la
+lib/libexempi.so
+lib/libexempi.so.3
+libdata/pkgconfig/exempi-2.0.pc
+@dirrm include/exempi-2.0/exempi
+@dirrm include/exempi-2.0
diff --git a/textproc/gstreamer-plugins-annodex/Makefile b/textproc/gstreamer-plugins-annodex/Makefile
new file mode 100644
index 000000000000..99a108019c2e
--- /dev/null
+++ b/textproc/gstreamer-plugins-annodex/Makefile
@@ -0,0 +1,18 @@
+# New ports collection makefile for: gstreamer-plugins-annodex
+# Date created: 14 Feb 2008
+# Whom: Koop Mast <kwm@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/textproc/gstreamer-plugins-annodex/Makefile,v 1.3 2008/03/19 14:05:38 ahze Exp $
+#
+
+PORTREVISION= 2
+CATEGORIES= textproc
+
+COMMENT= Gstreamer annodex xml plugin
+
+GST_PLUGIN= annodex
+
+MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/gtk-doc/Makefile b/textproc/gtk-doc/Makefile
index 88a1e8fe3558..66c69477af04 100644
--- a/textproc/gtk-doc/Makefile
+++ b/textproc/gtk-doc/Makefile
@@ -3,10 +3,10 @@
# Whom: fenner
#
# $FreeBSD$
-#
+# $MCom: ports/textproc/gtk-doc/Makefile,v 1.6 2008/03/19 21:35:45 ahze Exp $
PORTNAME= gtk-doc
-PORTVERSION= 1.9
+PORTVERSION= 1.10
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
diff --git a/textproc/gtk-doc/distinfo b/textproc/gtk-doc/distinfo
index 9fc10e82f9d1..07090c873a37 100644
--- a/textproc/gtk-doc/distinfo
+++ b/textproc/gtk-doc/distinfo
@@ -1,3 +1,3 @@
-MD5 (gtk-doc-1.9.tar.bz2) = bcd002f381385812737a05538eb8b21e
-SHA256 (gtk-doc-1.9.tar.bz2) = d1be2fc7be880b912f871675baed4a9e28ee4c19eef7fd1299c9c5d11cc9a80d
-SIZE (gtk-doc-1.9.tar.bz2) = 391957
+MD5 (gtk-doc-1.10.tar.bz2) = cbd4be396b0cf8b8ce1fc9b927cdf451
+SHA256 (gtk-doc-1.10.tar.bz2) = 5aeefd055c47d4e8b906e7f74b7769ebafbe3873d90cb9987b2ec503a9b558eb
+SIZE (gtk-doc-1.10.tar.bz2) = 404379
diff --git a/textproc/gtk-doc/pkg-plist b/textproc/gtk-doc/pkg-plist
index 52438fd79b66..980a8451a8aa 100644
--- a/textproc/gtk-doc/pkg-plist
+++ b/textproc/gtk-doc/pkg-plist
@@ -1,4 +1,5 @@
bin/gtkdoc-check
+bin/gtkdoc-depscan
bin/gtkdoc-fixxref
bin/gtkdoc-mkdb
bin/gtkdoc-mkhtml
diff --git a/textproc/intltool/Makefile b/textproc/intltool/Makefile
index 0f6909e71656..08aab60d1035 100644
--- a/textproc/intltool/Makefile
+++ b/textproc/intltool/Makefile
@@ -3,10 +3,10 @@
# Whom: Ade Lovett <ade@FreeBSD.org>
#
# $FreeBSD$
-#
+# $MCom: ports/textproc/intltool/Makefile,v 1.4 2008/02/25 10:42:46 kwm Exp $
PORTNAME= intltool
-PORTVERSION= 0.36.3
+PORTVERSION= 0.37.1
CATEGORIES= textproc gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome
diff --git a/textproc/intltool/distinfo b/textproc/intltool/distinfo
index 7cffabd10f18..a7fc9a8f6690 100644
--- a/textproc/intltool/distinfo
+++ b/textproc/intltool/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome/intltool-0.36.3.tar.bz2) = 4a4428eedf69ac2717f2353b742fe42e
-SHA256 (gnome/intltool-0.36.3.tar.bz2) = ba1c9907de4b4e89f73e753bc7861334625366406b237846bf357787466aa05e
-SIZE (gnome/intltool-0.36.3.tar.bz2) = 138644
+MD5 (gnome/intltool-0.37.1.tar.bz2) = 860d392f04299c2740d0752501639c3b
+SHA256 (gnome/intltool-0.37.1.tar.bz2) = 76cceaaaf188dfac032b21eb5dc4c7d231efe7ff180dee85dbf5e18bc5d27fe7
+SIZE (gnome/intltool-0.37.1.tar.bz2) = 139016
diff --git a/textproc/libtranslate/Makefile b/textproc/libtranslate/Makefile
index d707c4bfcb91..f9c0db4fe289 100644
--- a/textproc/libtranslate/Makefile
+++ b/textproc/libtranslate/Makefile
@@ -37,7 +37,7 @@ PLIST_SUB+= GENERIC="@comment "
.else
PLIST_SUB+= GENERIC=""
USE_GNOME+= libxml2
-LIB_DEPENDS+= soup-2.2:${PORTSDIR}/devel/libsoup
+LIB_DEPENDS+= soup-2.2:${PORTSDIR}/devel/libsoup22
MAN5+= services.xml.5
.endif
diff --git a/textproc/libxml++26/Makefile b/textproc/libxml++26/Makefile
index c2fe64402f72..665bee127469 100644
--- a/textproc/libxml++26/Makefile
+++ b/textproc/libxml++26/Makefile
@@ -4,11 +4,11 @@
# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/textproc/libxml++26/Makefile,v 1.22 2007/09/18 16:36:01 marcus Exp $
+# $MCom: ports/textproc/libxml++26/Makefile,v 1.25 2008/03/11 04:21:47 mezz Exp $
#
PORTNAME= libxml++
-PORTVERSION= 2.20.0
+PORTVERSION= 2.22.0
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
diff --git a/textproc/libxml++26/distinfo b/textproc/libxml++26/distinfo
index 7ae26a4ff694..53634aaaf134 100644
--- a/textproc/libxml++26/distinfo
+++ b/textproc/libxml++26/distinfo
@@ -1,3 +1,3 @@
-MD5 (libxml++-2.20.0.tar.gz) = 0f6a95220c7cd893e711f85ad4056a1c
-SHA256 (libxml++-2.20.0.tar.gz) = 4b77156f6590a294aea179f2c42c2ced6b97368552be1298ee1ed072ca2e130e
-SIZE (libxml++-2.20.0.tar.gz) = 2044144
+MD5 (libxml++-2.22.0.tar.gz) = 0ed7e73ba783839af8ddc0fb81a22526
+SHA256 (libxml++-2.22.0.tar.gz) = 4a874ae2b6608a989523cec96b08034f03e02ac6ec8a1aa271fc1eca141016ab
+SIZE (libxml++-2.22.0.tar.gz) = 2067450
diff --git a/textproc/libxml++26/files/patch-libxml++::parsers::parser.cc b/textproc/libxml++26/files/patch-libxml++::parsers::parser.cc
deleted file mode 100644
index c77f306e95b6..000000000000
--- a/textproc/libxml++26/files/patch-libxml++::parsers::parser.cc
+++ /dev/null
@@ -1,10 +0,0 @@
---- libxml++/parsers/parser.cc.orig Sat Feb 7 02:11:35 2004
-+++ libxml++/parsers/parser.cc Fri Feb 20 00:02:22 2004
-@@ -9,6 +9,7 @@
- #include <libxml/parser.h>
-
- #include <cstdarg> //For va_list.
-+#include <memory>
-
- namespace xmlpp {
-
diff --git a/textproc/rarian/Makefile b/textproc/rarian/Makefile
index f8d0260c8988..5804e61789ae 100644
--- a/textproc/rarian/Makefile
+++ b/textproc/rarian/Makefile
@@ -3,15 +3,13 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/textproc/rarian/Makefile,v 1.8 2007/10/11 04:04:18 mezz Exp $
+# $MCom: ports/textproc/rarian/Makefile,v 1.12 2008/03/09 21:41:22 mezz Exp $
#
PORTNAME= rarian
-PORTVERSION= 0.6.0
-PORTREVISION= 1
+PORTVERSION= 0.8.0
CATEGORIES= textproc gnome
-MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
+MASTER_SITES= GNOME
MAINTAINER= gnome@FreeBSD.org
COMMENT= An OMF help system based on the Freedesktop specification
diff --git a/textproc/rarian/distinfo b/textproc/rarian/distinfo
index c10840549f71..5994d6d55ed6 100644
--- a/textproc/rarian/distinfo
+++ b/textproc/rarian/distinfo
@@ -1,3 +1,3 @@
-MD5 (rarian-0.6.0.tar.bz2) = 23772a3b0f882d13c86dd9fa67bb21bf
-SHA256 (rarian-0.6.0.tar.bz2) = 2f169f3c794b2602d8590b1fd16c0aa5b7ca77e993f74b89c4f42db74c1d2029
-SIZE (rarian-0.6.0.tar.bz2) = 312258
+MD5 (rarian-0.8.0.tar.bz2) = 67e2d3ab27edcebdae9b85733712805e
+SHA256 (rarian-0.8.0.tar.bz2) = 93f97611ead9a5ed4aed468532c0543f0f8cdfed350f94ba8b0f789a10a1de9c
+SIZE (rarian-0.8.0.tar.bz2) = 338724
diff --git a/textproc/rarian/pkg-plist b/textproc/rarian/pkg-plist
index 1abb978331bc..bf7762d27b6b 100644
--- a/textproc/rarian/pkg-plist
+++ b/textproc/rarian/pkg-plist
@@ -26,6 +26,7 @@ bin/scrollkeeper-rebuilddb
bin/scrollkeeper-uninstall
bin/scrollkeeper-update
include/rarian/rarian-info.h
+include/rarian/rarian-main.h
include/rarian/rarian-man.h
include/rarian/rarian-reg-utils.h
include/rarian/rarian.h
@@ -34,7 +35,7 @@ lib/librarian.la
lib/librarian.so
lib/librarian.so.0
libdata/pkgconfig/rarian.pc
-share/doc/rarian/rarian.document
+%%DOCSDIR%%/rarian.document
share/librarian/Templates/C/scrollkeeper_cl.xml
share/librarian/manual/help-spec-0.2.xml
share/librarian/manual/index.xhtml
@@ -46,7 +47,7 @@ share/librarian/rarian-sk-cl.xml
@dirrm share/librarian/Templates/C
@dirrm share/librarian/Templates
@dirrm share/librarian
-@dirrm share/doc/rarian
+@dirrm %%DOCSDIR%%
@dirrm include/rarian
@unexec rm -rf /var/db/scrollkeeper 2>/dev/null || true
@exec mkdir -p /var/db/rarian