aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-String-Compare-ConstantTime/Makefile18
-rw-r--r--textproc/p5-String-Compare-ConstantTime/distinfo2
-rw-r--r--textproc/p5-String-Compare-ConstantTime/pkg-descr8
-rw-r--r--textproc/p5-String-Compare-ConstantTime/pkg-plist10
5 files changed, 39 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 6448f6875210..0319b6d52b5a 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -723,6 +723,7 @@
SUBDIR += p5-Spreadsheet-XLSX
SUBDIR += p5-String-BufferStack
SUBDIR += p5-String-CamelCase
+ SUBDIR += p5-String-Compare-ConstantTime
SUBDIR += p5-String-Divert
SUBDIR += p5-String-Escape
SUBDIR += p5-String-Flogger
diff --git a/textproc/p5-String-Compare-ConstantTime/Makefile b/textproc/p5-String-Compare-ConstantTime/Makefile
new file mode 100644
index 000000000000..19a4ff4c49b9
--- /dev/null
+++ b/textproc/p5-String-Compare-ConstantTime/Makefile
@@ -0,0 +1,18 @@
+# $FreeBSD$
+
+PORTNAME= String-Compare-ConstantTime
+PORTVERSION= 0.300
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for timing side-channel protected string compare
+
+USES= perl5
+USE_PERL5= configure
+
+MAN3= String::Compare::ConstantTime.3 \
+ String::Compare::README.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-String-Compare-ConstantTime/distinfo b/textproc/p5-String-Compare-ConstantTime/distinfo
new file mode 100644
index 000000000000..fa61e6a5f09a
--- /dev/null
+++ b/textproc/p5-String-Compare-ConstantTime/distinfo
@@ -0,0 +1,2 @@
+SHA256 (String-Compare-ConstantTime-0.300.tar.gz) = 579593451de15653f28c69fec61f4a7b987e8a1236b35e3a407241f6e9ce4f6f
+SIZE (String-Compare-ConstantTime-0.300.tar.gz) = 5210
diff --git a/textproc/p5-String-Compare-ConstantTime/pkg-descr b/textproc/p5-String-Compare-ConstantTime/pkg-descr
new file mode 100644
index 000000000000..adee8a7ed218
--- /dev/null
+++ b/textproc/p5-String-Compare-ConstantTime/pkg-descr
@@ -0,0 +1,8 @@
+This module provides one function, equals (not exported by default).
+
+You should pass this function two strings of the same length. It will
+return true if they are string-wise identical and false otherwise,
+just like eq. However, comparing any two differing strings will take
+a fixed amount of time, unlike eq.
+
+WWW: http://search.cpan.org/dist/String-Compare-ConstantTime/
diff --git a/textproc/p5-String-Compare-ConstantTime/pkg-plist b/textproc/p5-String-Compare-ConstantTime/pkg-plist
new file mode 100644
index 000000000000..794351e51898
--- /dev/null
+++ b/textproc/p5-String-Compare-ConstantTime/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/String/Compare/ConstantTime/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/String/Compare/ConstantTime/ConstantTime.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/String/Compare/ConstantTime/ConstantTime.so
+%%SITE_PERL%%/%%PERL_ARCH%%/String/Compare/README.pod
+%%SITE_PERL%%/%%PERL_ARCH%%/String/Compare/ConstantTime.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/String/Compare
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/String
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/String/Compare/ConstantTime
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/String/Compare
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/String