aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile10
-rw-r--r--textproc/bg-mythes/Makefile32
-rw-r--r--textproc/bg-mythes/distinfo2
-rw-r--r--textproc/bg-mythes/pkg-descr3
-rw-r--r--textproc/cs-mythes/Makefile30
-rw-r--r--textproc/cs-mythes/distinfo2
-rw-r--r--textproc/cs-mythes/pkg-descr1
-rw-r--r--textproc/en-mythes/Makefile44
-rw-r--r--textproc/en-mythes/distinfo2
-rw-r--r--textproc/en-mythes/pkg-descr1
-rw-r--r--textproc/es-mythes/Makefile44
-rw-r--r--textproc/es-mythes/distinfo2
-rw-r--r--textproc/es-mythes/pkg-descr3
-rw-r--r--textproc/it-mythes/Makefile28
-rw-r--r--textproc/it-mythes/distinfo2
-rw-r--r--textproc/it-mythes/pkg-descr3
-rw-r--r--textproc/nl-mythes/Makefile44
-rw-r--r--textproc/nl-mythes/distinfo2
-rw-r--r--textproc/nl-mythes/pkg-descr3
-rw-r--r--textproc/ro-mythes/Makefile30
-rw-r--r--textproc/ro-mythes/distinfo2
-rw-r--r--textproc/ro-mythes/pkg-descr3
-rw-r--r--textproc/sl-mythes/Makefile30
-rw-r--r--textproc/sl-mythes/distinfo2
-rw-r--r--textproc/sl-mythes/pkg-descr3
25 files changed, 328 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 66315ce91a96..500f15613ed9 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -36,6 +36,7 @@
SUBDIR += beediff
SUBDIR += bg-aspell
SUBDIR += bg-hyphen
+ SUBDIR += bg-mythes
SUBDIR += bib2html
SUBDIR += bibtex2html
SUBDIR += bibtool
@@ -74,6 +75,7 @@
SUBDIR += cost
SUBDIR += crimson
SUBDIR += cs-aspell
+ SUBDIR += cs-mythes
SUBDIR += csb-aspell
SUBDIR += csv2latex
SUBDIR += csv2xml
@@ -148,6 +150,7 @@
SUBDIR += emacs-wiki
SUBDIR += en-aspell
SUBDIR += en-hunspell
+ SUBDIR += en-mythes
SUBDIR += enchant
SUBDIR += eo-aspell
SUBDIR += eqe
@@ -156,6 +159,7 @@
SUBDIR += es-hunspell
SUBDIR += es-hyphen
SUBDIR += es-ispell
+ SUBDIR += es-mythes
SUBDIR += estraier
SUBDIR += et-aspell
SUBDIR += etoile-lucenekit
@@ -298,6 +302,7 @@
SUBDIR += it-hunspell
SUBDIR += it-hyphen
SUBDIR += it-ispell
+ SUBDIR += it-mythes
SUBDIR += jade
SUBDIR += jakarta-commons-digester
SUBDIR += jakarta-poi
@@ -427,6 +432,7 @@
SUBDIR += nl-aspell
SUBDIR += nl-hyphen
SUBDIR += nl-ispell
+ SUBDIR += nl-mythes
SUBDIR += nltk
SUBDIR += nn-aspell
SUBDIR += no-hunspell
@@ -1129,6 +1135,7 @@
SUBDIR += ro-aspell
SUBDIR += ro-hunspell
SUBDIR += ro-hyphen
+ SUBDIR += ro-mythes
SUBDIR += roap
SUBDIR += romdict
SUBDIR += rot
@@ -1244,10 +1251,12 @@
SUBDIR += sk-hunspell
SUBDIR += sk-hyphen
SUBDIR += sk-ispell
+ SUBDIR += sk-mythes
SUBDIR += skim
SUBDIR += skribe
SUBDIR += sl-aspell
SUBDIR += sl-hyphen
+ SUBDIR += sl-mythes
SUBDIR += slides
SUBDIR += sml-fxp
SUBDIR += smu
@@ -1278,6 +1287,7 @@
SUBDIR += supercat
SUBDIR += sv-aspell
SUBDIR += sv-hyphen
+ SUBDIR += sv-mythes
SUBDIR += svn2cl
SUBDIR += sw-aspell
SUBDIR += sw-hunspell
diff --git a/textproc/bg-mythes/Makefile b/textproc/bg-mythes/Makefile
new file mode 100644
index 000000000000..961b65ac162c
--- /dev/null
+++ b/textproc/bg-mythes/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: bg-mythes
+# Date created: 2011-07-21
+# Whom: Baptiste Daroussin <bapt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bg-mythes
+PORTVERSION= 4.3
+CATEGORIES= textproc
+MASTER_SITES= SF/bgoffice/OpenOffice.org%20Thesaurus%20BG/${PORTVERSION}/
+DISTNAME= OOo-thes-bg-${PORTVERSION}
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= Bulgarian thesaurus
+
+LICENSE= GPLv2 LGPL21 MPL
+LICENSE_COMB= dual
+
+USE_ZIP= yes
+NO_BUILD= yes
+
+PLIST_FILES= share/mythes/th_bg_BG.dat \
+ share/mythes/th_bg_BG.idx
+
+PLIST_DIRS= share/mythes
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/mythes
+ @${INSTALL_DATA} ${WRKSRC}/th_bg_BG.* ${PREFIX}/share/mythes
+
+.include <bsd.port.mk>
diff --git a/textproc/bg-mythes/distinfo b/textproc/bg-mythes/distinfo
new file mode 100644
index 000000000000..b61a6b0d1d89
--- /dev/null
+++ b/textproc/bg-mythes/distinfo
@@ -0,0 +1,2 @@
+SHA256 (OOo-thes-bg-4.3.zip) = 48489358065feee858d4f068b3c6fecbda6372df2c68383212fd947f29c74496
+SIZE (OOo-thes-bg-4.3.zip) = 1084454
diff --git a/textproc/bg-mythes/pkg-descr b/textproc/bg-mythes/pkg-descr
new file mode 100644
index 000000000000..45483bab3338
--- /dev/null
+++ b/textproc/bg-mythes/pkg-descr
@@ -0,0 +1,3 @@
+Bulgarian thesaurus
+
+WWW: http://bgoffice.sourceforge.net
diff --git a/textproc/cs-mythes/Makefile b/textproc/cs-mythes/Makefile
new file mode 100644
index 000000000000..b77c3659b8ed
--- /dev/null
+++ b/textproc/cs-mythes/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: cs-mythes
+# Date created: 2011-07-21
+# Whom: Baptiste Daroussin <bapt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cs-mythes
+PORTVERSION= 2007.09.26
+CATEGORIES= textproc
+MASTER_SITES= http://ftp.osuosl.org/pub/openoffice/contrib/dictionaries/
+DISTNAME= thes_cs_CZ_v2
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= Czech thesaurus
+
+LICENSE= BSD
+
+USE_ZIP= yes
+NO_BUILD= yes
+
+PLIST_FILES= share/mythes/th_cs_CZ_v2.dat \
+ share/mythes/th_cs_CZ_v2.idx
+PLIST_DIRS= share/mythes
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/mythes
+ @${INSTALL_DATA} ${WRKDIR}/th_cs_CZ_v2.* ${PREFIX}/share/mythes
+
+.include <bsd.port.mk>
diff --git a/textproc/cs-mythes/distinfo b/textproc/cs-mythes/distinfo
new file mode 100644
index 000000000000..da4dc25f9ce6
--- /dev/null
+++ b/textproc/cs-mythes/distinfo
@@ -0,0 +1,2 @@
+SHA256 (thes_cs_CZ_v2.zip) = 2b5660c2dd375a5475b5c2e24828e43ee001c9755e24b50a877d92aba6eb2728
+SIZE (thes_cs_CZ_v2.zip) = 260389
diff --git a/textproc/cs-mythes/pkg-descr b/textproc/cs-mythes/pkg-descr
new file mode 100644
index 000000000000..c1ed12d7078f
--- /dev/null
+++ b/textproc/cs-mythes/pkg-descr
@@ -0,0 +1 @@
+Czech thesaurus
diff --git a/textproc/en-mythes/Makefile b/textproc/en-mythes/Makefile
new file mode 100644
index 000000000000..480e562dfbc6
--- /dev/null
+++ b/textproc/en-mythes/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: en-mythes
+# Date created: 2011-07-21
+# Whom: Baptiste Daroussin <bapt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= en-mythes
+PORTVERSION= 2006.12.08
+CATEGORIES= textproc
+MASTER_SITES= http://ftp.osuosl.org/pub/openoffice/contrib/dictionaries/
+DISTNAME= thes_en_US_v2
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= English thesaurus
+
+LICENSE= LGPL21
+
+USE_ZIP= yes
+NO_BUILD= yes
+
+USALIASES= en_AG en_AU en_BS en_BW en_BZ en_CA en_DK en_GB en_GH en_IE \
+ en_IN en_JM en_NA en_NG en_NZ en_PH en_SG en_TT en_ZA en_ZW
+
+PLIST_FILES= share/mythes/th_en_US_v2.dat \
+ share/mythes/th_en_US_v2.idx
+
+.for ALIAS in ${USALIASES}
+PLIST_FILES+= share/mythes/th_${ALIAS}_v2.dat \
+ share/mythes/th_${ALIAS}_v2.idx
+.endfor
+
+PLIST_DIRS= share/mythes
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/mythes
+ @${INSTALL_DATA} ${WRKDIR}/th_en_US_v2.* ${PREFIX}/share/mythes
+ @cd ${PREFIX}/share/mythes; \
+ for alias in ${USALIASES}; do \
+ ${LN} -s th_en_US_v2.idx th_$${alias}_v2.idx ; \
+ ${LN} -s th_en_US_v2.dat th_$${alias}_v2.dat ; \
+ done
+
+.include <bsd.port.mk>
diff --git a/textproc/en-mythes/distinfo b/textproc/en-mythes/distinfo
new file mode 100644
index 000000000000..ee48a4f4cef7
--- /dev/null
+++ b/textproc/en-mythes/distinfo
@@ -0,0 +1,2 @@
+SHA256 (thes_en_US_v2.zip) = 0e1362f89572ec50aa46ca2db4980356b7c759a5a5610e892802a28427425a3b
+SIZE (thes_en_US_v2.zip) = 5162416
diff --git a/textproc/en-mythes/pkg-descr b/textproc/en-mythes/pkg-descr
new file mode 100644
index 000000000000..4f4a1c1d07d6
--- /dev/null
+++ b/textproc/en-mythes/pkg-descr
@@ -0,0 +1 @@
+English thesaurus
diff --git a/textproc/es-mythes/Makefile b/textproc/es-mythes/Makefile
new file mode 100644
index 000000000000..3ef045a1ed51
--- /dev/null
+++ b/textproc/es-mythes/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: es-mythes
+# Date created: 2011-07-21
+# Whom: Baptiste Daroussin <bapt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= es-mythes
+PORTVERSION= 20101002
+CATEGORIES= textproc
+MASTER_SITES= http://openthes-es.berlios.de/download/
+DISTNAME= OOo2-thes_es_ES
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= Spanish thesaurus
+
+LICENSE= LGPL21
+
+USE_BZIP2= yes
+NO_BUILD= yes
+
+ESALIASES= es_AR es_BO es_CL es_CO es_CR es_CU es_DO es_EC es_GT es_HN es_MX \
+ es_NI es_PA es_PE es_PR es_PY es_SV es_US es_UY es_VE
+
+PLIST_FILES= share/mythes/th_es_ES_v2.dat \
+ share/mythes/th_es_ES_v2.idx
+
+.for ALIAS in ${ESALIASES}
+PLIST_FILES+= share/mythes/th_${ALIAS}_v2.dat \
+ share/mythes/th_${ALIAS}_v2.idx
+.endfor
+
+PLIST_DIRS= share/mythes
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/mythes
+ @${INSTALL_DATA} ${WRKDIR}/th_es_ES_v2.* ${PREFIX}/share/mythes
+ @cd ${PREFIX}/share/mythes; \
+ for alias in ${ESALIASES}; do \
+ ${LN} -s th_es_ES_v2.idx th_$${alias}_v2.idx ; \
+ ${LN} -s th_es_ES_v2.dat th_$${alias}_v2.dat ; \
+ done
+
+.include <bsd.port.mk>
diff --git a/textproc/es-mythes/distinfo b/textproc/es-mythes/distinfo
new file mode 100644
index 000000000000..9ba0cb63d80d
--- /dev/null
+++ b/textproc/es-mythes/distinfo
@@ -0,0 +1,2 @@
+SHA256 (OOo2-thes_es_ES.tar.bz2) = 299a93d528ec3e22a9cccb6385b458de8740e1a5d131680cd42989e2d49171ca
+SIZE (OOo2-thes_es_ES.tar.bz2) = 824556
diff --git a/textproc/es-mythes/pkg-descr b/textproc/es-mythes/pkg-descr
new file mode 100644
index 000000000000..e19e90300775
--- /dev/null
+++ b/textproc/es-mythes/pkg-descr
@@ -0,0 +1,3 @@
+Spanish thesaurus
+
+WWW: http://openthes-es.berlios.de
diff --git a/textproc/it-mythes/Makefile b/textproc/it-mythes/Makefile
new file mode 100644
index 000000000000..71679f1e0161
--- /dev/null
+++ b/textproc/it-mythes/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: it-mythes
+# Date created: 2011-07-21
+# Whom: Baptiste Daroussin <bapt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= it-mythes
+DISTVERSION= 02_09_l
+CATEGORIES= textproc
+MASTER_SITES= SF/linguistico/Thesaurus%20OOo%202.x.x/${DISTVERSION}_2008_11_29/
+DISTNAME= thesaurus2_it_${DISTVERSION}_2008_11_29
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= Italian thesaurus
+
+USE_ZIP= yes
+NO_BUILD= yes
+
+PLIST_FILES= share/mythes/th_it_IT.dat \
+ share/mythes/th_it_IT.idx
+PLIST_DIRS= share/mythes
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/mythes
+ @${INSTALL_DATA} ${WRKDIR}/th_it_IT.* ${PREFIX}/share/mythes
+
+.include <bsd.port.mk>
diff --git a/textproc/it-mythes/distinfo b/textproc/it-mythes/distinfo
new file mode 100644
index 000000000000..f55272158f95
--- /dev/null
+++ b/textproc/it-mythes/distinfo
@@ -0,0 +1,2 @@
+SHA256 (thesaurus2_it_02_09_l_2008_11_29.zip) = e8223872c3a81c76be7683ad1a3097852e8b916015e2225f35ee72bf345b5522
+SIZE (thesaurus2_it_02_09_l_2008_11_29.zip) = 980279
diff --git a/textproc/it-mythes/pkg-descr b/textproc/it-mythes/pkg-descr
new file mode 100644
index 000000000000..6252452dc13e
--- /dev/null
+++ b/textproc/it-mythes/pkg-descr
@@ -0,0 +1,3 @@
+Italian thesaurus
+
+WWW: http://linguistico.sourceforge.net/pages/thesaurus_italiano.html
diff --git a/textproc/nl-mythes/Makefile b/textproc/nl-mythes/Makefile
new file mode 100644
index 000000000000..b08c1f05ee7e
--- /dev/null
+++ b/textproc/nl-mythes/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: nl-mythes
+# Date created: 2011-07-21
+# Whom: Baptiste Daroussin <bapt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nl-mythes
+PORTVERSION= 2011.06.09
+CATEGORIES= textproc
+MASTER_SITES= http://data.opentaal.org/opentaalbank/thesaurus/download/
+DISTNAME= thes_nl
+EXTRACT_SUFX= .oxt
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= Dutch thesaurus
+
+LICENSE= BSD
+
+USE_ZIP= yes
+NO_BUILD= yes
+
+PLIST_FILES= share/mythes/th_nl_NL_v2.dat \
+ share/mythes/th_nl_NL_v2.idx
+PLIST_DIRS= share/mythes
+
+NLALIASES= nl_AW nl_BE
+
+.for ALIAS in ${NLALIASES}
+PLIST_FILES+= share/mythes/th_${ALIAS}_v2.dat \
+ share/mythes/th_${ALIAS}_v2.idx
+.endfor
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/mythes
+ @${INSTALL_DATA} ${WRKDIR}/th_nl_v2.dat ${PREFIX}/share/mythes/th_nl_NL_v2.dat
+ @${INSTALL_DATA} ${WRKDIR}/th_nl_v2.dat ${PREFIX}/share/mythes/th_nl_NL_v2.idx
+ @cd ${PREFIX}/share/mythes; \
+ for alias in ${NLALIASES}; do \
+ ${LN} -s th_nl_NL_v2.dat th_$${alias}_v2.dat ; \
+ ${LN} -s th_nl_NL_v2.dat th_$${alias}_v2.idx ; \
+ done
+
+.include <bsd.port.mk>
diff --git a/textproc/nl-mythes/distinfo b/textproc/nl-mythes/distinfo
new file mode 100644
index 000000000000..2b9a7700c61f
--- /dev/null
+++ b/textproc/nl-mythes/distinfo
@@ -0,0 +1,2 @@
+SHA256 (thes_nl.oxt) = acbe57725cab867008f831bd623f5c57315c67e372c2af84627de10af369e7e3
+SIZE (thes_nl.oxt) = 1955743
diff --git a/textproc/nl-mythes/pkg-descr b/textproc/nl-mythes/pkg-descr
new file mode 100644
index 000000000000..5f56d2bbd4e5
--- /dev/null
+++ b/textproc/nl-mythes/pkg-descr
@@ -0,0 +1,3 @@
+Dutch thesaurus
+
+WWW: http://data.opentaal.org/opentaalbank/thesaurus
diff --git a/textproc/ro-mythes/Makefile b/textproc/ro-mythes/Makefile
new file mode 100644
index 000000000000..b678de09895f
--- /dev/null
+++ b/textproc/ro-mythes/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: ro-mythes
+# Date created: 2011-07-21
+# Whom: Baptiste Daroussin <bapt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ro-mythes
+PORTVERSION= 3.3
+CATEGORIES= textproc
+MASTER_SITES= SF/rospell/Romanian%20dictionaries/dict-${PORTVERSION}/
+DISTNAME= th_ro_RO.${PORTVERSION}
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= Romanian thesaurus
+
+LICENSE= GPLv2
+
+USE_ZIP= yes
+NO_BUILD= yes
+
+PLIST_FILES= share/mythes/th_ro_RO.dat \
+ share/mythes/th_ro_RO.idx
+PLIST_DIRS= share/mythes
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/mythes
+ @${INSTALL_DATA} ${WRKDIR}/th_ro_RO.* ${PREFIX}/share/mythes
+
+.include <bsd.port.mk>
diff --git a/textproc/ro-mythes/distinfo b/textproc/ro-mythes/distinfo
new file mode 100644
index 000000000000..109a1cae3b12
--- /dev/null
+++ b/textproc/ro-mythes/distinfo
@@ -0,0 +1,2 @@
+SHA256 (th_ro_RO.3.3.zip) = 097f0a58be60859292fb0c8109669d579abd19a500b9d93bda3c16b9aa446be0
+SIZE (th_ro_RO.3.3.zip) = 1235156
diff --git a/textproc/ro-mythes/pkg-descr b/textproc/ro-mythes/pkg-descr
new file mode 100644
index 000000000000..1f6ef08fc7ab
--- /dev/null
+++ b/textproc/ro-mythes/pkg-descr
@@ -0,0 +1,3 @@
+Romanian thesaurus
+
+WWW: http://rospell.sourceforge.net/
diff --git a/textproc/sl-mythes/Makefile b/textproc/sl-mythes/Makefile
new file mode 100644
index 000000000000..a6c721f5c6cf
--- /dev/null
+++ b/textproc/sl-mythes/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: sl-mythes
+# Date created: 2011-07-21
+# Whom: Baptiste Daroussin <bapt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sl-mythes
+PORTVERSION= 2011.07.21
+CATEGORIES= textproc
+MASTER_SITES= http://193.2.66.133:85/download/
+DISTNAME= thes_sl_SI_v2
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= Slovenian thesaurus
+
+LICENSE= LGPL21
+
+USE_ZIP= yes
+NO_BUILD= yes
+
+PLIST_FILES= share/mythes/th_sl_SI_v2.dat \
+ share/mythes/th_sl_SI_v2.idx
+PLIST_DIRS= share/mythes
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/mythes
+ @${INSTALL_DATA} ${WRKDIR}/th_sl_SI_v2.* ${PREFIX}/share/mythes
+
+.include <bsd.port.mk>
diff --git a/textproc/sl-mythes/distinfo b/textproc/sl-mythes/distinfo
new file mode 100644
index 000000000000..f7aac87fc19a
--- /dev/null
+++ b/textproc/sl-mythes/distinfo
@@ -0,0 +1,2 @@
+SHA256 (thes_sl_SI_v2.zip) = d66c9b53ec508f3965b7acdfbf58f74be7fd5a3820731eb29807bab4619e3dae
+SIZE (thes_sl_SI_v2.zip) = 317357
diff --git a/textproc/sl-mythes/pkg-descr b/textproc/sl-mythes/pkg-descr
new file mode 100644
index 000000000000..4ab964635930
--- /dev/null
+++ b/textproc/sl-mythes/pkg-descr
@@ -0,0 +1,3 @@
+Slovenian thesaurus
+
+WWW: http://www.tezaver.si/