aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
Diffstat (limited to 'textproc')
-rw-r--r--textproc/coccigrep/Makefile4
-rw-r--r--textproc/meld/Makefile17
2 files changed, 12 insertions, 9 deletions
diff --git a/textproc/coccigrep/Makefile b/textproc/coccigrep/Makefile
index 7a28272b56a2..08be10146651 100644
--- a/textproc/coccigrep/Makefile
+++ b/textproc/coccigrep/Makefile
@@ -23,13 +23,15 @@ MANCOMPRESSED= no
MAN1= coccigrep.1
+.include <bsd.port.options.mk>
+
post-install:
${INSTALL_MAN} ${WRKSRC}/coccigrep.1 ${MANPREFIX}/man/man1
${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/editors/cocci-grep.el ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/editors/cocci-grep.vim ${DATADIR}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/ChangeLog ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.rst ${DOCSDIR}
diff --git a/textproc/meld/Makefile b/textproc/meld/Makefile
index 82e5c7e6c914..b1563f1fbf14 100644
--- a/textproc/meld/Makefile
+++ b/textproc/meld/Makefile
@@ -24,14 +24,17 @@ MAKE_ARGS= prefix=${PREFIX}
INSTALLS_ICONS= yes
INSTALLS_OMF= yes
-OPTIONS= PYGNOMEDESKTOP "Code syntax hilighting (many dependencies)" off
+OPTIONS_DEFINE= PYGNOMEDESKTOP
+PYGNOMEDESKTOP_DESC= Code syntax hilighting (many dependencies)
-.if defined(WITHOUT_NLS)
-EXTRA_PATCHES= ${FILESDIR}/extra-Makefile-without_nls
-PLIST_SUB+= NLS="@comment "
-.else
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
+.else
+EXTRA_PATCHES= ${FILESDIR}/extra-Makefile-without_nls
+PLIST_SUB+= NLS="@comment "
.endif
post-patch:
@@ -48,9 +51,7 @@ post-patch:
s|$$(LANG)|$$(LANG_)|g' ${WRKSRC}/${file}
.endfor
-.include <bsd.port.options.mk>
-
-.if defined(WITH_PYGNOMEDESKTOP)
+.if ${PORT_OPTIONS:MPYGNOMEDESKTOP}
USE_GNOME+= pygnomedesktop
.endif