aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
Diffstat (limited to 'textproc')
-rw-r--r--textproc/cwtext/Makefile2
-rw-r--r--textproc/htmlsection/Makefile2
-rw-r--r--textproc/ibus-qt/Makefile2
-rw-r--r--textproc/multimarkdown/Makefile2
-rw-r--r--textproc/py-dsv/Makefile2
-rw-r--r--textproc/py-genshi-devel/Makefile2
-rw-r--r--textproc/resume/Makefile2
-rw-r--r--textproc/resume/pkg-plist34
-rw-r--r--textproc/ruby-escape/Makefile2
-rw-r--r--textproc/ruby-format/Makefile2
-rw-r--r--textproc/ruby-liquid/Makefile2
-rw-r--r--textproc/ruby-rdtool/Makefile2
-rw-r--r--textproc/ruby-sary/Makefile2
-rw-r--r--textproc/ruby-xmlparser/Makefile2
-rw-r--r--textproc/ruby-xmlscan/Makefile2
-rw-r--r--textproc/sary/Makefile2
-rw-r--r--textproc/sphinxsearch/Makefile2
-rw-r--r--textproc/tclExpat/Makefile2
-rw-r--r--textproc/teckit/Makefile2
-rw-r--r--textproc/tinyxml/Makefile7
-rw-r--r--textproc/webcpp/Makefile2
21 files changed, 55 insertions, 24 deletions
diff --git a/textproc/cwtext/Makefile b/textproc/cwtext/Makefile
index c1172c0cd225..82f77c3680fc 100644
--- a/textproc/cwtext/Makefile
+++ b/textproc/cwtext/Makefile
@@ -16,6 +16,8 @@ ALL_TARGET= ALL
LICENSE= GPLv2
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -e "s,%%STAGEDIR%%,${STAGEDIR},g" \
${WRKSRC}/makefile
diff --git a/textproc/htmlsection/Makefile b/textproc/htmlsection/Makefile
index dfa159d6e511..587ce41f7df3 100644
--- a/textproc/htmlsection/Makefile
+++ b/textproc/htmlsection/Makefile
@@ -15,6 +15,8 @@ USE_PERL5= build
JADOCSDIR= share/doc/ja/${PORTNAME}
PLIST_SUB= JADOCSDIR=${JADOCSDIR}
+OPTIONS_DEFINE= DOCS
+
pre-build:
@(echo perl is set ${PERL} in pre-build:)
@(cd ${WRKSRC}; ./findperl.sh ${PERL} > whereperl)
diff --git a/textproc/ibus-qt/Makefile b/textproc/ibus-qt/Makefile
index 692a74b64a69..b62ac46aa4b6 100644
--- a/textproc/ibus-qt/Makefile
+++ b/textproc/ibus-qt/Makefile
@@ -31,4 +31,6 @@ LDFLAGS+= -L${LOCALBASE}/lib
PROJECTHOST= ibus
WRKSRC= ${WRKDIR}/${DISTNAME}
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/textproc/multimarkdown/Makefile b/textproc/multimarkdown/Makefile
index 7de09a480c08..5eb823039ccc 100644
--- a/textproc/multimarkdown/Makefile
+++ b/textproc/multimarkdown/Makefile
@@ -26,7 +26,7 @@ WRKSRC= ${WRKDIR}/fletcher-MultiMarkdown-4-${MM4_COMMIT}
ALL_TARGET= ${PORTNAME}
-OPTIONS_DEFINE= CHEAT_SHEET EXTRAS HELPERS
+OPTIONS_DEFINE= CHEAT_SHEET EXTRAS HELPERS DOCS
CHEAT_SHEET_DESC= HTML-based cheat sheat
EXTRAS_DESC= Extra scripts and XSLT support
HELPERS_DESC= Helper scripts (conflicts with emulators/mtools)
diff --git a/textproc/py-dsv/Makefile b/textproc/py-dsv/Makefile
index f408bc145345..57cc5133cacc 100644
--- a/textproc/py-dsv/Makefile
+++ b/textproc/py-dsv/Makefile
@@ -16,6 +16,8 @@ USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
DSV_BASEDIR= ${PYTHONPREFIX_SITELIBDIR}/DSV
+OPTIONS_DEFINE= DOCS
+
post-install:
@${PRINTF} '#!/bin/sh\n${PYTHON_CMD} ${DSV_BASEDIR}/DSV.py "$$@"\n' \
>${WRKDIR}/DSV.sh
diff --git a/textproc/py-genshi-devel/Makefile b/textproc/py-genshi-devel/Makefile
index a87e2089da1e..63c52e2503d6 100644
--- a/textproc/py-genshi-devel/Makefile
+++ b/textproc/py-genshi-devel/Makefile
@@ -22,6 +22,8 @@ CONFLICTS= py-genshi-[0-9]*
DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
EXAMPLESDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
+OPTIONS_DEFINE= DOCS EXAMPLES
+
post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC}/doc/ && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
diff --git a/textproc/resume/Makefile b/textproc/resume/Makefile
index 4b537630d04f..971ce2638ae5 100644
--- a/textproc/resume/Makefile
+++ b/textproc/resume/Makefile
@@ -18,6 +18,8 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
PORTDOCS= *
+OPTIONS_DEFINE= DOCS EXAMPLES
+
post-patch:
${REINPLACE_CMD} -e 's|\.\./\.\./css|css|' ${WRKSRC}/xsl/params.xsl
${FIND} ${WRKSRC} -name '*.bak' -delete
diff --git a/textproc/resume/pkg-plist b/textproc/resume/pkg-plist
index 007f8f32c924..b649bcf1b172 100644
--- a/textproc/resume/pkg-plist
+++ b/textproc/resume/pkg-plist
@@ -69,20 +69,20 @@ share/xsl/resume/params.xsl
@dirrm share/xsl/resume
@dirrmtry share/xsl
%%JAVAJARDIR%%/xmlresume-filter.jar
-%%PORTDOCS%%%%EXAMPLESDIR%%/Makefile
-%%PORTDOCS%%%%EXAMPLESDIR%%/addressing/Makefile
-%%PORTDOCS%%%%EXAMPLESDIR%%/addressing/README
-%%PORTDOCS%%%%EXAMPLESDIR%%/addressing/brazil.xml
-%%PORTDOCS%%%%EXAMPLESDIR%%/addressing/canada.xml
-%%PORTDOCS%%%%EXAMPLESDIR%%/addressing/ireland.xml
-%%PORTDOCS%%%%EXAMPLESDIR%%/addressing/italy.xml
-%%PORTDOCS%%%%EXAMPLESDIR%%/addressing/norway.xml
-%%PORTDOCS%%%%EXAMPLESDIR%%/addressing/nz.xml
-%%PORTDOCS%%%%EXAMPLESDIR%%/addressing/uk.xml
-%%PORTDOCS%%%%EXAMPLESDIR%%/addressing/untagged.xml
-%%PORTDOCS%%%%EXAMPLESDIR%%/addressing/usa.xml
-%%PORTDOCS%%%%EXAMPLESDIR%%/build.xml
-%%PORTDOCS%%%%EXAMPLESDIR%%/example1.xml
-%%PORTDOCS%%%%EXAMPLESDIR%%/example2.xml
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/addressing
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/addressing/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/addressing/README
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/addressing/brazil.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/addressing/canada.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/addressing/ireland.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/addressing/italy.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/addressing/norway.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/addressing/nz.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/addressing/uk.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/addressing/untagged.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/addressing/usa.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/build.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example1.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example2.xml
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/addressing
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
diff --git a/textproc/ruby-escape/Makefile b/textproc/ruby-escape/Makefile
index cc440581d358..877cd258cb12 100644
--- a/textproc/ruby-escape/Makefile
+++ b/textproc/ruby-escape/Makefile
@@ -17,6 +17,8 @@ NO_BUILD= yes
DOCS= ChangeLog README
+OPTIONS_DEFINE= DOCS
+
do-install:
${MKDIR} ${STAGEDIR}${RUBY_SITELIBDIR}
@${INSTALL_DATA} ${INSTALL_WRKSRC}/escape.rb ${STAGEDIR}${RUBY_SITELIBDIR}/
diff --git a/textproc/ruby-format/Makefile b/textproc/ruby-format/Makefile
index 41672c71a232..6a1d562b204b 100644
--- a/textproc/ruby-format/Makefile
+++ b/textproc/ruby-format/Makefile
@@ -16,6 +16,8 @@ USE_RUBY= yes
NO_BUILD= yes
+OPTIONS_DEFINE= DOCS
+
post-patch:
${RUBY} -i.orig -pe 'gsub(/"(format_test\.pl)/, "\"./\\1")' ${WRKSRC}/test_format.rb
diff --git a/textproc/ruby-liquid/Makefile b/textproc/ruby-liquid/Makefile
index 8fca32cbeea5..0336247852e5 100644
--- a/textproc/ruby-liquid/Makefile
+++ b/textproc/ruby-liquid/Makefile
@@ -18,6 +18,8 @@ NO_BUILD= yes
SADIR= ${RUBY_SITELIBDIR}
DOCS= CHANGELOG README.txt History.txt
+OPTIONS_DEFINE= DOCS
+
do-install:
${MKDIR} ${STAGEDIR}${SADIR}/liquid/tags ${STAGEDIR}${SADIR}/liquid/extras
${INSTALL_DATA} ${WRKSRC}/lib/liquid.rb ${STAGEDIR}${SADIR}/
diff --git a/textproc/ruby-rdtool/Makefile b/textproc/ruby-rdtool/Makefile
index dae70b849e3a..61bd07589f66 100644
--- a/textproc/ruby-rdtool/Makefile
+++ b/textproc/ruby-rdtool/Makefile
@@ -26,6 +26,8 @@ RUBY_MODNAME= rd
DOCS_EN= README.rd doc/rd-draft.rd
DOCS_JA= README.rd.ja doc/rd-draft.rd.ja
+OPTIONS_DEFINE= DOCS
+
post-install:
${MKDIR} ${STAGEDIR}${RUBY_SITELIBDIR}/rd
${INSTALL_DATA} ${WRKSRC}/lib/rd/dot.rd2rc ${STAGEDIR}${RUBY_SITELIBDIR}/rd/
diff --git a/textproc/ruby-sary/Makefile b/textproc/ruby-sary/Makefile
index 22e6a52f7e94..cb42c2760ef0 100644
--- a/textproc/ruby-sary/Makefile
+++ b/textproc/ruby-sary/Makefile
@@ -29,6 +29,8 @@ DOCS_EN= ChangeLog \
DOCS_JA= ${RUBY_RD_FILES:M*.ja.rd} \
${RUBY_RD_HTML_FILES:M*.ja.html}
+OPTIONS_DEFINE= DOCS
+
post-install:
${INSTALL_SCRIPT} ${WRKSRC}/rsary.rb ${STAGEDIR}${PREFIX}/bin/
${MKDIR} ${STAGEDIR}${RUBY_MODDOCDIR}/ja
diff --git a/textproc/ruby-xmlparser/Makefile b/textproc/ruby-xmlparser/Makefile
index 14b051b9d698..11f4ed7fe070 100644
--- a/textproc/ruby-xmlparser/Makefile
+++ b/textproc/ruby-xmlparser/Makefile
@@ -27,6 +27,8 @@ INSTALL_TARGET= site-install
MAKE_ARGS= INSTALL_PROG="${INSTALL_PROGRAM}" \
INSTALL_DATA="${INSTALL_DATA}"
+OPTIONS_DEFINE= DOCS
+
post-extract:
${FIND} ${WRKSRC} -name CVS -type d -exec ${RM} -r {} ';' -prune
diff --git a/textproc/ruby-xmlscan/Makefile b/textproc/ruby-xmlscan/Makefile
index 10dc03b3072f..1b246363675b 100644
--- a/textproc/ruby-xmlscan/Makefile
+++ b/textproc/ruby-xmlscan/Makefile
@@ -23,6 +23,8 @@ DOCS_EN= ChangeLog \
doc/en/*
DOCS_JA= doc/ja/*
+OPTIONS_DEFINE= DOCS
+
do-install:
${MKDIR} ${STAGEDIR}${RUBY_SITELIBDIR}
${CP} -R ${WRKSRC}/lib/xmlscan ${STAGEDIR}${RUBY_SITELIBDIR}/
diff --git a/textproc/sary/Makefile b/textproc/sary/Makefile
index 30f913a25e39..aa6bab7f4389 100644
--- a/textproc/sary/Makefile
+++ b/textproc/sary/Makefile
@@ -15,6 +15,8 @@ USES= libtool pathfix pkgconfig
USE_GNOME= glib20
USE_LDCONFIG= yes
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -e '/^SUBDIRS/s|docs||g' ${WRKSRC}/Makefile.in
diff --git a/textproc/sphinxsearch/Makefile b/textproc/sphinxsearch/Makefile
index bed43dcc0ce2..c03beb9215a3 100644
--- a/textproc/sphinxsearch/Makefile
+++ b/textproc/sphinxsearch/Makefile
@@ -24,7 +24,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2
OPTIONS_DEFINE= ICONV ID64 LIBSTEMMER MYSQL OPTIMIZED_CFLAGS PGSQL \
- SYSLOG UNIXODBC
+ SYSLOG UNIXODBC DOCS
OPTIONS_DEFAULT=ICONV MYSQL SYSLOG
ICONV_CONFIGURE_WITH= iconv
diff --git a/textproc/tclExpat/Makefile b/textproc/tclExpat/Makefile
index c23fd24ad143..43fa838ef442 100644
--- a/textproc/tclExpat/Makefile
+++ b/textproc/tclExpat/Makefile
@@ -20,6 +20,8 @@ PLIST_SUB+= TCL_VERSION=${TCL_VER}
MAKEFILE= ${FILESDIR}/Makefile
MAKE_ENV+= TCL_VERSION=${TCL_VER}
+OPTIONS_DEFINE= DOCS
+
# Remove the old version of expat bundled with the package:
post-extract:
${RM} -rf ${WRKSRC}/expat
diff --git a/textproc/teckit/Makefile b/textproc/teckit/Makefile
index af526419b533..cc1a37a593d0 100644
--- a/textproc/teckit/Makefile
+++ b/textproc/teckit/Makefile
@@ -23,6 +23,8 @@ INSTALL_TARGET= install-strip
DOCS= AUTHORS README NEWS docs/*.pdf license/LICENSING.txt
+OPTIONS_DEFINE= DOCS
+
post-patch:
${CHMOD} ${BINMODE} ${WRKSRC}/configure ${WRKSRC}/install-sh
diff --git a/textproc/tinyxml/Makefile b/textproc/tinyxml/Makefile
index 795a5e72e980..c28da33d1cc4 100644
--- a/textproc/tinyxml/Makefile
+++ b/textproc/tinyxml/Makefile
@@ -18,11 +18,8 @@ USE_LDCONFIG= YES
SHLIB_MAJOR= 3
PLIST_SUB= SHLIB_MAJOR="${SHLIB_MAJOR}"
-.if defined(NOPROFILE) || defined(NO_PROFILE)
-PLIST_SUB+= PROFILE="@comment "
-.else
-PLIST_SUB+= PROFILE=""
-.endif
+OPTIONS_DEFINE= DOCS PROFILE
+OPTIONS_SUB= yes
post-patch:
${MV} ${WRKSRC}/Makefile ${WRKSRC}/Makefile.prev
diff --git a/textproc/webcpp/Makefile b/textproc/webcpp/Makefile
index 25555436f896..c73c93d75a74 100644
--- a/textproc/webcpp/Makefile
+++ b/textproc/webcpp/Makefile
@@ -14,6 +14,8 @@ GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+OPTIONS_DEFINE= DOCS
+
.if defined(WANT_FINAL)
CONFIGURE_ARGS+= --enable-final
USES= gmake