aboutsummaryrefslogtreecommitdiff
path: root/www/R-cran-shiny/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/R-cran-shiny/Makefile')
-rw-r--r--www/R-cran-shiny/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/www/R-cran-shiny/Makefile b/www/R-cran-shiny/Makefile
new file mode 100644
index 000000000000..60bf99bf78d8
--- /dev/null
+++ b/www/R-cran-shiny/Makefile
@@ -0,0 +1,23 @@
+# Created by: TAKATSU Tomonari <tota@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= shiny
+PORTVERSION= 0.5.0
+CATEGORIES= www
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= Web Application Framework for R
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= R-cran-httpuv>=1.0.5:${PORTSDIR}/www/R-cran-httpuv \
+ R-cran-caTools>0:${PORTSDIR}/devel/R-cran-caTools \
+ R-cran-RJSONIO>0:${PORTSDIR}/converters/R-cran-RJSONIO \
+ R-cran-xtable>0:${PORTSDIR}/converters/R-cran-xtable \
+ R-cran-digest>0:${PORTSDIR}/security/R-cran-digest
+
+USE_R_MOD= yes
+R_MOD_AUTOPLIST= yes
+
+.include <bsd.port.mk>