aboutsummaryrefslogtreecommitdiff
path: root/www/WebMagick/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/WebMagick/Makefile')
-rw-r--r--www/WebMagick/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/www/WebMagick/Makefile b/www/WebMagick/Makefile
new file mode 100644
index 000000000000..fe136a3d5c9f
--- /dev/null
+++ b/www/WebMagick/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: WebMagick
+# http://www.cyberramp.net/~bfriesen/webmagick/
+# Version required: 1.44
+# Date created: 20 May 1998
+# Whom: ache
+#
+# $Id: Makefile,v 1.18 1998/05/14 08:23:24 vanilla Exp $
+#
+
+DISTNAME= WebMagick-1.44
+CATEGORIES= www
+MASTER_SITES= http://www.cyberramp.net/~bfriesen/webmagick/dist/
+
+MAINTAINER= ache@freebsd.org
+
+USE_PERL5= YES
+GNU_CONFIGURE= YES
+CONFIGURE_ENV= webmagick_cv_rootpath=${PREFIX}/www/data \
+ webmagick_cv_iconpath=webmagick \
+ webmagick_cv_prefixpath="" \
+ webmagick_cv_htimage="" \
+ webmagick_cv_maptype=ncsa
+
+RUN_DEPENDS= ${PREFIX}/lib/libMagick.a:${PORTSDIR}/graphics/ImageMagick \
+ ${PREFIX}/lib/perl5/site_perl/i386-freebsd/auto/Image/Magick/Magick.so:${PORTSDIR}/graphics/p5-PerlMagick
+
+post-install:
+ cd ${WRKSRC}; \
+ if [ ! -f ${PREFIX}/etc/webmagickrc ] ; then \
+ ${INSTALL_DATA} webmagickrc ${PREFIX}/etc; \
+ fi; \
+ ${INSTALL_DATA} webmagickrc ${PREFIX}/etc/webmagickrc.dist
+
+.include <bsd.port.mk>