aboutsummaryrefslogtreecommitdiff
path: root/www/apache-jserv/files
diff options
context:
space:
mode:
Diffstat (limited to 'www/apache-jserv/files')
-rw-r--r--www/apache-jserv/files/patch-aa11
-rw-r--r--www/apache-jserv/files/patch-ab11
-rw-r--r--www/apache-jserv/files/patch-ac35
-rw-r--r--www/apache-jserv/files/patch-ad37
-rw-r--r--www/apache-jserv/files/patch-ae20
5 files changed, 114 insertions, 0 deletions
diff --git a/www/apache-jserv/files/patch-aa b/www/apache-jserv/files/patch-aa
new file mode 100644
index 000000000000..addcb364415f
--- /dev/null
+++ b/www/apache-jserv/files/patch-aa
@@ -0,0 +1,11 @@
+--- configure.orig Wed Mar 3 08:46:29 1999
++++ configure Wed Mar 3 08:46:42 1999
+@@ -1239,7 +1239,7 @@
+ fi
+
+ # Always use our own libtool.
+-LIBTOOL='$(SHELL) $(top_builddir)/libtool'
++LIBTOOL='libtool'
+
+ # Check for any special flags to pass to ltconfig.
+ libtool_flags=
diff --git a/www/apache-jserv/files/patch-ab b/www/apache-jserv/files/patch-ab
new file mode 100644
index 000000000000..a3247303a387
--- /dev/null
+++ b/www/apache-jserv/files/patch-ab
@@ -0,0 +1,11 @@
+--- docs/Makefile.in.orig Sat Jun 12 05:47:51 1999
++++ docs/Makefile.in Sat Jun 26 23:45:33 1999
+@@ -87,7 +87,7 @@
+
+ DOCFILES = $(strip $(shell ls $(EXTRA_DIST)))
+
+-docdir = ${prefix}/docs
++docdir = ${prefix}/share/doc/mod_jserv
+ mkinstalldirs = $(SHELL) $(top_srcdir)/src/scripts/build/unix/mkinstalldirs
+ CONFIG_CLEAN_FILES =
+ DIST_COMMON = Makefile.am Makefile.in
diff --git a/www/apache-jserv/files/patch-ac b/www/apache-jserv/files/patch-ac
new file mode 100644
index 000000000000..4d484cc4f81c
--- /dev/null
+++ b/www/apache-jserv/files/patch-ac
@@ -0,0 +1,35 @@
+--- conf/httpd.conf.in.orig Sat Jun 12 05:38:46 1999
++++ conf/httpd.conf.in Thu Jul 1 00:07:44 1999
+@@ -6,7 +6,7 @@
+ # Note: this file should be appended to or included in httpd.conf
+
+ # Tell Apache on win32 to load the Apache JServ communication module
+-#LoadModule jserv_module modules/ApacheModuleJServ.dll
++LoadModule jserv_module libexec/apache/mod_jserv.so
+
+ <IfModule mod_jserv.c>
+
+@@ -19,13 +19,13 @@
+ # In manual mode this directive is ignored
+ # Syntax: ApJServProperties [filename]
+ # Default: "./conf/jserv.properties"
+-ApJServProperties ./conf/jserv.properties
++ApJServProperties etc/apache/jserv.properties
+
+ # Log file for this module operation relative to Apache root directory.
+ # Syntax: ApJServLogFile [filename]
+ # Default: "./logs/mod_jserv.log"
+ # Note: when set to "DISABLED", the log will be redirected to Apache error log
+-ApJServLogFile ./logs/mod_jserv.log
++ApJServLogFile /var/log/mod_jserv.log
+
+ # Log Level for this module
+ # Syntax: ApJServLogLevel [debug|info|notice|warn|error|crit|alert|emerg]
+@@ -99,6 +99,7 @@
+ #ApJServAction .jsp /servlets/nl.nmg.jsp.JSPServlet
+ #ApJServAction .gsp /servlets/com.bitmechanics.gsp.GspServlet
+ #ApJServAction .jhtml /servlets/org.apache.servlet.ssi.SSI
++# Uncomment if you use Cocoon.
+ #ApJServAction .xml /servlets/org.apache.cocoon.Cocoon
+
+ # Enable the Apache JServ status handler with the URL of
diff --git a/www/apache-jserv/files/patch-ad b/www/apache-jserv/files/patch-ad
new file mode 100644
index 000000000000..d66834a164ec
--- /dev/null
+++ b/www/apache-jserv/files/patch-ad
@@ -0,0 +1,37 @@
+--- conf/jserv.properties.in.orig Sat Jun 12 05:38:46 1999
++++ conf/jserv.properties.in Tue Jun 29 23:02:02 1999
+@@ -52,8 +52,15 @@
+ # Note: the classes you want to be automatically reloaded upon modification
+ # MUST NOT be in this classpath or the classpath of the shell
+ # you start the Apache from.
+-wrapper.classpath=@JSERV_CLASSES@
++wrapper.classpath=@libexecdir@/ApacheJServ.jar
+ wrapper.classpath=@JSDK_CLASSES@
++# Uncomment if you use Cocoon.
++#wrapper.classpath=@prefix@/share/java/classes/Cocoon.jar
++#wrapper.classpath=@prefix@/share/java/classes/openxml.jar
++#wrapper.classpath=@prefix@/share/java/classes/xslp.jar
++# Currently, these are not officially supported by the Cocoon team.
++#wrapper.classpath=@prefix@/share/java/classes/xml4j.jar
++#wrapper.classpath=@prefix@/share/java/classes/lotusxsl.jar
+
+ # An environment name with value passed to the JVM
+ # Syntax: wrapper.env=[name]=[value]
+@@ -94,7 +101,7 @@
+ # Syntax: [servlet zone name as on the zones list].properties=[full path to configFile] (String)
+ # Default: NONE
+ # Note: if the file could not be opened, try using absolute paths.
+-root.properties=@JSERV_CONF@/zone.properties
++root.properties=@sysconfdir@/zone.properties
+
+ #
+ # Security parameters
+@@ -177,7 +184,7 @@
+ # Syntax: log.file=[log path and filename] (String)
+ # Default: NONE
+ # Note: if the file could not be opened, try using absolute paths.
+-log.file=@JSERV_LOG@/jserv.log
++log.file=/var/log/jserv.log
+
+ # Enable the timestamp before the log message
+ # Syntax: log.timestamp=[true,false] (boolean)
diff --git a/www/apache-jserv/files/patch-ae b/www/apache-jserv/files/patch-ae
new file mode 100644
index 000000000000..6b2f886f9d88
--- /dev/null
+++ b/www/apache-jserv/files/patch-ae
@@ -0,0 +1,20 @@
+--- conf/zone.properties.in~ Fri Feb 19 13:09:29 1999
++++ conf/zone.properties.in Tue Jun 29 23:04:05 1999
+@@ -23,6 +23,8 @@
+ # here.
+
+ repositories=
++# Uncomment if you use Cocoon.
++#repositories=@prefix@/share/java/classes/Cocoon.jar
+
+ # Classloader parameters
+ #########################
+@@ -133,6 +135,8 @@
+ # Syntax: servlet.[classname].initArgs=[name]=[value],[name]=[value],...
+ # Default: NONE
+ # servlet.org.fool.Dummy.initArgs=message=I'm a dummy servlet
++# Uncomment if you use Cocoon.
++#servlet.org.apache.cocoon.Cocoon.initArgs=properties=@prefix@/etc/apache/cocoon.properties
+
+ # Aliased Servlet Init Parameters
+ ##################################