aboutsummaryrefslogtreecommitdiff
path: root/www/apache2/Makefile.doc
diff options
context:
space:
mode:
Diffstat (limited to 'www/apache2/Makefile.doc')
-rw-r--r--www/apache2/Makefile.doc120
1 files changed, 120 insertions, 0 deletions
diff --git a/www/apache2/Makefile.doc b/www/apache2/Makefile.doc
new file mode 100644
index 000000000000..7488d59e1266
--- /dev/null
+++ b/www/apache2/Makefile.doc
@@ -0,0 +1,120 @@
+# Makefile.doc
+# Author: Clement Laforet <clement@FreeBSD.org>
+#
+# This files contains:
+# - make options output
+# - apache2 man/docs routines
+#
+# $FreeBSD$
+#
+
+## Available knobs:
+## By default, modules are compiled as dynamically loadable (DSO) modules.
+##
+## Apache-related
+## WITH_MPM: prefork (default)
+## worker
+## perchild
+## WITH_HTTP_PORT: default: 80
+## WITH_LDAP: Enable LDAP support (mod_auth_ldap)
+## WITHOUT_PROXY: Disable proxy support
+## WITH_CUSTOM_PROXY: Let you choose which proxy modules you wish
+## WITHOUT_AUTH: Disable auth modules
+## WITH_CUSTOM_AUTH: Let you choose which auth modules you wish
+## WITHOUT_DAV: Disable DAV support
+## WITH_IPV6_V6ONLY: Disable IPv4 support
+## WITHOUT_SSL: Disable SSL support
+## WITH_THREADS: Enable threads support !! USE IT WITH CARE !!
+## WITH_CUSTOM_THREADS: Let you choose which threaded modules you want
+## WITH_DBM: Choose your DBM: bdb (Berkeley DB), gdbm or ndbm (default)
+## WITH_BERKELEYDB: Choose your BerkeleyDB version: db2, db3, db4, db41 or FreeBSD (1.85)(default)
+## WITH_STATIC_SUPPORT: Build statically linked support binaries
+## WITH_STATIC_APACHE: Build a static version of httpd (implies WITH_STATIC_MODULES)
+## WITH_ALL_STATIC_MODULES: All modules will be statically linked.
+## WITH_STATIC_MODULES: List of modules to build modules statics (usefull for slave ports)
+## (They must be already enabled (i.e. WITH_MODULES or with default configuration
+## use 'make show-modules', to check if they are enabled)
+## WITH_EXPERIMENTAL: Build and install experimental modules
+## WITH_EXTRA_MODULES: To add addtionnal modules
+## WITH_MODULES: List of your own modules
+## WITHOUT_MODULES: Disable listed modules
+## WITH_SUEXEC: Enable suExec support
+## SUEXEC_DOCROOT: SuExec root directory
+## SUEXEC_USERDIR: User subdirectory (default public_html)
+## SUEXEC_SAFEPATH: Set the safepath
+## SUEXEC_UIDMIN: Minimal allowed UID (default 1000)
+## SUEXEC_GIDMIN: Minimal allowed GID (default 1000)
+## SUEXEC_CALLER: User allowed to call SuExec (default ${WWWOWN} (www))
+##
+## Port-related:
+## WITHOUT_WWW: Implies NO_CGI, NO_WWWDATA, NO_ICONS and NO_ERROR
+## WITH_CUSTOM_WWW: Let you choose your ${LOCALBASE}/www components: [cgi|errordocs|icons|wwwdata]
+##
+## Available make targets:
+## show-options: prints this message
+## show-modules: prints list of available modules
+##
+## Examples:
+## make WITHOUT_SSL=yes WITH_EXTRA_MODULES="bucketeer case_filter case_filter_in" WITHOUT_PROXY=yes
+## make WITH_STATIC_MODULES="ssl rewrite include" WITH_EXPERIMENTAL=yes WITH_CUSTOM_AUTH="auth auth_dbm"
+## make WITH_EXPERIMENTAL=yes WITHOUT_MODULES="access speling status"
+## make WITH_MODULES="include rewrite auth"
+##
+
+DOCSDIR= share/doc/apache2
+
+.if defined(NOPORTDOCS)
+MAKE_ENV+= NOPORTDOCS=yes
+.endif
+
+MAN1= dbmmanage.1 htdigest.1 htpasswd.1
+MAN8= ab.8 apachectl.8 apxs.8 httpd.8 logresolve.8 rotatelogs.8 suexec.8
+
+.if defined(WITHOUT_WWW)
+NO_CGI= YES
+NO_WWWDATA= YES
+NO_ICONS= YES
+NO_ERROR= YES
+.elif defined(WITH_CUSTOM_WWW)
+. if ${WITH_CUSTOM_WWW:Mcgi} == ""
+NO_CGI= YES
+. endif
+. if ${WITH_CUSTOM_WWW:Mwwwdata} == ""
+NO_WWWDATA= YES
+. endif
+. if ${WITH_CUSTOM_WWW:Merrordocs} == ""
+NO_ERROR= YES
+. endif
+. if ${WITH_CUSTOM_WWW:Micons} == ""
+NO_ICONS= YES
+. endif
+.endif
+
+.if defined(NO_CGI)
+MAKE_ENV+= NO_CGI=yes
+PLIST_SUB+= CGI="@comment "
+.else
+PLIST_SUB+= CGI=""
+.endif
+
+.if defined(NO_ICONS)
+MAKE_ENV+= NO_ICONS=yes
+PLIST_SUB+= ICONS="@comment "
+.else
+PLIST_SUB+= ICONS=""
+.endif
+
+.if defined(NO_WWWDATA)
+MAKE_ENV+= NO_WWWDATA=yes
+PLIST_SUB+= WWWDATA="@comment "
+.else
+PLIST_SUB+= WWWDATA=""
+.endif
+
+.if defined(NO_ERROR)
+MAKE_ENV+= NO_ERROR=yes
+PLIST_SUB+= ERROR="@comment "
+.else
+PLIST_SUB+= ERROR=""
+.endif
+