aboutsummaryrefslogtreecommitdiff
path: root/www/b2evolution/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/b2evolution/Makefile')
-rw-r--r--www/b2evolution/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/www/b2evolution/Makefile b/www/b2evolution/Makefile
index 2b6d285ba6dd..17001eb2a4a0 100644
--- a/www/b2evolution/Makefile
+++ b/www/b2evolution/Makefile
@@ -7,6 +7,7 @@
PORTNAME= b2evolution
PORTVERSION= 1.10.2
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= evocms
@@ -27,13 +28,19 @@ WANT_PHP_WEB= YES
TMPDIR?= ${PORTNAME}
WRKSRC= ${WRKDIR}/${TMPDIR}
-
B2EVO_URL?= b2evo
B2EVO_DIR?= www/${B2EVO_URL}
PLIST= ${WRKDIR}/pkg-plist
+OPTIONS= LOCAL_DB_SERVER "Want to use local MySQL server?" on
+
.include <bsd.port.pre.mk>
+.if defined(WITH_LOCAL_DB_SERVER)
+USE_MYSQL= YES
+RUN_DEPENDS+= mysql-server>=0:${PORTSDIR}/databases/mysql${MYSQL_VER}-server
+.endif
+
pre-install:
@cd ${WRKSRC} && ${FIND} -s . -type f | \
${SED} -e 's|^./||;s|^|${B2EVO_DIR}/|' > ${PLIST} \