aboutsummaryrefslogtreecommitdiff
path: root/www/bk_edit/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/bk_edit/Makefile')
-rw-r--r--www/bk_edit/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/www/bk_edit/Makefile b/www/bk_edit/Makefile
index 17971b3c9d5a..30972487eb0d 100644
--- a/www/bk_edit/Makefile
+++ b/www/bk_edit/Makefile
@@ -21,6 +21,12 @@ USE_GETOPT_LONG= yes
HAS_CONFIGURE= yes
MAKE_ENV= LD="${CC}" LDFLAGS="${LDFLAGS}"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
post-patch:
@${FIND} ${WRKSRC} -name "*Makefile*" | ${XARGS} ${REINPLACE_CMD} -e \
's|^CC .*=|CC ?=|g ; \
@@ -34,4 +40,4 @@ do-install:
@${MKDIR} ${PREFIX}/lib/bkedit
${INSTALL_DATA} ${WRKSRC}/src/plugins/*.so ${PREFIX}/lib/bkedit
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>