aboutsummaryrefslogtreecommitdiff
path: root/www/cgiwrap/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/cgiwrap/Makefile')
-rw-r--r--www/cgiwrap/Makefile37
1 files changed, 19 insertions, 18 deletions
diff --git a/www/cgiwrap/Makefile b/www/cgiwrap/Makefile
index 79a4c4725833..14d04fa4f9be 100644
--- a/www/cgiwrap/Makefile
+++ b/www/cgiwrap/Makefile
@@ -6,54 +6,55 @@
#
PORTNAME= cgiwrap
-PORTVERSION= 3.6.3
-CATEGORIES= www
-MASTER_SITES= http://www.unixtools.org/cgiwrap/dist/ \
- ftp://ftp.umr.edu/pub/cgi/cgiwrap/ \
- ftp://concert.cert.dfn.de/pub/tools/net/cgiwrap/
+PORTVERSION= 3.6.4
+CATEGORIES= www security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= petef@databits.net
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= ${HTTPDUSER} ${WITHOUTCHECK} --with-install-dir=${INSTALLDIR} \
- --with-install-group=${BINGRP} --with-cgi-dir=${CGIDIR}
+CONFIGURE_ARGS= --with-httpd-user=${HTTPDUSER} \
+ --with-install-dir=${MAINCGIDIR} \
+ --with-install-group=${BINGRP} \
+ --with-cgi-dir=${CGIDIR} \
+ ${WITHOUTCHECK}
###
# Set this to the directory (relative to each user's home) where CGI
# scripts will be found. (Another common value is "www/cgi-bin".)
###
-CGIDIR= public_html/cgi-bin
-
+CGIDIR?= public_html/cgi-bin
###
# The default security settings are very tight; enable one or more
# of these to loosen them. Run "configure -help" for information on
# these and other options.
###
-#WITHOUTCHECK= --without-check-owner --without-check-setuid \
+#WITHOUTCHECK?= --without-check-owner --without-check-setuid \
# --without-check-group --without-check-setgid \
# --without-check-group-writable \
# --without-check-world-writable
-
###
# Use these options for Apache:
###
-INSTALLDIR= ${PREFIX}/share/apache/cgi-bin
-HTTPDUSER= --with-httpd-user=nobody
+MAINCGIDIR?= ${PREFIX}/www/cgi-bin
+HTTPDUSER?= nobody
pre-install:
- ${MKDIR} ${INSTALLDIR}
+ @${MKDIR} ${MAINCGIDIR}
post-install:
- strip ${INSTALLDIR}/cgiwrap
+ strip ${MAINCGIDIR}/cgiwrap
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/cgiwrap
+ @${MKDIR} ${PREFIX}/share/doc/cgiwrap
.for file in accesscontrol.html afs.html changes.html comments.html \
download.html faq.html index.html install.html intro.html \
maillist.html notes.html pubs.html quickref.html setup.html \
thanks.html todo.html tricks.html y2k.html
- @${INSTALL_MAN} ${WRKSRC}/htdocs/${file} ${PREFIX}/share/doc/cgiwrap
+ @${INSTALL_DATA} ${WRKSRC}/htdocs/${file} ${PREFIX}/share/doc/cgiwrap
.endfor
@${ECHO} "Documentation installed in ${PREFIX}/share/doc/cgiwrap"
.endif
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>