aboutsummaryrefslogtreecommitdiff
path: root/www/cherokee-devel
diff options
context:
space:
mode:
Diffstat (limited to 'www/cherokee-devel')
-rw-r--r--www/cherokee-devel/Makefile106
-rw-r--r--www/cherokee-devel/distinfo3
-rw-r--r--www/cherokee-devel/files/cherokee.sh.in45
-rw-r--r--www/cherokee-devel/files/patch-Makefile.in30
-rw-r--r--www/cherokee-devel/files/patch-cherokee-connection.c10
-rw-r--r--www/cherokee-devel/files/patch-cherokee-handler_cgi_base.c12
-rw-r--r--www/cherokee-devel/files/patch-cherokee-socket.c23
-rw-r--r--www/cherokee-devel/files/patch-cherokee-util.h17
-rw-r--r--www/cherokee-devel/pkg-descr6
-rw-r--r--www/cherokee-devel/pkg-plist216
10 files changed, 0 insertions, 468 deletions
diff --git a/www/cherokee-devel/Makefile b/www/cherokee-devel/Makefile
deleted file mode 100644
index 819d66185898..000000000000
--- a/www/cherokee-devel/Makefile
+++ /dev/null
@@ -1,106 +0,0 @@
-# New ports collection makefile for: cherokee
-# Date created: 01 Jun 2002
-# Whom: silence <oksala@videotron.ca>
-#
-# $FreeBSD$
-#
-
-PORTNAME= cherokee
-PORTVERSION= 0.5.6
-PORTREVISION= 1
-CATEGORIES= www
-MASTER_SITES= http://www.cherokee-project.com/download/%SUBDIR%/ \
- http://www.alaskaparadise.com/freebsd/
-MASTER_SITE_SUBDIR= ${PORTVERSION:R}/${PORTVERSION}
-
-MAINTAINER= beech@alaskaparadise.com
-COMMENT= An extremely fast and flexible web server
-
-LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
-
-USE_GNOME= gnomehack gnometarget pkgconfig
-USE_RC_SUBR= cherokee.sh
-USE_GCC= 3.4+
-USE_BISON= yes
-USE_GETOPT_LONG= yes
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --mandir=${MANPREFIX}/man \
- --with-wwwroot=${PREFIX}/www
-
-OPTIONS= GNUTLS "TLS/SSL Use gnutls" on \
- OPENSSL "TLS/SSL Use openssl" off \
- NOTLS "No TLS/SSL" off \
- NOIPV6 "No IPv6" off
-
-USE_LDCONFIG= yes
-
-MAN1= cget.1 cherokee-config.1 cherokee.1 cherokee_logrotate.1
-
-CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-
-.include <bsd.port.pre.mk>
-
-.if !defined(WITHOUT_GNUTLS)
-LIB_DEPENDS+= gnutls.15:${PORTSDIR}/security/gnutls
-CONFIGURE_ARGS+= --enable-tls=gnutls
-.endif
-
-.if defined(WITH_OPENSSL)
-CFLAGS+= -DHAVE_OPENSSL
-CONFIGURE_ARGS+=--enable-tls=openssl
-LDFLAGS+= -lssl -lcrypto
-.endif
-
-.if defined(WITH_NOTLS)
-CONFIGURE_ARGS+=--disable-tls
-.endif
-
-.if defined(WITH_NOIPV6)
-CONFIGURE_ARGS+=--disable-ipv6
-.endif
-
-.if ${OSVERSION} < 500000
-PLIST_SUB+= PAM=""
-.else
-PLIST_SUB+= PAM="@comment "
-.endif
-
-post-patch:
- @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
- 's|@mkdir_p@|${MKDIR} --|g'
-
-pre-build:
-.for file in advanced.conf cherokee.conf mods-ssl sites-default sites-example
- @cd ${BUILD_WRKSRC} && ${SED} -e \
- 's:%sysconfdir%:${PREFIX}/etc:g ; \
- s:%datadir%:${PREFIX}/share:g ; \
- s:%wwwroot%:${PREFIX}/www:g ; \
- s:%prefix%:${PREFIX}:g' < ${file}.sample.pre > ${file}.sample
-.endfor
-
-pre-install:
- @if [ ! -f ${PREFIX}/www ]; then \
- ${MKDIR} ${PREFIX}/www;\
- fi
- @if [ ! -f ${PREFIX}/www/data ] ; then \
- ${MKDIR} ${PREFIX}/www/data;\
- fi
- @${ECHO_MSG} " `pwd` "
-
-post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/*.html ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/*.png ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/images/*.png ${DOCSDIR}
-.endif
- ${INSTALL_DATA} ${WRKSRC}/doc/develop/Intro.txt ${DATADIR}
- @${ECHO_MSG} " "
- @${ECHO_MSG} " Dont forget to read the doc "
- @${ECHO_MSG} " ${PREFIX}/share/cherokee/Intro.txt"
- @${ECHO_MSG} " "
-
-.include <bsd.port.post.mk>
diff --git a/www/cherokee-devel/distinfo b/www/cherokee-devel/distinfo
deleted file mode 100644
index ecafe009b942..000000000000
--- a/www/cherokee-devel/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (cherokee-0.5.6.tar.gz) = 0c5ae67c296f7e080900b23e533efd0b
-SHA256 (cherokee-0.5.6.tar.gz) = d19ac8a85c252ccfe04c06ce0ec9b03d036b27d07c6db4601ce7d6b33c4e9cc8
-SIZE (cherokee-0.5.6.tar.gz) = 1392282
diff --git a/www/cherokee-devel/files/cherokee.sh.in b/www/cherokee-devel/files/cherokee.sh.in
deleted file mode 100644
index 098daf69297e..000000000000
--- a/www/cherokee-devel/files/cherokee.sh.in
+++ /dev/null
@@ -1,45 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-# PROVIDE: cherokee
-# REQUIRE: %%REQUIRE%%
-# KEYWORD: shutdown
-#
-# Add the following lines to /etc/rc.conf to enable cherokee:
-#
-# cherokee_enable (bool): Set it to "YES" to enable cherokee
-# Default is "NO".
-# cherokee_conf (path): Set full path to config file.
-# Default is "%%PREFIX%%/etc/cherokee/cherokee.conf".
-#
-
-. %%RC_SUBR%%
-
-name="cherokee"
-rcvar=`set_rcvar`
-
-load_rc_config $name
-
-: ${cherokee_enable="NO"}
-: ${cherokee_conf="%%PREFIX%%/etc/cherokee/cherokee.conf"}
-
-command=%%PREFIX%%/sbin/cherokee
-command_args="-C ${cherokee_conf} -b"
-pidfile=/var/run/cherokee.pid
-required_files=${cherokee_conf}
-stop_postcmd=stop_postcmd
-restart_precmd="checkconfig"
-
-checkconfig()
-{
- echo "Performing sanity check on ${name} configuration:"
- eval "${command} ${command_args} -t"
-}
-
-stop_postcmd()
-{
- rm -f ${pidfile}
-}
-
-run_rc_command "$1"
diff --git a/www/cherokee-devel/files/patch-Makefile.in b/www/cherokee-devel/files/patch-Makefile.in
deleted file mode 100644
index 4400c7c64dcf..000000000000
--- a/www/cherokee-devel/files/patch-Makefile.in
+++ /dev/null
@@ -1,30 +0,0 @@
---- Makefile.in.orig Tue Apr 4 17:23:41 2006
-+++ Makefile.in Tue Apr 11 02:25:14 2006
-@@ -314,7 +314,7 @@
- sharedstatedir = @sharedstatedir@
- sysconfdir = @sysconfdir@
- target_alias = @target_alias@
--SUBDIRS = m4 contrib www doc icons qa cherokee cget windows
-+SUBDIRS = m4 contrib www icons qa cherokee cget windows
- bin_SCRIPTS = cherokee-config
- SUFFIXES = .sample.pre .sample
-
-@@ -979,7 +979,7 @@
-
-
- .sample.pre.sample:
-- $(top_builddir)/cherokee_replace $< $@ "%sysconfdir%" "${sysconfdir}" "%datadir%" "${datadir}" "%prefix%" "${prefix}" "%wwwroot%" "${WWW_ROOT}"
-+ true $< $@ "%sysconfdir%" "${sysconfdir}" "%datadir%" "${datadir}" "%prefix%" "${prefix}" "%wwwroot%" "${WWW_ROOT}"
-
- install-data-local-config:
- @$(mkinstalldirs) $(DESTDIR)$(pkgincludedir);
-@@ -1022,9 +1022,6 @@
- echo "$@ will not overwrite existing $(cherokeeconfdir)/mime.compression.types"; \
- else \
- $(INSTALL_DATA) $(top_srcdir)/mime.compression.types.sample $(DESTDIR)$(cherokeeconfdir)/mime.compression.types; \
-- fi
-- @if test -d $(DESTDIR)$(sysconfdir)/pam.d && test ! -d $(DESTDIR)$(sysconfdir)/pam.d/cherokee ; then \
-- $(INSTALL_DATA) $(top_srcdir)/pam.d_cherokee $(DESTDIR)$(sysconfdir)/pam.d/cherokee; \
- fi
- @if test -f $(DESTDIR)$(cherokeeconfdir)/sites-available/default ; then \
- echo "$@ will not overwrite existing $(cherokeeconfdir)/sites-available/default"; \
diff --git a/www/cherokee-devel/files/patch-cherokee-connection.c b/www/cherokee-devel/files/patch-cherokee-connection.c
deleted file mode 100644
index 9d990d78957e..000000000000
--- a/www/cherokee-devel/files/patch-cherokee-connection.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- cherokee/connection.c.orig Mon Dec 11 11:44:26 2006
-+++ cherokee/connection.c Thu Dec 14 09:50:08 2006
-@@ -32,6 +32,7 @@
- #include <fcntl.h>
- #include <time.h>
- #include <sys/types.h>
-+#include <limits.h>
-
- #ifdef HAVE_PWD_H
- # include <pwd.h>
diff --git a/www/cherokee-devel/files/patch-cherokee-handler_cgi_base.c b/www/cherokee-devel/files/patch-cherokee-handler_cgi_base.c
deleted file mode 100644
index 29b5f24a660e..000000000000
--- a/www/cherokee-devel/files/patch-cherokee-handler_cgi_base.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- cherokee/handler_cgi_base.c.orig Mon Dec 11 11:44:26 2006
-+++ cherokee/handler_cgi_base.c Thu Dec 14 10:09:38 2006
-@@ -21,7 +21,8 @@
- * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
- * USA
- */
--
-+#include <stdlib.h>
-+#include <limits.h>
- #include "common-internal.h"
- #include "handler_cgi_base.h"
-
diff --git a/www/cherokee-devel/files/patch-cherokee-socket.c b/www/cherokee-devel/files/patch-cherokee-socket.c
deleted file mode 100644
index c3d2ffb49222..000000000000
--- a/www/cherokee-devel/files/patch-cherokee-socket.c
+++ /dev/null
@@ -1,23 +0,0 @@
---- cherokee/socket.c.orig Thu Dec 7 09:46:29 2006
-+++ cherokee/socket.c Thu Dec 14 10:35:48 2006
-@@ -1153,13 +1153,17 @@
- cherokee_socket_init_client_tls (cherokee_socket_t *socket)
- {
- #ifdef HAVE_TLS
-- int re;
--
- # ifdef HAVE_GNUTLS
-+
- const int kx_priority[] = {GNUTLS_KX_ANON_DH, 0};
- gnutls_anon_client_credentials anoncred;
--
-+
-+#endif
-+
-+ int re;
- socket->is_tls = TLS;
-+
-+# ifdef HAVE_GNUTLS
-
- /* Acredentials
- */
diff --git a/www/cherokee-devel/files/patch-cherokee-util.h b/www/cherokee-devel/files/patch-cherokee-util.h
deleted file mode 100644
index 6a3ea92b1589..000000000000
--- a/www/cherokee-devel/files/patch-cherokee-util.h
+++ /dev/null
@@ -1,17 +0,0 @@
---- cherokee/util.h.orig Wed Sep 13 22:13:07 2006
-+++ cherokee/util.h Wed Sep 13 22:15:20 2006
-@@ -31,6 +31,14 @@
-
- #include <cherokee/common.h>
-
-+#ifdef HAVE_SYS_TYPES_H
-+#include <sys/types.h>
-+#endif
-+
-+#ifdef HAVE_SYS_SOCKET_H
-+# include <sys/socket.h>
-+#endif
-+
- #include <time.h>
- #include <dirent.h>
-
diff --git a/www/cherokee-devel/pkg-descr b/www/cherokee-devel/pkg-descr
deleted file mode 100644
index 914eb17d7223..000000000000
--- a/www/cherokee-devel/pkg-descr
+++ /dev/null
@@ -1,6 +0,0 @@
-Cherokee is a tiny, ultrafast, lightweight Web server. It is implemented
-entirely in C, and has no dependencies beyond a standard C library. It
-provides only the most basic HTTP functionality, but is extremely fast and
-small.
-
-WWW: http://www.cherokee-project.com/
diff --git a/www/cherokee-devel/pkg-plist b/www/cherokee-devel/pkg-plist
deleted file mode 100644
index ed101d58aa96..000000000000
--- a/www/cherokee-devel/pkg-plist
+++ /dev/null
@@ -1,216 +0,0 @@
-bin/cget
-bin/cherokee-config
-bin/cherokee-panic
-bin/cherokee_logrotate
-etc/cherokee/advanced.conf
-etc/cherokee/cherokee.conf
-etc/cherokee/icons.conf
-etc/cherokee/mime.compression.types
-etc/cherokee/mime.types
-etc/cherokee/mods-available/admin
-etc/cherokee/mods-available/ssl
-etc/cherokee/sites-available/default
-etc/cherokee/sites-available/example.com
-etc/cherokee/sites-enabled/default
-include/cherokee/admin_client.h
-include/cherokee/buffer.h
-include/cherokee/cherokee-config.h
-include/cherokee/cherokee.h
-include/cherokee/common.h
-include/cherokee/connection.h
-include/cherokee/connection_info.h
-include/cherokee/downloader.h
-include/cherokee/encoder.h
-include/cherokee/fdpoll.h
-include/cherokee/handler.h
-include/cherokee/header.h
-include/cherokee/http.h
-include/cherokee/list.h
-include/cherokee/list_merge_sort.h
-include/cherokee/logger.h
-include/cherokee/macros.h
-include/cherokee/mime.h
-include/cherokee/mime_entry.h
-include/cherokee/module.h
-include/cherokee/module_loader.h
-include/cherokee/nonce.h
-include/cherokee/resolv_cache.h
-include/cherokee/server.h
-include/cherokee/table.h
-include/cherokee/typed_table.h
-include/cherokee/url.h
-include/cherokee/util.h
-lib/cherokee/libplugin_admin.a
-lib/cherokee/libplugin_admin.la
-lib/cherokee/libplugin_admin.so
-lib/cherokee/libplugin_cgi.a
-lib/cherokee/libplugin_cgi.la
-lib/cherokee/libplugin_cgi.so
-lib/cherokee/libplugin_combined.a
-lib/cherokee/libplugin_combined.la
-lib/cherokee/libplugin_combined.so
-lib/cherokee/libplugin_common.a
-lib/cherokee/libplugin_common.la
-lib/cherokee/libplugin_common.so
-lib/cherokee/libplugin_dirlist.a
-lib/cherokee/libplugin_dirlist.la
-lib/cherokee/libplugin_dirlist.so
-lib/cherokee/libplugin_error_redir.a
-lib/cherokee/libplugin_error_redir.la
-lib/cherokee/libplugin_error_redir.so
-lib/cherokee/libplugin_fastcgi.a
-lib/cherokee/libplugin_fastcgi.la
-lib/cherokee/libplugin_fastcgi.so
-lib/cherokee/libplugin_fcgi.a
-lib/cherokee/libplugin_fcgi.la
-lib/cherokee/libplugin_fcgi.so
-lib/cherokee/libplugin_file.a
-lib/cherokee/libplugin_file.la
-lib/cherokee/libplugin_file.so
-lib/cherokee/libplugin_gzip.a
-lib/cherokee/libplugin_gzip.la
-lib/cherokee/libplugin_gzip.so
-lib/cherokee/libplugin_htdigest.a
-lib/cherokee/libplugin_htdigest.la
-lib/cherokee/libplugin_htdigest.so
-lib/cherokee/libplugin_ncsa.a
-lib/cherokee/libplugin_ncsa.la
-lib/cherokee/libplugin_ncsa.so
-lib/cherokee/libplugin_nn.a
-lib/cherokee/libplugin_nn.la
-lib/cherokee/libplugin_nn.so
-%%PAM%%lib/cherokee/libplugin_pam.a
-%%PAM%%lib/cherokee/libplugin_pam.la
-%%PAM%%lib/cherokee/libplugin_pam.so
-lib/cherokee/libplugin_phpcgi.a
-lib/cherokee/libplugin_phpcgi.la
-lib/cherokee/libplugin_phpcgi.so
-lib/cherokee/libplugin_plain.a
-lib/cherokee/libplugin_plain.la
-lib/cherokee/libplugin_plain.so
-lib/cherokee/libplugin_read_config.a
-lib/cherokee/libplugin_read_config.la
-lib/cherokee/libplugin_read_config.so
-lib/cherokee/libplugin_redir.a
-lib/cherokee/libplugin_redir.la
-lib/cherokee/libplugin_redir.so
-lib/cherokee/libplugin_scgi.a
-lib/cherokee/libplugin_scgi.la
-lib/cherokee/libplugin_scgi.so
-lib/cherokee/libplugin_server_info.a
-lib/cherokee/libplugin_server_info.la
-lib/cherokee/libplugin_server_info.so
-lib/cherokee/libplugin_w3c.a
-lib/cherokee/libplugin_w3c.la
-lib/cherokee/libplugin_w3c.so
-lib/libcherokee-base.a
-lib/libcherokee-base.la
-lib/libcherokee-base.so
-lib/libcherokee-base.so.0
-lib/libcherokee-client.a
-lib/libcherokee-client.la
-lib/libcherokee-client.so
-lib/libcherokee-client.so.0
-lib/libcherokee-config.a
-lib/libcherokee-config.la
-lib/libcherokee-config.so
-lib/libcherokee-config.so.0
-lib/libcherokee-server.a
-lib/libcherokee-server.la
-lib/libcherokee-server.so
-lib/libcherokee-server.so.0
-libdata/pkgconfig/cherokee.pc
-sbin/cherokee
-share/aclocal/cherokee.m4
-%%DATADIR%%/Intro.txt
-%%DATADIR%%/deps/combined.deps
-%%DATADIR%%/deps/common.deps
-%%DATADIR%%/deps/error_redir.deps
-%%DATADIR%%/deps/nn.deps
-%%DATADIR%%/deps/phpcgi.deps
-%%DATADIR%%/icons/back.png
-%%DATADIR%%/icons/binary.png
-%%DATADIR%%/icons/blank.png
-%%DATADIR%%/icons/bomb.png
-%%DATADIR%%/icons/compressed.png
-%%DATADIR%%/icons/folder.png
-%%DATADIR%%/icons/image.png
-%%DATADIR%%/icons/iso.png
-%%DATADIR%%/icons/java.png
-%%DATADIR%%/icons/movie.png
-%%DATADIR%%/icons/pdf.png
-%%DATADIR%%/icons/ps.png
-%%DATADIR%%/icons/readme.png
-%%DATADIR%%/icons/script.png
-%%DATADIR%%/icons/sound.png
-%%DATADIR%%/icons/tex.png
-%%DATADIR%%/icons/text.png
-%%DATADIR%%/icons/unknown.png
-%%DATADIR%%/mime_types.txt
-%%PORTDOCS%%%%DOCSDIR%%/Authentication.html
-%%PORTDOCS%%%%DOCSDIR%%/Authors.html
-%%PORTDOCS%%%%DOCSDIR%%/Behavior_configuration.html
-%%PORTDOCS%%%%DOCSDIR%%/CGI_executing.html
-%%PORTDOCS%%%%DOCSDIR%%/Cget.html
-%%PORTDOCS%%%%DOCSDIR%%/Cherokee-icono.png
-%%PORTDOCS%%%%DOCSDIR%%/Combined_logger.html
-%%PORTDOCS%%%%DOCSDIR%%/Combined_logs.html
-%%PORTDOCS%%%%DOCSDIR%%/Common_behavior.html
-%%PORTDOCS%%%%DOCSDIR%%/Comparison_servers.html
-%%PORTDOCS%%%%DOCSDIR%%/Compiling_and_Installing.html
-%%PORTDOCS%%%%DOCSDIR%%/Configuration.html
-%%PORTDOCS%%%%DOCSDIR%%/Copying_and_license.html
-%%PORTDOCS%%%%DOCSDIR%%/Current_events.html
-%%PORTDOCS%%%%DOCSDIR%%/Directory_configuration.html
-%%PORTDOCS%%%%DOCSDIR%%/Directory_listing.html
-%%PORTDOCS%%%%DOCSDIR%%/Encoders.html
-%%PORTDOCS%%%%DOCSDIR%%/Exquisite-khelpcenter.png
-%%PORTDOCS%%%%DOCSDIR%%/Extension_configuration.html
-%%PORTDOCS%%%%DOCSDIR%%/FastCGI.html
-%%PORTDOCS%%%%DOCSDIR%%/File_sending.html
-%%PORTDOCS%%%%DOCSDIR%%/Frequently_asked_questions.html
-%%PORTDOCS%%%%DOCSDIR%%/Gzip_encoder.html
-%%PORTDOCS%%%%DOCSDIR%%/How_to_generate_SSL_keys.html
-%%PORTDOCS%%%%DOCSDIR%%/How_to_manage_Virtual_Host.html
-%%PORTDOCS%%%%DOCSDIR%%/Htdigest_validator.html
-%%PORTDOCS%%%%DOCSDIR%%/Htpasswd_validator.html
-%%PORTDOCS%%%%DOCSDIR%%/Icons_configuration.html
-%%PORTDOCS%%%%DOCSDIR%%/Jaws_and_Cherokee_with_FastCGI.html
-%%PORTDOCS%%%%DOCSDIR%%/Logging_system.html
-%%PORTDOCS%%%%DOCSDIR%%/Mime_types_configuration.html
-%%PORTDOCS%%%%DOCSDIR%%/NCSA_logger.html
-%%PORTDOCS%%%%DOCSDIR%%/NCSA_logs.html
-%%PORTDOCS%%%%DOCSDIR%%/PAM_validator.html
-%%PORTDOCS%%%%DOCSDIR%%/PHP_execution.html
-%%PORTDOCS%%%%DOCSDIR%%/Plain_validator.html
-%%PORTDOCS%%%%DOCSDIR%%/Redirections.html
-%%PORTDOCS%%%%DOCSDIR%%/Request_configuration.html
-%%PORTDOCS%%%%DOCSDIR%%/Ruby_on_Rails_with_SCGI.html
-%%PORTDOCS%%%%DOCSDIR%%/SCGI.html
-%%PORTDOCS%%%%DOCSDIR%%/Server-conf-small.png
-%%PORTDOCS%%%%DOCSDIR%%/Server_configuration.html
-%%PORTDOCS%%%%DOCSDIR%%/U-Cherokee.html
-%%PORTDOCS%%%%DOCSDIR%%/Validators.html
-%%PORTDOCS%%%%DOCSDIR%%/W3C_logger.html
-%%PORTDOCS%%%%DOCSDIR%%/W3C_logs.html
-%%PORTDOCS%%%%DOCSDIR%%/WebApplications.html
-%%PORTDOCS%%%%DOCSDIR%%/cherokee.png
-%%PORTDOCS%%%%DOCSDIR%%/index.html
-www/images/cherokee-logo.png
-www/images/default-bg.png
-www/images/powered_by_cherokee.png
-www/index.html
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm %%DATADIR%%/icons
-@dirrm %%DATADIR%%/deps
-@dirrm %%DATADIR%%
-@dirrm lib/cherokee
-@dirrm include/cherokee
-@dirrm etc/cherokee/ssl
-@dirrm etc/cherokee/sites-enabled
-@dirrm etc/cherokee/sites-available
-@dirrm etc/cherokee/mods-enabled
-@dirrm etc/cherokee/mods-available
-@dirrm etc/cherokee
-@dirrmtry www/images
-@dirrmtry www/data