aboutsummaryrefslogtreecommitdiff
path: root/www/cherokee/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/cherokee/Makefile')
-rw-r--r--www/cherokee/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/www/cherokee/Makefile b/www/cherokee/Makefile
index d3987b2dae4f..42f04874098a 100644
--- a/www/cherokee/Makefile
+++ b/www/cherokee/Makefile
@@ -17,7 +17,7 @@ GH_PROJECT= webserver
GH_TAGNAME= ${PORTVERSION:S/^/v/}
GH_COMMIT= e5583c6
-USES= autoreconf gettext gmake libtool pathfix pkgconfig \
+USES= autoreconf cpe gettext gmake libtool pathfix pkgconfig \
python:2,build shebangfix
SHEBANG_FILES= admin/CTK/CTK-run.pre admin/server.py \
admin/upgrade_config.py cherokee/cherokee-admin-launcher \
@@ -42,6 +42,8 @@ MAKE_ARGS= pkgconfigdir=${PREFIX}/libdata/pkgconfig
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
+CPE_VENDOR= cherokee-project
+
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -pthread