aboutsummaryrefslogtreecommitdiff
path: root/www/chpasswd
diff options
context:
space:
mode:
Diffstat (limited to 'www/chpasswd')
-rw-r--r--www/chpasswd/Makefile12
-rw-r--r--www/chpasswd/files/patch-chpasswd.c19
2 files changed, 17 insertions, 14 deletions
diff --git a/www/chpasswd/Makefile b/www/chpasswd/Makefile
index 7142642014d4..b765e943f114 100644
--- a/www/chpasswd/Makefile
+++ b/www/chpasswd/Makefile
@@ -7,9 +7,9 @@
PORTNAME= chpasswd
PORTVERSION= 2.2.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITES= SF
MASTER_SITE_SUBDIR= orsochpasswd
MAINTAINER= jmelo@FreeBSD.org
@@ -21,16 +21,10 @@ CONFIGURE_ARGS= --prefix=${PREFIX}/etc/chpasswd \
--enable-language=English \
--enable-cgidir=${PREFIX}/www/cgi-bin
-.include <bsd.port.pre.mk>
-
-.if (${OSVERSION} >= 700000)
-BROKEN= Does not compile on 7.X
-.endif
-
pre-install:
@${MKDIR} ${PREFIX}/www/cgi-bin
post-install:
@${ECHO} 'Remember, passwd and log file must be owned by httpd user, or chmod 777'
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/chpasswd/files/patch-chpasswd.c b/www/chpasswd/files/patch-chpasswd.c
index 13b2872d0767..171961cf36a9 100644
--- a/www/chpasswd/files/patch-chpasswd.c
+++ b/www/chpasswd/files/patch-chpasswd.c
@@ -1,8 +1,17 @@
---- chpasswd.c.orig Fri Apr 11 01:54:02 2003
-+++ chpasswd.c Wed Sep 22 15:46:47 2004
-@@ -23,6 +23,16 @@
- static void vrfyauth(IpAuth,PwdLogFile,PwdFile,SmtpUser,SmtpSubject);
- eperror(s);
+--- chpasswd.c.orig 2005-05-09 13:05:08.000000000 +0000
++++ chpasswd.c 2007-11-08 15:10:11.000000000 +0000
+@@ -282,7 +282,7 @@
+ }
+
+
+-static int
++int
+ htoi(s)
+ unsigned char *s;
+ {
+@@ -664,6 +664,16 @@
+ }
+
+void getword(char *, char *, char);
+void Herror(char *);