aboutsummaryrefslogtreecommitdiff
path: root/www/chromium/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/chromium/Makefile')
-rw-r--r--www/chromium/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index e248d37833cc..3a8945465b8a 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -3,7 +3,7 @@
PORTNAME= chromium
PORTVERSION= 68.0.3440.106
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES?= www
MASTER_SITES= https://commondatastorage.googleapis.com/chromium-browser-official/ \
LOCAL/cpm/chromium/:fonts
@@ -69,10 +69,11 @@ ONLY_FOR_ARCHS= aarch64 amd64 i386
.endif
.if defined(GN_ONLY)
-USES= compiler:c++14-lang ninja pkgconfig python:2.7,build shebangfix tar:xz
-.else
-USES= bison cpe desktop-file-utils jpeg ninja perl5 pkgconfig \
+USES= compiler:c++14-lang localbase:ldflags ninja pkgconfig \
python:2.7,build shebangfix tar:xz
+.else
+USES= bison cpe desktop-file-utils gnome jpeg localbase:ldflags \
+ ninja perl5 pkgconfig python:2.7,build shebangfix tar:xz
.endif
MAKE_ARGS= -C out/${BUILDTYPE}
BINARY_ALIAS= python=${PYTHON_CMD}
@@ -120,8 +121,8 @@ GN_ARGS+= clang_use_chrome_plugins=false \
use_system_freetype=true \
use_system_harfbuzz=true \
use_system_libjpeg=true \
- extra_cxxflags="-I${LOCALBASE}/include" \
- extra_ldflags="-L${LOCALBASE}/lib"
+ extra_cxxflags="${CXXFLAGS}" \
+ extra_ldflags="${LDFLAGS}"
# TODO: investigate building with these options:
# use_system_minigbm
GN_BOOTSTRAP_FLAGS= --no-clean --no-rebuild
@@ -196,7 +197,8 @@ SNDIO_VARS_OFF= GN_ARGS+=use_sndio=false
.endif
-TEST_ALL_TARGET= base_unittests
+.include "Makefile.tests"
+TEST_ALL_TARGET= ${TEST_TARGETS}
TEST_DISTFILES= ${PORTNAME}-${DISTVERSION}-testdata${EXTRACT_SUFX} \
test_fonts${EXTRACT_SUFX}:fonts