aboutsummaryrefslogtreecommitdiff
path: root/www/cocoon/Makefile.test-options
diff options
context:
space:
mode:
Diffstat (limited to 'www/cocoon/Makefile.test-options')
-rw-r--r--www/cocoon/Makefile.test-options50
1 files changed, 46 insertions, 4 deletions
diff --git a/www/cocoon/Makefile.test-options b/www/cocoon/Makefile.test-options
index 1a669d12c3dd..91b27738bf28 100644
--- a/www/cocoon/Makefile.test-options
+++ b/www/cocoon/Makefile.test-options
@@ -38,6 +38,7 @@ BLOCKS+= html
.if defined(WITH_ITEXT)
BLOCKS+= itext
+BLOCKS+= xsp
.endif
.if defined(WITH_JFOR)
@@ -57,12 +58,17 @@ BLOCKS+= xsp
BLOCKS+= lucene
.endif
+.if defined(WITH_MIDI)
+BLOCKS+= midi
+.endif
+
.if defined(WITH_NAMING)
BLOCKS+= naming
.endif
.if defined(WITH_OJB)
BLOCKS+= ojb
+BLOCKS+= ajax
BLOCKS+= databases
BLOCKS+= forms
BLOCKS+= hsqldb
@@ -79,9 +85,13 @@ BLOCKS+= poi
.if defined(WITH_PORTAL)
BLOCKS+= portal
+BLOCKS+= ajax
BLOCKS+= authentication-fw
BLOCKS+= cron
+BLOCKS+= databases
BLOCKS+= forms
+BLOCKS+= hsqldb
+BLOCKS+= ojb
BLOCKS+= session-fw
BLOCKS+= xsp
.endif
@@ -138,8 +148,13 @@ BLOCKS+= woody
BLOCKS+= xsp
.endif
+.if defined(WITH_AJAX)
+BLOCKS+= ajax
+.endif
+
.if defined(WITH_APPLES)
BLOCKS+= apples
+BLOCKS+= ajax
BLOCKS+= forms
.endif
@@ -151,6 +166,10 @@ BLOCKS+= asciiart
BLOCKS+= axis
.endif
+.if defined(WITH_CAPTCHA)
+BLOCKS+= captcha
+.endif
+
.if defined(WITH_CRON)
BLOCKS+= cron
.endif
@@ -161,6 +180,7 @@ BLOCKS+= deli
.if defined(WITH_EVENTCACHE)
BLOCKS+= eventcache
+BLOCKS+= cron
BLOCKS+= databases
BLOCKS+= hsqldb
BLOCKS+= jms
@@ -169,9 +189,13 @@ BLOCKS+= xsp
.if defined(WITH_FACES)
BLOCKS+= faces
+BLOCKS+= ajax
BLOCKS+= authentication-fw
BLOCKS+= cron
+BLOCKS+= databases
BLOCKS+= forms
+BLOCKS+= hsqldb
+BLOCKS+= ojb
BLOCKS+= portal
BLOCKS+= session-fw
BLOCKS+= taglib
@@ -180,10 +204,12 @@ BLOCKS+= xsp
.if defined(WITH_FORMS)
BLOCKS+= forms
+BLOCKS+= ajax
.endif
.if defined(WITH_JAVAFLOW)
BLOCKS+= javaflow
+BLOCKS+= ajax
BLOCKS+= databases
BLOCKS+= forms
BLOCKS+= hsqldb
@@ -191,8 +217,13 @@ BLOCKS+= ojb
BLOCKS+= xsp
.endif
+.if defined(WITH_JCR)
+BLOCKS+= jcr
+.endif
+
.if defined(WITH_JMS)
BLOCKS+= jms
+BLOCKS+= cron
BLOCKS+= databases
BLOCKS+= hsqldb
BLOCKS+= xsp
@@ -207,12 +238,9 @@ BLOCKS+= mail
BLOCKS+= asciiart
.endif
-.if defined(WITH_MIDI)
-BLOCKS+= midi
-.endif
-
.if defined(WITH_PETSTORE)
BLOCKS+= petstore
+BLOCKS+= ajax
BLOCKS+= databases
BLOCKS+= forms
BLOCKS+= hsqldb
@@ -230,6 +258,7 @@ BLOCKS+= qdox
.if defined(WITH_QUERYBEAN)
BLOCKS+= querybean
+BLOCKS+= ajax
BLOCKS+= databases
BLOCKS+= forms
BLOCKS+= hsqldb
@@ -240,6 +269,7 @@ BLOCKS+= xsp
.if defined(WITH_REPOSITORY)
BLOCKS+= repository
+BLOCKS+= cron
BLOCKS+= databases
BLOCKS+= eventcache
BLOCKS+= hsqldb
@@ -253,6 +283,7 @@ BLOCKS+= serializers
.if defined(WITH_SLIDE)
BLOCKS+= slide
+BLOCKS+= cron
BLOCKS+= databases
BLOCKS+= eventcache
BLOCKS+= hsqldb
@@ -275,13 +306,20 @@ BLOCKS+= taglib
.if defined(WITH_TOUR)
BLOCKS+= tour
+BLOCKS+= ajax
BLOCKS+= batik
BLOCKS+= fop
BLOCKS+= forms
+BLOCKS+= slop
+.endif
+
+.if defined(WITH_VALIDATION)
+BLOCKS+= validation
.endif
.if defined(WITH_WEBDAV)
BLOCKS+= webdav
+BLOCKS+= cron
BLOCKS+= databases
BLOCKS+= eventcache
BLOCKS+= hsqldb
@@ -290,3 +328,7 @@ BLOCKS+= repository
BLOCKS+= xsp
.endif
+.if defined(WITH_XSLTAL)
+BLOCKS+= xsltal
+.endif
+