aboutsummaryrefslogtreecommitdiff
path: root/www/dansguardian/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/dansguardian/Makefile')
-rw-r--r--www/dansguardian/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/www/dansguardian/Makefile b/www/dansguardian/Makefile
index 198890c42af3..f52381dbf2d0 100644
--- a/www/dansguardian/Makefile
+++ b/www/dansguardian/Makefile
@@ -27,7 +27,6 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --bindir=/sbin/ \
--sysconfdir=/etc/dansguardian/ \
--sysvdir=/etc/rc.d/ \
- --mandir=/man/ \
--logdir=/var/log/ \
--cgidir=/www/cgi-bin/ \
--piddir=/var/run/ \
@@ -55,6 +54,10 @@ USE_APACHE= 1.3+
IGNORE="Commercial source download is restricted. Please visit and read ${DG_URL} and download ${DISTNAME}${EXTRACT_SUFX} into ${DISTDIR} before running make"
.endif
+post-configure:
+ @${REINPLACE_CMD} -e 's,^MANUALFILES = .*,MANUALFILES = ${MANPREFIX}/man/,' \
+ ${WRKSRC}/Makefile
+
pre-install:
# Configure pkg-plist based on whether phraselists are to be installed or not
.if defined(WITH_DG_PHRASELISTS)