aboutsummaryrefslogtreecommitdiff
path: root/www/dillo2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/dillo2/Makefile')
-rw-r--r--www/dillo2/Makefile113
1 files changed, 60 insertions, 53 deletions
diff --git a/www/dillo2/Makefile b/www/dillo2/Makefile
index 2f4b1db46823..a0e5372ceafe 100644
--- a/www/dillo2/Makefile
+++ b/www/dillo2/Makefile
@@ -1,82 +1,89 @@
# New ports collection makefile for: dillo
-# Date created: 23 February 2001
-# Whom: George Reid <greid@ukug.uk.freebsd.org>
+# Date created: 28 August 2008
+# Whom: bf <bf2006a@yahoo.com>
#
# $FreeBSD$
-#
-# Tunables:
-# WITH_DILLO_SSL: enable experimental SSL support
-# WITH_DILLO_DLGUI: enable experimental FLTK2 based gui for file downloads
-#
PORTNAME= dillo
-PORTVERSION= 0.8.6
-PORTREVISION= 2
+PORTVERSION= 2.0
CATEGORIES= www ipv6
MASTER_SITES= http://www.dillo.org/download/
-MAINTAINER= tmseck@netcologne.de
-COMMENT= A fast, small graphical Web browser built upon GTK+
+MAINTAINER= bf2006a@yahoo.com
+COMMENT= A fast, small graphical Web browser built upon fltk2
-RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
+BUILD_DEPENDS= ${LOCALBASE}/lib/libfltk2.a:${PORTSDIR}/x11-toolkits/fltk2
+RUN_DEPENDS= ${LOCALBASE}/lib/libfltk2.a:${PORTSDIR}/x11-toolkits/fltk2 \
+ wget:${PORTSDIR}/ftp/wget
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png
USE_BZIP2= yes
-USE_GNOME= gnometarget gtk12
-USE_GMAKE= yes
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
- LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --enable-cookies --enable-threaded-dns \
- --libdir=${PREFIX}/libexec
-.if !defined(WITHOUT_DILLO_IPV6) && !defined(WITHOUT_IPV6)
-CONFIGURE_ARGS+= --enable-ipv6
+USE_GMAKE= yes
+PORTDOCS= *
+CONFIGURE_ARGS= --libdir=${PREFIX}/libexec
+CONFLICTS= dillo-i18n-[0-9]* \
+ dillo-0*
+
+OPTIONS= COOKIES "Enable cookies" On \
+ DEBUG "Enable profiling and extra logging" Off \
+ IPV6 "Enable ipv6" On \
+ SSL "Enable (experimental) https support" On \
+ THREADED_DNS "Enable re-entrant resolver library" On
+
+.include <bsd.port.pre.mk>
+
+.ifdef(WITH_COOKIES)
+CONFIGURE_ARGS+= --enable-cookies
+.else
+CONFIGURE_ARGS+= --disable-cookies
.endif
-.if defined(WITH_DILLO_SSL)
-CONFIGURE_ARGS+= --enable-ssl
-EXTRA_PATCHES+= ${PATCHDIR}/enable-ssl.patch
-USE_OPENSSL= yes
+.ifdef(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-gprof --enable-rtfl
.else
-CONFIGURE_ARGS+= --disable-ssl
+CONFIGURE_ARGS+= --disable-gprof --disable-rtfl
.endif
-.if defined(WITH_DILLO_DLGUI)
-CONFIGURE_ARGS+= --enable-dlgui
-BUILD_DEPENDS+= fltk>=2.0.r4825:${PORTSDIR}/x11-toolkits/fltk2
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+.ifdef(WITH_IPV6)
+CONFIGURE_ARGS+= --enable-ipv6
.else
-CONFIGURE_ARGS+= --disable-dlgui
+CONFIGURE_ARGS+= --disable-ipv6
.endif
-CONFLICTS= dillo-i18n-*[0-9]*
+.ifdef(WITH_SSL)
+CONFIGURE_ARGS+= --enable-ssl
+.include "${PORTSDIR}/Mk/bsd.openssl.mk"
+.else
+CONFIGURE_ARGS+= --disable-ssl
+.endif
+
+.ifdef(WITH_THREADED_DNS)
+CONFIGURE_ARGS+= --enable-threaded-dns
+CFLAGS+= ${PTHREAD_CFLAGS}
+.else
+CONFIGURE_ARGS+= --disable-threaded-dns
+.endif
post-patch:
- @${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g ; \
- s|-D_THREAD_SAFE|${PTHREAD_CFLAGS}|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|dillorc|dillorc.sample|g' ${WRKSRC}/Makefile.in
- @${CP} ${WRKSRC}/dillorc ${WRKSRC}/dillorc.sample
+.ifdef(WITH_SSL)
+ ${REINPLACE_CMD} -e '/^#undef ENABLE_SSL/d' ${WRKSRC}/dpi/https.c
+.endif
+ @${MV} ${WRKSRC}/dillorc ${WRKSRC}/dillorc.dist
+ @${REINPLACE_CMD} -e "s|dillorc|dillorc.dist|g" ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e "s|dpidrc|dpidrc.dist|g" ${WRKSRC}/dpid/Makefile.in
-pre-configure:
-.if !defined(WITH_DILLO_SSL)
- @${ECHO_CMD} ""
- @${ECHO_CMD} " Set WITH_DILLO_SSL=yes in your make environment or on the"
- @${ECHO_CMD} " commandline to enable experimental SSL support."
+post-install:
+.if !exists(${PREFIX}/etc/dillorc)
+ ${INSTALL_DATA} ${PREFIX}/etc/dillorc.dist ${PREFIX}/etc/dillorc
.endif
-.if !defined(WITH_DILLO_DLGUI)
- @${ECHO_CMD} ""
- @${ECHO_CMD} " Set WITH_DILLO_DLGUI=yes in your make environment or on the"
- @${ECHO_CMD} " commandline to enable a FLTK2 based gui for download operations."
+.if !exists(${PREFIX}/etc/dpidrc)
+ ${INSTALL_DATA} ${PREFIX}/etc/dpidrc.dist ${PREFIX}/etc/dpidrc
.endif
-.if !defined(WITHOUT_DILLO_IPV6) && !defined(WITHOUT_IPV6)
- @${ECHO_CMD} ""
- @${ECHO_CMD} " Set WITHOUT_DILLO_IPV6=yes (or WITHOUT_IPV6=yes) in your make"
- @${ECHO_CMD} " environment or on the commandline to disable IPv6 support."
+.ifndef(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/doc/* ${DOCSDIR}
.endif
- @${ECHO_CMD} ""
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>