aboutsummaryrefslogtreecommitdiff
path: root/www/elinks/files
diff options
context:
space:
mode:
Diffstat (limited to 'www/elinks/files')
-rw-r--r--www/elinks/files/patch-configure.ac19
-rw-r--r--www/elinks/files/patch-meson.build13
-rw-r--r--www/elinks/files/patch-src_config_options.c28
-rw-r--r--www/elinks/files/patch-src_intl_gettext_libintl.h11
4 files changed, 52 insertions, 19 deletions
diff --git a/www/elinks/files/patch-configure.ac b/www/elinks/files/patch-configure.ac
deleted file mode 100644
index 3c9bfe209491..000000000000
--- a/www/elinks/files/patch-configure.ac
+++ /dev/null
@@ -1,19 +0,0 @@
---- configure.ac.orig 2021-12-24 19:53:43 UTC
-+++ configure.ac
-@@ -531,6 +531,7 @@ else
- if $PKG_CONFIG $pkg_config_static libbrotlidec; then
- BROTLI_CFLAGS=`$PKG_CONFIG $pkg_config_static --cflags libbrotlidec`
- BROTLI_LIBS=`$PKG_CONFIG $pkg_config_static --libs libbrotlidec`
-+ CFLAGS="$BROTLI_CFLAGS $CFLAGS"
- LIBS="$BROTLI_LIBS $LIBS"
- CONFIG_BROTLI=yes
- AC_DEFINE([CONFIG_BROTLI], [1], [Define as 1 to use the libbrotli library.])
-@@ -1861,7 +1862,7 @@ if test "x$ac_cv_c_compiler_gnu" = "xyes"; then
- ;;
- 10|10.*|11|11.*)
- # gettext
-- CFLAGS="$CFLAGS -fno-strict-aliasing -Wno-builtin-declaration-mismatch -Wno-array-bounds"
-+ CFLAGS="$CFLAGS -fno-strict-aliasing -Wno-array-bounds"
- ;;
- *)
- # These should be ok using -Werror
diff --git a/www/elinks/files/patch-meson.build b/www/elinks/files/patch-meson.build
new file mode 100644
index 000000000000..dd8549a15b67
--- /dev/null
+++ b/www/elinks/files/patch-meson.build
@@ -0,0 +1,13 @@
+--- meson.build.orig 2022-07-31 10:16:29 UTC
++++ meson.build
+@@ -3,9 +3,7 @@ srcdir = meson.source_root()
+
+ srcdir = meson.source_root()
+
+-txt = run_command('git', '--git-dir=' + srcdir + '/.git', 'rev-parse', 'HEAD').stdout().strip()
+-dirty = run_command(srcdir + '/git-dirty.sh').stdout().strip()
+-add_global_arguments('-DBUILD_ID="' + txt + dirty + '"', language : 'c')
++add_global_arguments('-DBUILD_ID="\\0"', language : 'c')
+
+ conf_data = configuration_data()
+ conf_data.set('VERSION', meson.project_version())
diff --git a/www/elinks/files/patch-src_config_options.c b/www/elinks/files/patch-src_config_options.c
new file mode 100644
index 000000000000..b59ebc61f415
--- /dev/null
+++ b/www/elinks/files/patch-src_config_options.c
@@ -0,0 +1,28 @@
+--- src/config/options.c.orig 2022-07-31 10:16:29 UTC
++++ src/config/options.c
+@@ -892,6 +892,7 @@ change_hook_ui_double_esc(struct session *ses, struct
+ return 0;
+ }
+
++#ifdef CONFIG_MOUSE
+ static int
+ change_hook_ui_mouse_disable(struct session *ses, struct option *current, struct option *changed)
+ {
+@@ -907,6 +908,7 @@ change_hook_ui_mouse_disable(struct session *ses, stru
+ }
+ return 0;
+ }
++#endif
+
+
+ /** Make option templates visible or invisible in the option manager.
+@@ -984,7 +986,9 @@ static const struct change_hook_info change_hooks[] =
+ { "ui.colors", change_hook_ui_colors },
+ { "ui.double_esc", change_hook_ui_double_esc },
+ { "ui.language", change_hook_language },
++#ifdef CONFIG_MOUSE
+ { "ui.mouse_disable", change_hook_ui_mouse_disable },
++#endif
+ { "ui", change_hook_ui },
+ { NULL, NULL },
+ };
diff --git a/www/elinks/files/patch-src_intl_gettext_libintl.h b/www/elinks/files/patch-src_intl_gettext_libintl.h
new file mode 100644
index 000000000000..827752d8ad8f
--- /dev/null
+++ b/www/elinks/files/patch-src_intl_gettext_libintl.h
@@ -0,0 +1,11 @@
+--- src/intl/gettext/libintl.h.orig 2022-07-31 10:16:29 UTC
++++ src/intl/gettext/libintl.h
+@@ -44,7 +44,7 @@ _(const char *msg, struct terminal *term)
+ return (char *)gettext_noop(msg);
+ }
+
+-static inline char *
++static inline const char *
+ n_(const char *msg1, const char *msg2, unsigned long int n, struct terminal *term)
+ {
+ return gettext_noop(msg1);