aboutsummaryrefslogtreecommitdiff
path: root/www/firefox-i18n/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/firefox-i18n/Makefile')
-rw-r--r--www/firefox-i18n/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/www/firefox-i18n/Makefile b/www/firefox-i18n/Makefile
index 5dbf167c4a99..eaa8f51c096d 100644
--- a/www/firefox-i18n/Makefile
+++ b/www/firefox-i18n/Makefile
@@ -7,6 +7,7 @@
PORTNAME= firefox-i18n
PORTVERSION= 6.0
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITE_SUBDIR= firefox/releases/${PORTVERSION}/linux-i686/xpi
PKGNAMEPREFIX=
@@ -19,7 +20,7 @@ COMMENT= Localized interface for Firefox 5.0
EXTRACT_DEPENDS= zip:${PORTSDIR}/archivers/zip
USE_FIREFOX= yes
-USE_XPI= *firefox
+USE_XPI= firefox
USE_SUBMAKE= yes
@@ -56,8 +57,10 @@ do-extract:
then \
exit 1; \
fi; \
- cd ${WRKSRC}/langpack-$$lang@firefox.mozilla.org/chrome; \
- ${LOCALBASE}/bin/zip -r $$lang.jar $$lang; \
+ cd ${WRKSRC}/langpack-$$lang@firefox.mozilla.org/chrome/$$lang; \
+ ${LOCALBASE}/bin/zip -r ../$$lang.jar locale; \
+ cd ..; ${RM} -rf $$lang; cd ..; \
+ ${REINPLACE_CMD} -i "" "s,chrome/$$lang,jar:chrome/$$lang.jar!," chrome.manifest; \
done
.if !exists(${OPTIONSFILE}) && !defined(PACKAGE_BUILDING)