aboutsummaryrefslogtreecommitdiff
path: root/www/firefox/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/firefox/Makefile')
-rw-r--r--www/firefox/Makefile26
1 files changed, 11 insertions, 15 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index e1f36bdd8f87..03a82750137a 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -9,15 +9,14 @@
PORTNAME= phoenix
PORTVERSION= 0.4
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= www # pita
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= trevor
MAINTAINER= phoenix@freebsd.org # alane@fbsd and trevor@fbsd
-LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
- jpeg.9:${PORTSDIR}/graphics/jpeg \
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
mng.1:${PORTSDIR}/graphics/libmng \
freetype.9:${PORTSDIR}/print/freetype2 \
@@ -39,18 +38,21 @@ HAS_CONFIGURE= yes
USE_GNOMENG= yes
USE_GNOME= gtk12 orbit
+CPPFLAGS+= -I${X11BASE}/include
CFLAGS+= ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${X11BASE}/lib
LIBS+= ${PTHREAD_LIBS}
NO_MTREE= yes
WRKSRC= ${WRKDIR}/mozilla
LOCAL_PREFIX= ${PREFIX}/lib/${PORTNAME}
-MAKE_ENV+= XP_UNIX=1
-MAKE_ARGS+= XP_UNIX=1
.include <bsd.port.pre.mk>
.if !defined(PERL_LEVEL)
+.if !exists(${LOCALBASE}/bin/perl)
+PERL_LEVEL=0
+.endif # !exists(${LOCALBASE}/bin/perl)
perl_major=${PERL_VERSION:C|^([1-9]+).*|\1|}
_perl_minor=00${PERL_VERSION:C|^([1-9]+)\.([0-9]+).*|\2|}
perl_minor=${_perl_minor:C|^.*(...)|\1|}
@@ -66,20 +68,12 @@ PERL_LEVEL=${perl_major}${perl_minor}${perl_patch}
SITE_PERL?= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
-.if ${OSVERSION} > 500038
-
-BROKEN= "on -CURRENT, can only be used with local files. You can run"
-BROKEN+="make with -DNO_IGNORE to override this message"
-
-.endif
-
.if ${PERL_LEVEL} < 500601
.undef NO_IGNORE
BROKEN= "right now, we can only support the ports versions of Perl."
BROKEN+="We are working on the problem. Sorry for the inconvenience."
BROKEN+="If you have installed a Perl port, and are getting this message,"
BROKEN+="please make sure you have issued the command 'use.perl port'"
-
.endif # ${PERL_LEVEL} < 500601
pre-extract::
@@ -88,7 +82,9 @@ pre-extract::
@${ECHO_MSG}
post-extract::
- @${SED} -e 's|@CFLAGS@|${CFLAGS}|' \
+ @${SED} -e 's|@CPPFLAGS@|${CPPFLAGS}|' \
+ -e 's|@CFLAGS@|${CFLAGS}|' \
+ -e 's|@LDFLAGS@|${LDFLAGS}|' \
-e 's|@LIBS@|${LIBS}|' \
-e 's|@X11BASE@|${X11BASE}|' \
-e 's|@LOCALBASE@|${LOCALBASE}|' \
@@ -110,7 +106,7 @@ post-install:
@${LN} -s ${LOCAL_PREFIX}/bin/mozilla-config \
${PREFIX}/bin/phoenix-config
@${CAT} ${PKGMESSAGE} 2>/dev/null; sleep 5
- @${RM} -fr ${LOCAL_PREFIX}/share
+ @${RM} -fr ${LOCAL_PREFIX}/share/idl
@${RM} -fr ${LOCAL_PREFIX}/include
.include <bsd.port.post.mk>