aboutsummaryrefslogtreecommitdiff
path: root/www/firefox/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/firefox/Makefile')
-rw-r--r--www/firefox/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index bd328eda4498..017069a4b098 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= firefox
-DISTVERSION= 3.6.13
+DISTVERSION= 3.6.14
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA}
@@ -63,6 +63,15 @@ EXTRA_PATCHES= ${FILESDIR}/releng6_pulseaudio
EXTRA_PATCHES= ${FILESDIR}/libsydney_oss
.endif
+.if ${ARCH} == powerpc64
+.if ${OSVERSION} < 900033
+BROKEN= Needs binutils 2.17.50 to build
+.else
+CONFIGURE_ENV+= UNAME_m="powerpc64"
+CFLAGS+= -mminimal-toc
+.endif
+.endif
+
WRKSRC:= ${WRKSRC}-1.9.2
GECKO_PTHREAD_LIBS!=${CC} -dumpspecs | ${GREP} -m 1 '%{\!pg: %{pthread:' | ${SED} -e 's|^.*%{\!pg: %{pthread:|| ; s|}.*$$||' || ${TRUE}