aboutsummaryrefslogtreecommitdiff
path: root/www/firefox/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/firefox/Makefile')
-rw-r--r--www/firefox/Makefile22
1 files changed, 16 insertions, 6 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 8de59bf092bc..a197d83f1ecb 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -9,22 +9,24 @@
PORTNAME= phoenix
PORTVERSION= 0.3
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= trevor
-MAINTAINER= alane@freebsd.org # will change to trevor@ soon
-
-BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
- freetype-config:${PORTSDIR}/print/freetype2 \
- perl5.8.0:${PORTSDIR}/lang/perl5.8
+MAINTAINER= alane@freebsd.org # and trevor@freebsd.org
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
mng.1:${PORTSDIR}/graphics/libmng \
freetype.9:${PORTSDIR}/print/freetype2
+BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
+ freetype-config:${PORTSDIR}/print/freetype2 \
+ perl5.8.0:${PORTSDIR}/lang/perl5.8
+
+PREFIX= ${X11BASE}/lib/${PORTNAME}
+
USE_BZIP2= yes
USE_GMAKE= yes
#USE_AUTOCONF_VER= 213
@@ -34,11 +36,19 @@ WRKSRC= ${WRKDIR}/mozilla
.include <bsd.port.pre.mk>
+.if !defined(PERL_VER) || ${PERL_VER} != 5.8.0
+.error This port requires Perl 5.8.0.
+.endif
+
post-extract:
${SED} -e 's|@X11BASE@|${X11BASE}|' \
-e 's|@LOCALBASE@|${LOCALBASE}|' \
<${FILESDIR}/mozconfig.in >${WRKSRC}/.mozconfig
+post-install:
+ ${LN} -s ${PREFIX}/bin/phoenix ${X11BASE}/bin/phoenix
+ ${LN} -s ${PREFIX}/bin/mozilla-config ${X11BASE}/bin/phoenix-config
+
.include <bsd.port.post.mk>
#EOF