aboutsummaryrefslogtreecommitdiff
path: root/www/firefox/files/patch-bug847568
diff options
context:
space:
mode:
Diffstat (limited to 'www/firefox/files/patch-bug847568')
-rw-r--r--www/firefox/files/patch-bug84756819
1 files changed, 7 insertions, 12 deletions
diff --git a/www/firefox/files/patch-bug847568 b/www/firefox/files/patch-bug847568
index 5c5d687877dd..76b07298304f 100644
--- a/www/firefox/files/patch-bug847568
+++ b/www/firefox/files/patch-bug847568
@@ -101,9 +101,9 @@ diff --git gfx/graphite2/moz-gr-update.sh gfx/graphite2/moz-gr-update.sh
index f3d76ea..a9e7fb6 100644
--- gfx/graphite2/moz-gr-update.sh
+++ gfx/graphite2/moz-gr-update.sh
-@@ -23,8 +23,14 @@ echo "\nSee" $0 "for update procedure.\n" >> gfx/graphite2/README.mozilla
- find gfx/graphite2/ -name "*.cpp" -exec perl -p -i -e "s/<cstdio>/<stdio.h>/;s/Windows.h/windows.h/;" {} \;
- find gfx/graphite2/ -name "*.h" -exec perl -p -i -e "s/<cstdio>/<stdio.h>/;s/Windows.h/windows.h/;" {} \;
+@@ -37,6 +37,12 @@
+ #find gfx/graphite2/ -name "*.cpp" -exec perl -p -i -e "s/<cstdio>/<stdio.h>/;s/Windows.h/windows.h/;" {} \;
+ #find gfx/graphite2/ -name "*.h" -exec perl -p -i -e "s/<cstdio>/<stdio.h>/;s/Windows.h/windows.h/;" {} \;
+# closest tag/release to require for system version
+TAG=$(cd ../graphitedev/ && hg parents --template {latesttag})
@@ -112,11 +112,8 @@ index f3d76ea..a9e7fb6 100644
+ if /GR2_VERSION_REQUIRE/" configure.in
+
# summarize what's been touched
--echo Updated to $CHANGESET.
-+echo Updated to $CHANGESET \($TAG for --with-system-graphite2\)
+ echo Updated to $RELEASE.
echo Here is what changed in the gfx/graphite2 directory:
- echo
-
diff --git gfx/harfbuzz/README-mozilla gfx/harfbuzz/README-mozilla
index ca57d16..1ce21fe 100644
--- gfx/harfbuzz/README-mozilla
@@ -207,16 +204,14 @@ diff --git intl/unicharutil/util/moz.build intl/unicharutil/util/moz.build
index d736943..41a931f 100644
--- intl/unicharutil/util/moz.build
+++ intl/unicharutil/util/moz.build
-@@ -42,6 +42,9 @@ if CONFIG['_MSC_VER']:
- if CONFIG['ENABLE_INTL_API']:
+@@ -43,4 +43,7 @@
CXXFLAGS += CONFIG['MOZ_ICU_CFLAGS']
+ USE_LIBS += ['icu']
+if CONFIG['MOZ_NATIVE_HARFBUZZ']:
+ CXXFLAGS += CONFIG['MOZ_HARFBUZZ_CFLAGS']
+
- if CONFIG['GNU_CXX']:
- FAIL_ON_WARNINGS = True
-
+ DIST_INSTALL = True
diff --git netwerk/dns/moz.build netwerk/dns/moz.build
index 0b0717a..2e665c9 100644
--- netwerk/dns/moz.build