aboutsummaryrefslogtreecommitdiff
path: root/www/firefox15/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/firefox15/Makefile')
-rw-r--r--www/firefox15/Makefile28
1 files changed, 19 insertions, 9 deletions
diff --git a/www/firefox15/Makefile b/www/firefox15/Makefile
index 6663e46fa276..8de59bf092bc 100644
--- a/www/firefox15/Makefile
+++ b/www/firefox15/Makefile
@@ -8,27 +8,37 @@
#
PORTNAME= phoenix
-PORTVERSION= 0.3.20021021
+PORTVERSION= 0.3
PORTREVISION= 0
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= alane
+MASTER_SITE_SUBDIR= trevor
MAINTAINER= alane@freebsd.org # will change to trevor@ soon
-.if !defined(RING_OF_FIRE)
-.undef NO_IGNORE
-BORKED= This is a work in progress.
-BROKEN= ${BORKED}
-FORBIDDEN= ${BORKED}
-.endif # !defined(RING_OF_FIRE)
+BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
+ freetype-config:${PORTSDIR}/print/freetype2 \
+ perl5.8.0:${PORTSDIR}/lang/perl5.8
+
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ png.5:${PORTSDIR}/graphics/png \
+ mng.1:${PORTSDIR}/graphics/libmng \
+ freetype.9:${PORTSDIR}/print/freetype2
USE_BZIP2= yes
USE_GMAKE= yes
-USE_AUTOCONF_VER= 213
+#USE_AUTOCONF_VER= 213
GNU_CONFIGURE= yes
+WRKSRC= ${WRKDIR}/mozilla
+
.include <bsd.port.pre.mk>
+
+post-extract:
+ ${SED} -e 's|@X11BASE@|${X11BASE}|' \
+ -e 's|@LOCALBASE@|${LOCALBASE}|' \
+ <${FILESDIR}/mozconfig.in >${WRKSRC}/.mozconfig
+
.include <bsd.port.post.mk>
#EOF