aboutsummaryrefslogtreecommitdiff
path: root/www/firefox35
diff options
context:
space:
mode:
Diffstat (limited to 'www/firefox35')
-rw-r--r--www/firefox35/Makefile4
-rw-r--r--www/firefox35/files/mozconfig.in4
2 files changed, 6 insertions, 2 deletions
diff --git a/www/firefox35/Makefile b/www/firefox35/Makefile
index e29b771f7c35..57b32b21368c 100644
--- a/www/firefox35/Makefile
+++ b/www/firefox35/Makefile
@@ -37,6 +37,10 @@ WRKSRC= ${WRKDIR}/mozilla
.include <bsd.port.pre.mk>
+.if !defined(PERL_VER) || ${PERL_VER} != "5.8.0"
+BROKEN= This port requires Perl 5.8.0 because of File::Spec issues.
+.endif # !defined(PERL_VER) || ${PERL_VER} != "5.8.0"
+
post-extract:
${SED} -e 's|@CFLAGS@|${CFLAGS}|' \
-e 's|@LIBS@|${LIBS}|' \
diff --git a/www/firefox35/files/mozconfig.in b/www/firefox35/files/mozconfig.in
index 336ea6e8d8c9..b931397179d9 100644
--- a/www/firefox35/files/mozconfig.in
+++ b/www/firefox35/files/mozconfig.in
@@ -14,8 +14,8 @@ ac_add_options --disable-composer
# FBSD specific
export CFLAGS=@CFLAGS@
export LIBS=@LIBS@
-#export PERL=@LOCALBASE@/bin/perl5.8.0
-#mk_add_options PERL=$PERL
+export PERL=@LOCALBASE@/bin/perl5.8.0
+mk_add_options PERL=$PERL
export GTK_CONFIG=@X11BASE@/bin/gtk12-config
mk_add_options GTK_CONFIG=$GTK_CONFIG
export GLIB_CONFIG=@LOCALBASE@/bin/glib12-config