aboutsummaryrefslogtreecommitdiff
path: root/www/firefox36/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/firefox36/Makefile')
-rw-r--r--www/firefox36/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/www/firefox36/Makefile b/www/firefox36/Makefile
index 0ed05ba057ec..f2eb5ed038e2 100644
--- a/www/firefox36/Makefile
+++ b/www/firefox36/Makefile
@@ -31,8 +31,6 @@ USE_GCC= 3.4+
FIREFOX_ICON= ${MOZILLA}.xpm
FIREFOX_ICON_SRC= ${PREFIX}/lib/${MOZILLA}/icons/default.xpm
MOZ_OPTIONS= --enable-application=browser \
- --enable-svg \
- --enable-svg-renderer=cairo \
--enable-system-cairo \
--enable-official-branding \
--enable-canvas
@@ -50,6 +48,10 @@ OPTIONS= NEWTAB "Open external links in a new tab" on \
IGNORE= core dumps on alpha during post-build
.endif
+.if ${OSVERSION} >= 504101
+MOZ_OPTIONS+= --enable-svg --enable-svg-renderer=cairo
+.endif
+
.if ${PERL_LEVEL} < 500600
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config_make-jars.pl
.endif