aboutsummaryrefslogtreecommitdiff
path: root/www/firefox3
diff options
context:
space:
mode:
Diffstat (limited to 'www/firefox3')
-rw-r--r--www/firefox3/Makefile5
-rw-r--r--www/firefox3/distinfo6
-rw-r--r--www/firefox3/files/patch-xpcom_reflect_xptcall_src_md_unix_Makefile.in39
3 files changed, 29 insertions, 21 deletions
diff --git a/www/firefox3/Makefile b/www/firefox3/Makefile
index b36e398156f3..48a76c22f815 100644
--- a/www/firefox3/Makefile
+++ b/www/firefox3/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= firefox
-DISTVERSION= 3.0.1
-PORTREVISION= 1
+DISTVERSION= 3.0.4
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA}
@@ -58,7 +57,7 @@ OPTIONS= DBUS "Enable D-BUS support" on \
.include <bsd.port.pre.mk>
-GECKO_PTHREAD_LIBS!=${CC} -dumpspecs | ${GREP} -m 1 pthread | ${SED} -e 's|^.*%{\!pg: %{pthread:|| ; s|}.*$$||' || ${TRUE}
+GECKO_PTHREAD_LIBS!=${CC} -dumpspecs | ${GREP} -m 1 '%{\!pg: %{pthread:' | ${SED} -e 's|^.*%{\!pg: %{pthread:|| ; s|}.*$$||' || ${TRUE}
.if ${HAVE_GNOME:Mlibgnomeui}!=""
USE_GNOME+= libgnomeui
diff --git a/www/firefox3/distinfo b/www/firefox3/distinfo
index c029a3ca06a4..746858b101b2 100644
--- a/www/firefox3/distinfo
+++ b/www/firefox3/distinfo
@@ -1,3 +1,3 @@
-MD5 (firefox-3.0.1-source.tar.bz2) = 406d67174f8f74ab154a1b17d0881b27
-SHA256 (firefox-3.0.1-source.tar.bz2) = e16c9794b624188a85af52a2f61131189f422cb99c7fb9777686741cb330dc33
-SIZE (firefox-3.0.1-source.tar.bz2) = 36868928
+MD5 (firefox-3.0.4-source.tar.bz2) = 8a1ac4a5940108a96458c5307a74c98d
+SHA256 (firefox-3.0.4-source.tar.bz2) = 685df7c7f33fc71a8c2d0fb71e190d59e2dd92007c2ace1ad176e655fb3012d7
+SIZE (firefox-3.0.4-source.tar.bz2) = 36989339
diff --git a/www/firefox3/files/patch-xpcom_reflect_xptcall_src_md_unix_Makefile.in b/www/firefox3/files/patch-xpcom_reflect_xptcall_src_md_unix_Makefile.in
index cf4ffb04e511..b1aa7ce6c524 100644
--- a/www/firefox3/files/patch-xpcom_reflect_xptcall_src_md_unix_Makefile.in
+++ b/www/firefox3/files/patch-xpcom_reflect_xptcall_src_md_unix_Makefile.in
@@ -1,16 +1,16 @@
---- xpcom/reflect/xptcall/src/md/unix/Makefile.in.orig Thu Aug 14 21:00:23 2003
-+++ xpcom/reflect/xptcall/src/md/unix/Makefile.in Sun Feb 1 15:06:40 2004
-@@ -49,6 +49,9 @@
- ifeq (86,$(findstring 86,$(OS_TEST)))
- CPPSRCS := xptcinvoke_unixish_x86.cpp xptcstubs_unixish_x86.cpp
+--- xpcom/reflect/xptcall/src/md/unix/Makefile.in
++++ xpcom/reflect/xptcall/src/md/unix/Makefile.in
+@@ -70,6 +70,9 @@
+ ifeq (Darwin,$(OS_ARCH))
+ DEFINES += -DKEEP_STACK_16_BYTE_ALIGNED
endif
+ifeq (x86_64,$(OS_TEST))
+CPPSRCS := xptcinvoke_x86_64_linux.cpp xptcstubs_x86_64_linux.cpp
+endif
endif
+ endif
#
- # New code for Linux, et. al., with gcc
-@@ -60,7 +63,7 @@
+@@ -87,7 +90,7 @@
endif
endif
# IA64 Linux
@@ -19,7 +19,7 @@
ifneq (,$(findstring ia64,$(OS_TEST)))
CPPSRCS := xptcinvoke_ipf64.cpp xptcstubs_ipf64.cpp
ASFILES := xptcstubs_asm_ipf64.s xptcinvoke_asm_ipf64.s
-@@ -106,9 +109,15 @@
+@@ -150,9 +153,15 @@
ASFILES := xptcinvoke_asm_osf1_alpha.s xptcstubs_asm_osf1_alpha.s
endif
#
@@ -36,12 +36,19 @@
CPPSRCS := xptcinvoke_linux_alpha.cpp xptcstubs_linux_alpha.cpp
endif
#
-@@ -294,6 +303,15 @@
- ifeq ($(OS_ARCH)$(OS_TEST),NetBSDsparc)
- CPPSRCS := xptcinvoke_sparc_netbsd.cpp xptcstubs_sparc_netbsd.cpp
+@@ -311,7 +320,7 @@
+ #
+ # Linux/PPC
+ #
+-ifeq ($(OS_ARCH)$(OS_TEST),Linuxpowerpc)
++ifneq (,$(filter Linuxpowerpc FreeBSDpowerpc,$(OS_ARCH)$(OS_TEST)))
+ CPPSRCS := xptcinvoke_ppc_linux.cpp xptcstubs_ppc_linux.cpp
+ ASFILES := xptcinvoke_asm_ppc_linux.s xptcstubs_asm_ppc_linux.s
+ AS := $(CC) -c -x assembler-with-cpp
+@@ -389,6 +398,15 @@
ASFILES := xptcinvoke_asm_sparc_netbsd.s xptcstubs_asm_sparc_netbsd.s
-+endif
-+#
+ endif
+ #
+# FreeBSD/SPARC64
+#
+ifeq ($(OS_ARCH),FreeBSD)
@@ -49,6 +56,8 @@
+CPPSRCS := xptcinvoke_sparc64_freebsd.cpp xptcstubs_sparc64_freebsd.cpp
+ASFILES := xptcinvoke_asm_sparc64_freebsd.s xptcstubs_asm_sparcv9_solaris.s
+endif
- endif
++endif
++#
+ # OpenBSD/SPARC
#
- # Solaris/SPARC
+ ifeq ($(OS_ARCH)$(OS_TEST),OpenBSDsparc)