aboutsummaryrefslogtreecommitdiff
path: root/www/flashplugin/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/flashplugin/Makefile')
-rw-r--r--www/flashplugin/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/www/flashplugin/Makefile b/www/flashplugin/Makefile
index ee8036410b62..a455e10ffbb4 100644
--- a/www/flashplugin/Makefile
+++ b/www/flashplugin/Makefile
@@ -23,6 +23,12 @@ MAKE_ENV= OBJFORMAT=aout LIBRARY_PATH=${PREFIX}/lib/aout
PORTOBJFORMAT= aout
ALL_TARGET= libswf.so
+pre-build:
+.if !exists(/usr/lib/aout/c++rt0.o)
+ @${CAT} ${FILESDIR}/message.nolib
+ @${FALSE}
+.endif
+
do-install:
.if !defined(PACKAGE_BUILDING)
@PKG_PREFIX=${PREFIX} ${SH} ${PKGREQ} ${PKGNAME} INSTALL