aboutsummaryrefslogtreecommitdiff
path: root/www/flickcurl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/flickcurl/Makefile')
-rw-r--r--www/flickcurl/Makefile33
1 files changed, 28 insertions, 5 deletions
diff --git a/www/flickcurl/Makefile b/www/flickcurl/Makefile
index 80fa03ebb3e7..17f59a8ae529 100644
--- a/www/flickcurl/Makefile
+++ b/www/flickcurl/Makefile
@@ -2,21 +2,44 @@
# $FreeBSD$
PORTNAME= flickcurl
-PORTVERSION= 1.23
+PORTVERSION= 1.24
CATEGORIES= www
MASTER_SITES= http://download.dajobe.org/flickcurl/
MAINTAINER= ports@FreeBSD.org
COMMENT= C library for the Flickr API
+LICENSE= AL2 GPLv2 LGPL21
+LICENSE_COMB= dual
+
LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
+OPTIONS_DEFINE= RAPTOR DOCS
+OPTIONS_DEFAULT=RAPTOR
+RAPTOR_DESC= Use Raptor to serialize to triples
+
+USES= pathfix pkgconfig
+USE_GNOME= ltverhack libxml2
USE_AUTOTOOLS= libtool
-USES= pathfix
-USE_GNOME= ltverhack libxml2 pkgconfig
+CONFIGURE_ARGS= --with-html-dir=${WRKDIR}/tmproot
USE_LDCONFIG= yes
-CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc
+MAKE_JOBS_SAFE= yes
+
+MAN1= flickcurl.1 flickcurl-config.1 flickrdf.1
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MRAPTOR}
+LIB_DEPENDS+= raptor2:${PORTSDIR}/textproc/raptor2
+CONFIGURE_ARGS+=--with-raptor=2
+.else
+CONFIGURE_ARGS+=--with-raptor=no
+.endif
-MAN1= flickrdf.1 flickcurl.1 flickcurl-config.1
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ @(cd ${WRKDIR}/tmproot/flickcurl && ${COPYTREE_SHARE} . ${DOCSDIR})
+.endif
.include <bsd.port.mk>